Question

Sonos seems to think Sub is a Playbar

  • 25 October 2015
  • 7 replies
  • 822 views

Userlevel 2
I have factory reset every Sonos component many times and still have the following problem. I add the first playbar and 2 surrounds fine (no subwoofer). I add the second playbar, but when I add its subwoofer, it gives me an error saying, "You just tried to add a product that is not a sub." The sub then shows up as if it is an unused playbar, and strange things start happening in the system from then on, such as sometimes being able to control the sound of the second playbar but sometimes not. Like I said, I have factory reset this many times, but I don't know what else to do. any suggestions?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Have you shut down your entire network and everything connected to it and restarted them? All at the same time I mean, not individually at different times.
Userlevel 6
Badge +3
Hi Kobenauf

welcome to the Sonos Community

After you try what The LHC says have a look at this post for more tips.

https://en.community.sonos.com/setting-up-sonos-228990/tips-and-tricks-and-sonos-101-6730704

Les
This is happening to me now- were you ever able to fix it?
Userlevel 1
Badge +1
Hello Jack, This sounds like behavior we have seen before with specific routers. Can you please check the make and model of the router you are using in your home? It would also be helpful if you could submit a diagnostic report from your system to help confirm and isolate the issue. Can you follow the steps here and let us know the number?

If the router you are using is an Technicolor CT2000/CT2100, it may be experiencing an issue where it sees two devices as the same thing. I would suggest taking a look at the settings within on the router’s administration page to confirm if this is the issue. That page on CenturyLink’s website illustrates the settings change needed for that router.

If you’re using a different router, please disregard, and let us know what router you have.
I have one of those Century Link routers. Resetting the router and doing a factory reset on the playbar and sub worked.
I have a CT2100 router and an having the same issues. I tried rebooting the router, factory resetting the player and sub, went to the router network page and made changes as suggested, but nothing is working. I'm at a complete loss as to what to do. The system was all working fine yesterday. If I can't get this figured out soon I'm just going to return everything this system was to bring me enjoyment but it seems to bring me nothing but frustration so far.
I’d recommend running a diagnostic on your Sonos controller app, then getting in touch with Sonos via one of the methods listed on the link at the bottom of this page under “Contact us”. They should be able to rectify any issues you might have by working with you directly.