Sonos Roam, doesn't connect to podcast stream after a pause


The first sonos i started to use is Sonos one. I was really satisfied with this speaker, due to its seamless connectivity to apple tv and apple devices.

Satisfied by the sonos one performance, When i needed to get a portable speaker, decided to get sonos roam, Thinking that it would be the safe bet for a christmas gift this year. 

Less than 10 days after getting the Sonos Roam, I’ve this issue where i pause a podcast in midway and when i try to play it again after a break, my Sonos Roam is unable to be detected by my apple device.

[This detection issue is occuring while my device is not in sleep mode and connected to my wifi. There are no network issues, since i’m able to access the internet through other devices and the single strength is quite strong]

I’ve tried the following, trying to troubleshoot this issue:

  1. Restarted my Sonos Roam
  2. Restarted my Wifi
  3. Restarted my apple devices
  4. logged off and logged back into my podcast app.
  5. switched off the wifi pairing in my phone and restarted it after a while.
  6. I’m well within the range of my wifi router, as the other devices that i use from same room, shows super strong wifi connection, (also i experience the same issue, while i place sonos roam just next to my wifi router)

The trouble that i’ve gone through and the time i’ve wasted so far trying to pair the Sonos Roam to my apple/idevices makes me believe that i’ve not bought the right device for the portable use. I’ll be returning the device back in the store soon. 

Alas, this christmas I’ve not gotten myself the right gift.


15 replies

Userlevel 7

How long is your “break”? Because the Roam will automatically go into sleep mode after 30 minutes of it being idle. If you have Battery Saver enabled, the Roam will shut off completely after being idle for 30 minutes.

How long is your “break”? Because the Roam will automatically go into sleep mode after 30 minutes of it being idle. If you have Battery Saver enabled, the Roam will shut off completely after being idle for 30 minutes.

After the device goes into the sleep mode, I try pressing on the power button for 1-3 secs to activate the device, before try and pair to the device. It is at this point, the pairing doesn’t happen. 

How long is your “break”? Because the Roam will automatically go into sleep mode after 30 minutes of it being idle. If you have Battery Saver enabled, the Roam will shut off completely after being idle for 30 minutes.

After the device goes into the sleep mode, I try pressing on the power button for 1-3 secs to activate the device, before try and pair to the device. It is at this point, the pairing doesn’t happen. 

It’s not entirely clear to me if you are using the Sonos App and a podcast service in the App, but if that’s the case then try switching off ‘WiFi Assist/Calling’ and ‘Private Address’ (MAC spoofing) on the iOS device to see if that resolves the issue.

However, if this is a ‘Bluetooth’ or ‘Airplay’ pairing? ..then are you doing the re-pairing (after sleep mode) from the ‘sending device list’ of Bluetooth, or Airplay, devices, or are you trying to do it by using the Roam speaker buttons?

How long is your “break”? Because the Roam will automatically go into sleep mode after 30 minutes of it being idle. If you have Battery Saver enabled, the Roam will shut off completely after being idle for 30 minutes.

After the device goes into the sleep mode, I try pressing on the power button for 1-3 secs to activate the device, before try and pair to the device. It is at this point, the pairing doesn’t happen. 

It’s not entirely clear to me if you are using the Sonos App and a podcast service in the App, but if that’s the case then try switching off ‘WiFi Assist/Calling’ and ‘Private Address’ (MAC spoofing) on the iOS device to see if that resolves the issue.

However, if this is a ‘Bluetooth’ or ‘Airplay’ pairing? ..then are you doing the re-pairing (after sleep mode) from the ‘sending device list’ of Bluetooth, or Airplay, devices, or are you trying to do it by using the Roam speaker buttons?

I’m not using the inapp podcast serivce, but the podcasts app that is available in apple iphone.

The problem is with the Airplay pairing, I am using the Airplay option in the Podcast app to try and connect to the Roam.

If I use the Apple Podcast app on my iPad and play to a ‘Roam’ (called Voyager) using Airplay, I can play/pause it using the play/pause button on the speaker, or via the options in the iOS control centre.  If I put the Roam to sleep, or let it fall asleep,

 I just use the iOS control centre to link back to the speaker to continue where it left off. 

On the Apple website and forums it mentions these list of things, if you’re having issues with Airplay…

How to fix Airplay 

  • Restart all devices and try to AirPlay again
  • Toggle off Bluetooth, or if already off, try turning it on
  • Turn off Cellular Data
  • Disconnect from any other Bluetooth devices (like speakers)
  • Connect to the same WiFi network access point
  • Reset your network settings on your iDevice in Settings > General > Reset > Reset Network Settings
  • Update iOS, and speaker firmware/software
  • Move your devices away from other electronics and closer to the main router
  • Renew your devices DHCP lease via the router configuration pages or reboot the router
  • Switch off any Security/VPN software installed on the sending (mobile) device

If I use the Apple Podcast app on my iPad and play to a ‘Roam’ (called Voyager) using Airplay, I can play/pause it using the play/pause button on the speaker, or via the options in the iOS control centre.  If I put the Roam to sleep, or let it fall asleep,

 I just use the iOS control centre to link back to the speaker to continue where it left off. 

This is what doesn’t work. Post bringing back the roam from sleep, when i do a airplay stream either from control centre or from my podcast airplay stream option, it fails to connect.

On the Apple website and forums it mentions these list of things, if you’re having issues with Airplay…

How to fix Airplay 

  • Restart all devices and try to AirPlay again
  • Toggle off Bluetooth, or if already off, try turning it on
  • Turn off Cellular Data
  • Disconnect from any other Bluetooth devices (like speakers)
  • Connect to the same WiFi network access point
  • Reset your network settings on your iDevice in Settings > General > Reset > Reset Network Settings
  • Update iOS, and speaker firmware/software
  • Move your devices away from other electronics and closer to the main router
  • Renew your devices DHCP lease via the router configuration pages or reboot the router
  • Switch off any Security/VPN software installed on the sending (mobile) device

I’ve done all the steps (except the last since i don’t have any VPN intalled). Also, I’ve done factory reset of my Sonos Roam couple of times.

I’ve done all the steps (except the last since i don’t have any VPN intalled). Also, I’ve done factory reset of my Sonos Roam couple of times.

It’s all working okay for the Sonos Roam I have here.. Do you perhaps have another iOS device you can try, as it sounds like the issue is related to Airplay? - It’s odd that it connects first time, but not the second?

What does your Airplay list show, or what error message are you seeing when you try to reconnect to the Roam through the iOS control centre?

Also, what type of Wireless network are you using? Is it a centrally based router, or mesh setup? Any other WiFi access points/extenders etc?

If not done this already, it’s perhaps also worth trying the Roam on a different WiFi band, so if it’s currently setup on your 5Ghz band, maybe try it on your 2.4Ghz signal instead and also set that signal to use a non-overlapping WiFi channel, like channel 1, 6 or 11 and cut down on any interference by limiting its channel-width to 20MHz to see if that might improve your Airplay/WiFi connection.

It’s all working okay for the Sonos Roam I have here.. Do you perhaps have another iOS device you can try, as it sounds like the issue is related to Airplay? - It’s odd that it connects first time, but not the second? - I’ve tried both my iphone and Ipad. The result is same.

What does your Airplay list show, or what error message are you seeing when you try to reconnect to the Roam through the iOS control centre? - It attempts to connect, and says “Sonos roam is not available” when i am still able to control the volume in my podcast, using the volume + & - buttons in my sonos roam which is quite strange. 

Also, what type of Wireless network are you using? Is it a centrally based router, or mesh setup? Any other WiFi access points/extenders etc? - its the same wireless network that i’ve connected my Sono’ s one to, which is working perfectly fine for the past 2 years. all my sonos devices are connected to the 5GHZ band.

 

now the issue is that my Sonos roam wouldn’t even turn on, rendering it impossible for me to reset and remap it to a different Wifi band.

 

 

now the issue is that my Sonos roam wouldn’t even turn on, rendering it impossible for me to reset and remap it to a different Wifi band.

You should not need to reset the Roam to move it between WiFi bands, in fact a ‘reset’ is usually only ever a last resort option.. it’s not something you should ever need to do unless perhaps selling-on the device.

To move the Roam to a different WiFi band, you should use the ‘Update Networks’ feature in ‘Settings/System/Networks/Manage Networks’. Just for good measure too you can remove the 5Ghz band too in the ‘List of Networks’ in the same area of the App.

To change to non-overlapping channels/channel-width (as necessary), you will likely need to do that via your router configuration pages. That should then hopefully help with the Airplay communication. 🤞

The Sonos Roam wouldn't even turn on now. it just went from bad to worse too soon.

The Sonos Roam wouldn't even turn on now. it just went from bad to worse too soon.

Perhaps it needs charging? It should power on when it’s returned to its charger, but if the battery is really flat/drained you may have to wait a while for it to power on.

That’s what I initially thought couple of days back and I tried leaving it on charge for the last 2 days, through the night. Yet no luck.

Anticipating the question, I am sending you a picture of my charger.

 
it’s a 5V -3A, the same charger I use for my Chromecast.

I left in on charge through last night as well. (Note, the charger is working, as I am able to charge my iPad with the same charger)

@Ravikumar 
With the Roam off its charger (important) …perhaps try holding the rear power-button for 15+ seconds then return it to the charger and leave for 30 minutes, if that doesn’t solve your issue, repeat the steps one more time off the charger and leave it on the charger again.

If the above steps fail to bring the speaker back to life, then I suggest contacting Sonos Support via this LINK

Hope you are able to get it sorted.👍

Reply