Answered

Sonos Roam / BT Turntable pairing issues

  • 26 June 2022
  • 3 replies
  • 32 views

I have a Sonos Roam that I am attempting to connect to a Project Audio BT turntable. The first time I used it, everything worked perfectly. But now whenever I try to enter BT pairing mode it will connect for a second or two before disconnecting again. I can pair the turntable with other speakers successfully, and I can pair other devices with the Roam, but the two no longer play together properly.

I have already tried numerous factory resets but to no avail. Anyone run into anything like this before?

icon

Best answer by AjTrek1 26 June 2022, 20:34

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

I’m going to hazard a guess here. Did you pair the Roam with some other device, like your phone? If so, you’ll need to turn off the Bluetooth signal on that device so the Roam isn’t latched on to that, and can revert to the connection to the turntable. 

Userlevel 7

Hi

@Airgetlam “hazarded” guess is a real possibility. However, if you have performed a factory reset on the Roam that should have wiped out any previous pairing memory to other devices. That assuming you didn’t pair the Roam to another device before attempting to pair it to your BT turntable.

Therefore, I’d move to the turntable BT stack and have it forget all devices or at least the Roam and try pairing again. Forgetting all devices is comparable to a factory reset for BT.

The joy of Bluetooth….it’s always a bunch of possibilities :)