Answered

Sonos repeating first 10-15 second of song on Spotify

  • 27 July 2021
  • 1 reply
  • 14 views

When I select a song to repeat in the Sonos app, it will play through the first time then on the second time around it only plays the first 10-15 seconds and then restarts. It keeps doing this until i deselect repeat and move on to another song. Seems this has been an issue with others.

 

Diagnostic # 87898677

icon

Best answer by Corry P 28 July 2021, 10:28

Hi @Mazzagatti 

Welcome to the Sonos Community!

Your diagnostics are showing the errors, though there’s no immediately apparent cause. I presume it has to do with networking, therefore.

Please unplug your router, your Google mesh and your Sonos speakers. Once your router has been off for 30 seconds, turn it on. Once the router is online, turn on the Google mesh, and once that is online turn on Sonos and test.

If that hasn’t helped, please try connecting one speaker to the main Google node with an ethernet cable and test again a couple of minutes later.

In both cases, please additionally test sources other than Spotify - is the issue restricted to Spotify only?

View original

1 reply

Userlevel 7
Badge +17

Hi @Mazzagatti 

Welcome to the Sonos Community!

Your diagnostics are showing the errors, though there’s no immediately apparent cause. I presume it has to do with networking, therefore.

Please unplug your router, your Google mesh and your Sonos speakers. Once your router has been off for 30 seconds, turn it on. Once the router is online, turn on the Google mesh, and once that is online turn on Sonos and test.

If that hasn’t helped, please try connecting one speaker to the main Google node with an ethernet cable and test again a couple of minutes later.

In both cases, please additionally test sources other than Spotify - is the issue restricted to Spotify only?

Reply