Sonos Radio issue

  • 21 June 2022
  • 3 replies
  • 31 views

I have a customer who runs a gym and has a Connect connected to his soundsystem. 

He is having regular issues with the mornings alarm not playing the radio channel via Sonos Radio but goes straight to Chime. We’ve tried to change radio stations but the issue is still there. It does not happen every morning but more sporadically, so its hard to track. 

Went there today to do some more testing and we are having problems with radio channels. I tried different services like Sonos Radio, Tunein etc. but none streamed the radio. Added my spotifyaccount to check and that works like a charm. After an hour of tinckering the radio started playing again… =/ 

PC has been restarted, Connect has been restarted, Network is ok (Lots of other stuff connected which has no issues at all) 

 

Diagnostic:1937825018 - Can anyone see if anything is logged here? 

 

Thanks, Jan


3 replies

Have you perhaps tried a different ‘fixed’ non-overlapping router WiFi channel for the 2.4Ghz band? Try channel 1, 6 or 11 and maybe set the channel-width to 20Mhz (if the router allows).

If using SonosNet instead, then in addition to the above, set it’s channel in the Sonos App network settings so it is at least 5 channels away from the chosen router channel above and see if that resolves your issues.

The connect is connected to internet via cable. No other Sonos units than the Connect. 

I’ve seen some users suggest two things to often remedy this…

  • First set a ‘silent alarm’ a few minutes before the primary alarm to wake-up the network devices including the router processor that maybe powered down due to inactivity. 
  • Try moving the primary alarm time forward/backward a few minutes which means the connection to the online service is perhaps not happening precisely on the hour/half hour which is a common time for others connecting to the same service.

See if perhaps those two things might resolve the issue for you.

Reply