Question

Sonos plyer in WIFI not shown in controller

  • 9 January 2017
  • 8 replies
  • 335 views

Hello,

My SONOS installation is compound of :
- A sonos connect, directly connected to my wired LAN
- A SONOS Play 5 which is connected via the SONOS net WIFI

Both players are in the same room, at a distance of about 6 meters.

Most of the time, when I connect from the SONOS Controler, I can see the room corresponding to the SONOS Connect, but not the one corresponding to the Play 5.

If I physically click on the play button, the steam start instantly, with good quality (no lag at all).
After I launched it and the stream start, I can see the Paly 5 now appearing in the controller.

This is really a pain, cause if I can't manage my players from Mobile before physically accessing them, It'will be difficult to managed multiroom, and I have a plan to enhance my installation with many new players for multiroom.

This issue don't look like a WIFI issue, as the stream as qoog quality. It's more like if the player was "Asleep". The only way to wake it up it to physically launch the player with the button, or to power cycle it.

I made the following test, and hope that it can help investigations to solve this issue :
- Step 1 - unable to see the Play 5 from sonos application, only the connect is available ==> Send Diagnostic 6973004
- Step 2 - Launch play 5 by physically clicking on the button. Streaming start immediatly with excellent quallity, but play 5 still not available from the application ==> Send diagnostic 6973009
- Step 3 - Play 5 now available from the application ==> Send Diagnostic 6973015

Could you please provide some support ?

Thanks for your help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Today again, the player disapeared from the application even if it were playing a internet radio. The steamin don't stop, and works perfectly, but I can't contol anymore my player!
Corresponding diagnostic 6985412

I would realy apreciate advice and help from SONOS. I'm really happy with the quality of sound, but such an issue is not acceptebale regarding the price paid for this material. It's useless if I can't control it.

Thanks in advance.
And now, the player is back to the application, but if I click on play, I get the error message "Impossible de se connecter au Lecteur Sonos " =< Impossible to connect to sonos Player :@
New Diagnostic 6985453

Again, physically clicking on the player is ok, and relaunch the stream.
Such error NEVER happend to the sonos connect which is connected to my wired network.
Userlevel 7
Badge +20
And now, the player is back to the application, but if I click on play, I get the error message "Impossible de se connecter au Lecteur Sonos " =< Impossible to connect to sonos Player :@
New Diagnostic 6985453

Again, physically clicking on the player is ok, and relaunch the stream.
Such error NEVER happend to the sonos connect which is connected to my wired network.


It sounds like there's a communication issue between your Sonos units. Please try rebooting each Sonos unit by removing them from power for ten seconds. It may also help to reboot your router.

Also, please try replacing the ethernet cable connecting your CONNECT to the network. Let me know how it goes.
Thanks Jeff for your answer.

I'm going to try what you suggest, but I'm afraid that it could be more than that, because I already had the opportunity to reboot my SONOS multiple time...

Nevertheless, I will try this, to follow a complete testing scénario. I'll send you a feedback in few days, as the issue is not there all the time.

One more quetion : Do you think a factory reset of the play5 could help ? Or do you think I should first try asimple reboot + ethernet cable change ?

Thanks for your help,

Cyril
Userlevel 7
Badge +21
Factory resetting should be left as a last resort and Sonos support will advise when you reach that point.

Far more likely you have network issues or wireless interference.

You may have re-booted individual units but the full process should be to switch off your router, Sonos units AND every item connected to the network (phones, Tablets and so). Then switch router on, wait, Then Bridge/Boost, wait (if you have them), then Sonos units and after the rest of your units.

After that if still poor you will need to explore wireless interference - So find out what channel your router broadcasts the 2,4 GHz network and ensure, in your Sonos app, that you are on a different channel number.
Thanks for Your help.

Here is what I did :

1 - Power off all equipments
2 - Power on My router and for it to be up & running + internet connection OK (There is no built in WIFI activated for this router)
3 - Power on the 24 port switch (this switch is in a by, all wired euipent connected to it, ans no equipment directly connected to the router)
4 - Power on the 2 WIFI AP (both AP connected to the 24 ports switch, one operating the channel 11, the other on channel 1)
5 - Power on the Sonos Connect connected to the 24 port switch with a new cable
6 - Power on the Sonos play 5 (connected via the sonos WIFI apparently on Channel 6)
7 - Power on the phones & tablets

For the moment, everythng is workng perfectly, as it is the case after any sonos reboot. I have to wait few days to see if it is stable.

I'll keep you posted.
Unfortunatly, the issue is back again : Only the SONOS connect is available from the application, the Play5 is not there. Same behaviour from both my Android phone, and my wife's Iphone.
Even if If can't see it from the sonos application, the play5 appears to connected from my router, and I can acces the URL http://XX.XX.XX.XX:1400/status (corresponding to the play5 IP)
I can also ping it.
Userlevel 7
Badge +20
Unfortunatly, the issue is back again : Only the SONOS connect is available from the application, the Play5 is not there. Same behaviour from both my Android phone, and my wife's Iphone.
Even if If can't see it from the sonos application, the play5 appears to connected from my router, and I can acces the URL http://XX.XX.XX.XX:1400/status (corresponding to the play5 IP)
I can also ping it.


It would be best to work with our phone team to get this sorted out. Please give us a call and reference case number: 170111-001602. Our phone number and hours are found here.