Question

Sonos playing wrong song with weird offsets in Folder mode!

  • 27 July 2020
  • 1 reply
  • 50 views

Okay, I have a stumper here I want to figure out. Sonos is playing the wrong song when I click on one!

 

I have a decently large MP3 collection (35k tracks give or take) that I have been maintaining for 20+ years. I’ve been using Sonos to play them for the last 8 of those. I never experienced the following problem until the last month or so.

The collection is loosely sorted into folders of genres, then folders for an artist, then folders for albums. Most of the genre folders and many of the artist folders also have a large number of miscellaneous songs that are not in an album folder.

Usually when I want to hear a song or an album, I go to Browse → Music Library → Folders → (NAS share) → (desired directory) and then I either click the track I want to hear or use the “Play” button in a folder to play a full album. This is much faster than searching the library by names.

I just discovered that for several of the folders, the indexes are off or something and it plays a track different than the one I just clicked!

Example: I have a Blues and Jazz folder. Within that there are 25 subfolders, and 93 other misc. songs.

If I click the first song (listed alphabetically), it plays just fine.
If I click the second song, it plays the first song!

Same for the 3rd.  In fact clicking on any of the first 18 songs plays that first track. Clicking on the 19th song plays the second song (alphabetically) and so on up to clicking on the last track, #93 which will play song #76 instead. So there is some weird constant -17 track offset !! (it can’t play tracks 77 or higher!)

 

So I started testing other directories, and many of them are like that:

My (year) 90s folder: 30 subfolders, 141 misc. tracks: Has a constant -10 offset (#12 → #2)

My (year) 2000+ folder: 52 subfolders, 158 misc tracks: Has a constant -35 track offset (#37 → #2)

My Ambient folder: 93 subfolders, 100 misc tracks: Has a constant -57 track offset

I can’t find any pattern to it. Some folders don’t have the problem:

Artists → Depeche Mode: 14 subfolders, 17 misc tracks: at least a -16 track offset because clicking any of the 17 tracks only plays the first one.

Artists → New Order: 17 subfolders, 52 misc tracks: NO offset!

I have tested this on my Huawei Android phone (S1 app), my wife’s Pixel, and even the Windows-based S1 controller, with identical functionality on all of them. So it’s a problem with the library not the app.

However, if instead of clicking the track (my usual behavior), I right click (windows) or use the three-dot menu (phones) and say ‘Play Now’, it actually plays the correct track!

I tried “Update Music Collection” to no effect, so then I tried removing the NAS entirely from the Music Library folders and re-added it, but no difference (I notice it kept my Sonos playlists despite deleting and reloading the library so I wonder if it needs a more complete reset?)

 

So I’m stumped. This is new behavior or I am really sure I would have noticed before this. I welcome any ideas for troubleshooting this. I’m a former programmer and quite technical so open to trying anything.

 

System Overview:

Sonos Play 1 + Sonos Play 3 + Sonos Play 5 (gen 1), Music library on a QNAP NAS.

The mp3s play normally using any other apps, so doesn’t seem to be a filesystem issue.

Recent changes (unsure if factor): Added the Play 5, a used model from a friend that I factory reset and added to the other two existing units.

 


1 reply

Userlevel 4
Badge +12

Hi @sushihome, welcome to the community, and thanks for reaching out! We really appreciate all the details you share with us and the efforts, but it would be best to Call 800-680-2345 for further troubleshooting and maybe escalate to our engineers since it’s like there’s a pattern on how it’s working. We’re open from Monday - Friday 10 am - 9 pm EST. If you’d need anything please let us know. We’re always here to help. Thanks! 

Reply