Answered

Sonos Patchiness


Badge

Does anyone have suggestions on how to make my Sonos less patchy. I currently have the below setup.

 

Office - Connect (network cable extension from router -> tp-link splitter)

Around 11 feet

Hallway (in between office and living room) - Boost (network cable into router)

Around 20 feet

Play:1 (living room) (wifi)

 

Laptop -> Connect (line in)

 

Currently set as Automatic Audio Compression, but have tried Compressed and Uncompressed myself.

 

When using my laptop using the Connect line in, the Play:1 is so up and down it’s very annoying. Sometimes just stop, play via the app wakes it up, but sometimes it doesn’t. I do live in an apartment so there is other wifi noise, but using wifi detectors, my wifi is generally at least twice as powerful as neighbours wifi.

 

I realise the Connect is not supported anymore, but I don’t really want to upgrade everything, if everything is the same patchiness. I’m currently trying to stay away from getting cables across my hallway to the living room but surely the distances shouldn’t be this painful for Sonos?

 

Would getting a wireless mesh help it?

icon

Best answer by Ken_Griffiths 10 June 2021, 23:25

I will suggest a few quick things, but if you’re not sure what to do here, then you may perhaps want to ask a relative/friend/colleague who perhaps understands some aspects of home networking … the first step is hopefully easy for you to do yourself anyway…

  • I would first move the Sonos Boost from beneath your router and set it well away from the router - I recommend 4 feet away, but many say 2 feet will do, but the further the better in my view.. keep it away from other wireless devices.
  • This is the slightly difficult step… Login to your router configuration pages and set the 2.4Ghz WiFi channel to either 1, 6 or 11 and leave it ‘fixed’ on the chosen channel. You may see the option in the WiFi network settings to also change the channel-width for the 2.4Ghz band - if so, set it to 20MHz only. (This will help reduce wireless interference).
  • I’m fairly sure you will be able to figure out the following steps… Next Goto the network settings of the Sonos App and look-for/set the SonosNet channel so that it is at least 5 channels away from your earlier chosen router channel. (So if you have set your Router’s 2.4Ghz band to channel 6 for example, then set your SonosNet channel to either 1 or 11)
  • In the network settings in the Sonos App, it will likely show you your routers SSID (WiFi name) as a ‘previously used’ WiFi network, I would (optionally) suggest selecting/removing that connection from your Sonos setup (select it to remove) as that ensures your Sonos devices will then not hop between the SonosNet signal and your routers WiFi signal, possibly causing interruptions. The network signal is not needed when running your setup with a Sonos product wired to your router.

Hopefully that will then eliminate the issues you have reported in your post.

HTH

 

View original

3 replies

I will suggest a few quick things, but if you’re not sure what to do here, then you may perhaps want to ask a relative/friend/colleague who perhaps understands some aspects of home networking … the first step is hopefully easy for you to do yourself anyway…

  • I would first move the Sonos Boost from beneath your router and set it well away from the router - I recommend 4 feet away, but many say 2 feet will do, but the further the better in my view.. keep it away from other wireless devices.
  • This is the slightly difficult step… Login to your router configuration pages and set the 2.4Ghz WiFi channel to either 1, 6 or 11 and leave it ‘fixed’ on the chosen channel. You may see the option in the WiFi network settings to also change the channel-width for the 2.4Ghz band - if so, set it to 20MHz only. (This will help reduce wireless interference).
  • I’m fairly sure you will be able to figure out the following steps… Next Goto the network settings of the Sonos App and look-for/set the SonosNet channel so that it is at least 5 channels away from your earlier chosen router channel. (So if you have set your Router’s 2.4Ghz band to channel 6 for example, then set your SonosNet channel to either 1 or 11)
  • In the network settings in the Sonos App, it will likely show you your routers SSID (WiFi name) as a ‘previously used’ WiFi network, I would (optionally) suggest selecting/removing that connection from your Sonos setup (select it to remove) as that ensures your Sonos devices will then not hop between the SonosNet signal and your routers WiFi signal, possibly causing interruptions. The network signal is not needed when running your setup with a Sonos product wired to your router.

Hopefully that will then eliminate the issues you have reported in your post.

HTH

 

Badge

Hi Ken,

Thanks for the reply!
My router does 5Ghz and 2.4Ghz but Sonos is set as 2.4Ghz so that it can be on the same network as my Amazon Alexa, which doesn’t seem to do 5Ghz, so I can chose between the Sonos speakers or that on my phone.

Not sure how to find out the channel width? Is that on my router?

The boost is on the floor below the table the router is sat on, so about 2 and a half foot away.

 

If I do Manage Networks it looks like only the network I’m connected to is mentioned. I presume my Wifi credentials are also stored as I think I did use it at the beginning without any network cables plugged in, but not sure how to confirm that.

The Sonos devices are all running on SonosNet from what you have mentioned  - Do you know what wifi channels are in use for your router (2.4Ghz band) and SonosNet and if the channels are fixed on the router?

The channel-width might be a little helpful too and also how far away is the Boost from your router?

Do you have the WiFi credentials still stored in the Sonos App network settings?

Just need a bit more info. (as above) before suggesting some things to try.

Reply