Sonos optical audio is too quiet

  • 25 October 2017
  • 1 reply

Userlevel 3
Badge +3
My TV's remote is configured to emit the IR signal for the Sonos - it does not change volume on the TV itself. What ends up happening is that when I change the volume using the TV remote, I can see the volume change on the Sonos app - hence it is actually affecting it there. It remains there when I try to play music, which means that Optical Audio is nowhere near as amplified as music sources from the Playbase itself.

I'd love to know why it is that there's so much disparity between the two audio sources? I'm getting tired of my ears getting blasted when I switch to music after watching TV 🙂

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Some TVs have the option to change the output on the optical connection, If yours does, there's likely a setting on the TV's audio that says something along the lines of "Digital / Optical Signal: "Fixed" or "Variable". Generally speaking, if you have that kind of option (and it could be named something extremely different, the key is the "fixed/Variable" part), it is best to set the TV as "Fixed" output. That sets the TV to an appropriate level so that you're getting the maximum amount of data through.

But that being said, there's no guaranty that your TV output will be at the same level as the data coming in from the internet when streaming music. And for better or worse, there's no leveling feature inside the Sonos app to adjust for that.

Hope this at least helps in understanding the issue.