Question

SONOS One stops playing or skips to next song

  • 23 November 2020
  • 2 replies
  • 91 views

Hi,

First some info to better explain the situation: in total we have 5 Sonos One devices and 1 Sonos Play:5 device.

On one Sonos One device I recently noticed that sometimes it just stops playing music or skips to another track. I already tried over WiFi and also connected via ethernet cable. On both options the same problem occured. I also tried changing the WiFi channel in the system setup (1, 6 and 11)

It is also not music service dependant. I have the same issue when playing from Spotify as well as playing from Apple Music. Playing music over Airplay (Apple Music on iPhone) does not have the problem.

Because I tried both cable and WiFi I do not think this can be related to my network. Also because playing over Airplay has no issues. A reset of the device was no success either.

The strange part is: When I combine this specific Sonos One to play with any other Sonos device in my setup it keeps playing without any interruption or skipping issues.

Soemtimes it also says that cannot make any connection to spotify or Apple Music. But at the same time other SONOS devices are seamlessly streaming music from one of both services.

Someone any ideas?

Thanks in advance for the help.

Diagnosis number 142433070

 


2 replies

Userlevel 5
Badge +15

Hi @devosk.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining the issue as well as the step(s) that you did, let me help and try to figure this out.

Upon checking the diagnostic report, there are errors and symptoms of interference detected by the system. I see that one of the Sonos One doesn’t have a cloud connection. These conditions could be caused by 
wireless interference and this article will help you reduce wireless interference around your Sonos products. 

 

I recommend changing the wireless channel on the wireless router (or access point).

NOTE: This may involve disabling automatic channel assignment on the wireless router or access point.

  • Log in to the wireless router or access point that Sonos is associated with through a web browser or through the router/AP's designated App.

  • Change the router/AP's wireless channel to a different channel. If the router/AP uses an automatic channel assignment, it is recommended that this be disabled for this exercise. Ideally, select channels 1, 6, or 11 are the preferred non-overlapping channels.

  • Please wait for 3 minutes and get a new diagnostic.

  • Test it and attempt music playback, or any other activity to Sonos that was previously failing, and see if the problem is now resolved.

 

Let us know how it goes and if you have any questions feel free to reach out, we’re always here to help.

Hi @Annazel S,

thanks for your reply.

I changed the channel of my WiFi to a channel which is least used around. I also deactivated the WiFi on this particular SONOS so it would only connect using the cable which is plugged in but unfortunately both actions had no success. I still have interruptions when playing only this particular SONOS One device (no issues when in group mode).

Another diagnosis has been sent #1012122088

Kind regards,
Kenneth

Reply