Sonos One plays Chime instead of Apple Music

  • 22 December 2021
  • 3 replies
  • 45 views

Badge

I have set up daily alarms that play apple music playlist. It's very flaky. I have noticed that the playlist works during the day. But the first alarm in the morning is failing consistently. It plays Chime instead of the playlist. I have to tap on the play button to stop the Chime. After that it works as expected starting with my next alarm till the end of the day. I have submitted diagnostic information via ticket 1574779059. Can you help?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

While you wait for a forum moderator to look at that diagnostic, in resolved cases like this, the issue has been a failure, at the moment of the alarm occurring, of the speaker being able to reach the server that is specified for the alarm. Again, in most cases, it’s been some sort of issue with wifi interference of some type. Not being familiar with the way the cod is written, I’m not sure how much ‘grace’ time is given to establish such a connection, but as it is an alarm, Sonos does the dosage thing and defaults to the charm.

Something to look at, if you’re not interested in calling Sonos Support directly to discuss it. There are relatively few moderators here, and while they’re excellent when they look at diagnostics, it’s not their primary focus. 

Userlevel 5
Badge +10

There have been suggestions in the past that when the system is not used for a while that various components, routers, switches or the like in some networks go into a power saving mode. The result being that when the Sonos speaker intiates the alarm it takes longer than normal to wake up all the kit along the route which results in the speaker “giving up” waiting for a response and so plays the chime instead. No idea if there is any truth in this but if there is then the simple solution is to set an alarm for a couple of minutes before the requested time; the alarm should use the same source, be of short duration 1 or 2 minutes with a volume level of zero.

 

Badge

Bruce,
 

I thought this issue might have been with connectivity with Apple Music. 
Wi-Fi interference is possible but why only in the morning (after a long sleep)? I do have couple of Ring WiFi extenders but not sure if they would cause interference. I don't have any other devices in or around the room. And the question still remains why only in the morning.
 

Ralpfocus
 

I will try your suggestion of setting alarm few minutes before but at the moment exact time of the alarm is not a concern really.
 

Today morning the alarm worked without any issues. 🤞🏽🤞🏽