Answered

SONOS ONE - Having trouble understanding right now.....

  • 5 November 2017
  • 61 replies
  • 53391 views


Show first post

61 replies

Had same problem. Seems all my Sonos One Alexa's somehow got deauthorized from Amazon which is why Alexa has trouble understanding until it's corrected. Easy fix. Open Sonos app, go to Settings, click on Room Settings. Then pick your first room where Alexa isn't understanding and click on it. Voice Services will show the account Alexa is signed in as - click that, a window opens, then choose 'Remove Amazon Alexa from this room'. Then where your account info was for the same room setting it should say 'Add Amazon Alexa' - press it and follow the prompts to Sign in to Amazon. After signed in, click 'Allow' to reauthorize Alexa on the speaker. Click continue and if you have a second speaker or more, you'll have to 'Allow' each of them to reauthorize. Was pretty easy and I'm back up and running!
I’m unfortunately experiencing the same issue on both of my Sonos One units. It either responds with “Sorry, I’m having trouble understanding right now. Please try a little later”, or simply a beep followed by inaction.
Ok, this worked for me:
Go to the Sonos app and select
< ... More >
< Voice Services >
< Amazon Alexa >
< Room Settings >
Then the problem speaker
Under Voice Services, tap < Amazon Alexa> and

I set up one of my speakers again, and the other one also started working.
Hope it works generally.
Ok, this worked for me:
Go to the Sonos app and select
< ... More >
< Voice Services >
< Amazon Alexa >
< Room Settings >
Then the problem speaker
Under Voice Services, tap < Amazon Alexa> and

I set up one of my speakers again, and the other one also started working.
Hope it works generally.




Thanks, this worked a treat!
Didn’t work for me 😞
Same here, restarting the services does not solve my issue. Also, in my case I have it switched to Spanish language, but I get the error message in English (weird). Any other workaround?
Mine has also just stopped working. It has also changed from English to American
Guys Be Patient.. Don't get Frustrated.. I know that this shouldn't happen but, in my case happened when I updated my Sonos Firmware, so:
Un-link the accounts in both apps , disable Alexa skill and re-add it again, and then authorise the app in the Sonos APP on your phone * (never found the option in my Mac)...
Hope this helps!
Userlevel 1
Badge +2
Yes, it is very frustrating. So far I'm not loving this product. I have dozens of smart home devices, including several Alexa and Google Home devices, and so far this Sonos One has been the most difficult to set up and keep working. But disabling the Alexa skill AND removing voice services in the Sonos app resolved this spontaneous problem. Let's hope this kind of thing doesn't keep happening frequently.
Ok, this worked for me:
Go to the Sonos app and select
< ... More >
< Voice Services >
< Amazon Alexa >
< Room Settings >
Then the problem speaker
Under Voice Services, tap < Amazon Alexa> and

I set up one of my speakers again, and the other one also started working.
Hope it works generally.



This worked like a charm - thank you very much!!

Reply