Answered

Sonos One disappearing from app/network

  • 12 November 2019
  • 23 replies
  • 212 views

Badge +1

I posted on here a few months ago about a connection problem we've been experiencing with our two Sonos Ones. They were originally connected on wifi, and I changed hem both a while ago to be cabled via powerline connectors. They initially seemed to be ok on the powerline connectors but then they started having connection issues again. Playback just stops or they can't be seen on the network.

I did a bit of reading on here and realised that the powerline adapters for the two units are actually on two different ring mains. It was suggested that due this, it would be a good idea to put one back onto wifi so that it could connect to the wired unit by sonosnet. I tried this for a short time, but it didn’t improve things.

Then I thought it would be an idea to disconnect one of the speakers and just use the cabled speaker that's on the same ring main as the router to see if that was stable on its own. The  same problems were experienced just using the one speaker.

Then I thought I'd ditch the powerlines altogether and change and have the one speaker on wifi. When I change the connection from wifi disabled to wifi enabled in the app, even though it thinks about it and then shows the wifi enabled ticked, if I disconnect the powerline network cable, the speaker is lost from the network/sonos app and won't reappear until the cable is plugged back in.

Reading more on the forum, I downloaded inSSIDer to see if we were on a bad wifi channel. It said we would be better on channel 4, so I changed this on the router. I also changed the sonos channel to 6. More reading on the forum, and I decided to set a fixed IP address for the cabled sonos and the WDMycloud drive that has my music library. I plugged th espeaker directly into the router to change the IP, then took it back down to the powerline downstairs. After initially working again, the following day after successfully playing a playlist from Amazon music, when I tried to play something from my library, it lost the speaker on the network again. I checked the router atached devices, and it wasn't showing there either.

This makes me think that we are not getting a stable connection via the powerine units, however I can't work out why I can't seem to switch back to wifi and get it to work without a cable.

Since we've had the speakers (nearly two years) we've had two different routers/broadband providers. Had them initially wifi, then powerlined, and they never seem reliable. I'm fast losing patience with the whole thing and after spending too many hours trying to fix them, and getting wound up by them I am tempted to give up on them. Can anyone help? Would I be best doing a factory reset?

icon

Best answer by Ken_Griffiths 8 December 2019, 12:22

No need to factory reset. I would personally set aside the powerline adapters. It sounds like you would be better off running these devices on SonosNet but try to use non-overlapping WiFi channels… that means setting your routers 2.4ghz WiFi channel to 1, 6 or 11.

i would perhaps try 11 as a starter and ensure you fix the channel so it does not change on reboot etc.

Just as a temporary measure cable one of your speakers direct to your router and set the SonosNet channel in the Sonos App to Settings/System/Network to either channel 1 or channel 6. Its best to ensure that the SonosNet channel is at least 5 channels away from the routers WiFi channel and select the least used channels from 1, 6 or 11 only.

With the speakers now hopefully both showing in the Sonos App also do the following…

  • When running your devices on SonosNet, with one device wired to the main router, ensure you have removed your WiFi credentials in “Settings/System/Network/Wireless Setup”  as they are not required and this will prevent Sonos devices hopping back and forth between SonosNet and your Routers WiFi Signal.
  • If you have any WiFi Hubs, Access Points, or Repeaters on your network, in addition to the main router, then ensure their broadcasting SSID's and WiFi channels exactly match those of your main router. Note: the 2.4ghz SSID name, should be different to the 5ghz name too.

If the setup above works fine and it’s inconvenient to leave a speaker wired to the router, my suggestion would be to purchase the Sonos Boost and use that as the Sonos device cabled to the router instead. Also one further point to note and that is you try to keep the Sonos device cabled to the router at least 4 feet away from the router so it does not interfere with the SonosNet signal.

Hope that resolves your issues.👍 

View original

23 replies

No need to factory reset. I would personally set aside the powerline adapters. It sounds like you would be better off running these devices on SonosNet but try to use non-overlapping WiFi channels… that means setting your routers 2.4ghz WiFi channel to 1, 6 or 11.

i would perhaps try 11 as a starter and ensure you fix the channel so it does not change on reboot etc.

Just as a temporary measure cable one of your speakers direct to your router and set the SonosNet channel in the Sonos App to Settings/System/Network to either channel 1 or channel 6. Its best to ensure that the SonosNet channel is at least 5 channels away from the routers WiFi channel and select the least used channels from 1, 6 or 11 only.

With the speakers now hopefully both showing in the Sonos App also do the following…

  • When running your devices on SonosNet, with one device wired to the main router, ensure you have removed your WiFi credentials in “Settings/System/Network/Wireless Setup”  as they are not required and this will prevent Sonos devices hopping back and forth between SonosNet and your Routers WiFi Signal.
  • If you have any WiFi Hubs, Access Points, or Repeaters on your network, in addition to the main router, then ensure their broadcasting SSID's and WiFi channels exactly match those of your main router. Note: the 2.4ghz SSID name, should be different to the 5ghz name too.

If the setup above works fine and it’s inconvenient to leave a speaker wired to the router, my suggestion would be to purchase the Sonos Boost and use that as the Sonos device cabled to the router instead. Also one further point to note and that is you try to keep the Sonos device cabled to the router at least 4 feet away from the router so it does not interfere with the SonosNet signal.

Hope that resolves your issues.👍 

Badge +1

Thanks for the reply. After reading some other threads on here I’ve already done some of your suggestions. I dispensed with the powerlines, put one speaker cabled to the router and things have improved. I have sky broadband and the sky q acts as a repeater. Initially I changed the router channel, but couldn’t see any way to change the q box channel to match, so I ended up putting the router back on channel 1 (the same as the q box).

I do have a couple of questions - with the speaker that’s cabled, should I disable the wifi on that one? I tried it assuming that it would then talk to the other one using sonosnet, but I’m not sure if that’s correct? I lost the wireless speaker a few days after disabling the wifi on the cabled one, and had to enable wifi on the cabled speaker to get the wireles one to be found again.

Also, after following the instructions on here I still couldn’t see where to remove the wifi password from the speakers.

Things do seem to be a bit better with one cabled speaker, and I agree that it sounds like a Also, I read that a Boost would be a good idea. I’m just a bit loathed to spend even more money when we currently have £400 worth of speakers that spend most of their time making me wound up. I guess I’ll have to try it as the router is up in a bedroom, and I don’t really want a speaker in the bedrooom.

Yes you will need to leave the WiFi switched on on the cabled speaker as that is what is used to communicate with the other speaker. If it’s working now, I think it best you leave if and consider the option of buying a Boost if you prefer to use the bedroom speaker elsewhere.

Badge +1

OK thanks. We’ve had a couple of connectivity issues over the weekend, but I’m not altogether sure that they weren’t caused by other things. If I can get it to be reliable with one speaker cabled, then I’l llook at getting a Boost and put the speaker back where it was. We bought a couple of Amazon Dots to use as a backup, but the sound is nothing like as good as the Sonos (obvious when you think of the cost, I know). The Dot’s just always work though.

OK thanks. We’ve had a couple of connectivity issues over the weekend, but I’m not altogether sure that they weren’t caused by other things. If I can get it to be reliable with one speaker cabled, then I’l llook at getting a Boost and put the speaker back where it was. We bought a couple of Amazon Dots to use as a backup, but the sound is nothing like as good as the Sonos (obvious when you think of the cost, I know). The Dot’s just always work though.

The Sonos speakers should always work too, just ensure your Sonosnet channel is set to either 6 or 11, so it does not clash with your WiFi and sky q fixed to channel 1. You could also consider running your sky q system on the 5ghz band only via the engineers menu options.

Badge +1

Ive just got home and checked the system. We had a lost speaker last night and they were unplugged and plugged back in. Today even though the one next to the router is cabled, they're both showing WM=0 in "system - about my system" page, which I understand means connected by Wi-Fi? They are both working though.
My WiFi channel is 1, sonosnet channel is 6. When I click “system - network” it says “networks, in use, other networks, and my Wi-Fi network name” with a - symbol next to to it. Should I click the “-” next to the Wi-Fi network name to remove it from the system?

Userlevel 7
Badge +21

WM: 0 means SonosNet

You should remove your home WiFi’s SSID to prevent issues.

If you assign static/reserved IP addresses from your router’s DHCP page, the power cycle and update issues may be greatly reduced.

Ive just got home and checked the system. We had a lost speaker last night and they were unplugged and plugged back in. Today even though the one next to the router is cabled, they're both showing WM=0 in "system - about my system" page, which I understand means connected by Wi-Fi? They are both working though.
My WiFi channel is 1, sonosnet channel is 6. When I click “system - network” it says “networks, in use, other networks, and my Wi-Fi network name” with a - symbol next to to it. Should I click the “-” next to the Wi-Fi network name to remove it from the system?

Here are the meanings of the Wireless Modes (WM) for your info…

WM: 0 Device is using SonosNet Mode (Sonos’s own in-built STP WiFi System - (requires at least one Sonos device wired to LAN)

WM: 1 Device is using your local WiFi (with no Sonos devices wired to LAN)

WM: 2 Device is operating as HT surround/sub, (with no Sonos devices wired to LAN)

As your setup has one wired device to your router you can remove/reset your WiFi credentials from the Sonos App in the “Settings/System/Network/Wireless Setup” area, as they are not required when using a wired Sonos device.

I also agree with Stanley_4’s suggestion, it’s a good idea to add the Sonos IP addresses to the routers DHCP Reservation Table, that is definitely worthwhile.

Badge +1

I see, sorry I thought 0 was ordinary Wi-Fi.
 

Ok I've now deleted the Wi-Fi network so we'll see how long it lasts this time.

Thanks for the info.

Badge +1

I have allocated a static ip for the wired speaker, not the wireless one - yet. I don't know why I didn't do them both!

I have allocated a static ip for the wired speaker, not the wireless one - yet. I don't know why I didn't do them both!

Yes, it’s best to fix the addresses of all the Sonos devices.👍

Badge +1

So after being fairly happy that I had one cabled speaker (upstairs), one wireless speaker (downstairs) and that they were connected via sonos net, I was hoping things would now prove to be a bit more stable.

Yesterday, Sonos app on (android) phone updated earlier in evening from playstore.

Sonos was running the previous evening with no problem, playing music from my network music library. Next day initially in "about my system" showed both the cabled (upstairs) speaker and downstairs (wireless) speaker still on the system and connected via sonos net. Tried to get it to play a different album from library, and it can't browse library (error 1002). Tried getting it to play an album on the phone - same error.

Previous album (located on network library) was still showing on sonos screen so hit play, and it carried on playing from where it was the previous evening. Checked "about my system" again and downstairs speaker had now disappeared from the app, but at the same time it was still playing the album from the network music library (that it can't see in the app).

Managed to get an album from the phone to play on the upstairs (cabled speaker), downstairs speaker still missing from system, and still won't play from/browse network library.

Checked with a laptop (connected on wifi). Sonos came up with an update required. Updated it, and when it loaded up, downstairs wireless speaker not showing on there either.

Checked upstairs (cabled) speaker via the app and found it was set as "wifi disabled", changed to "wifi enabled". Wireless speaker still not showing. One of the last things I'd done the previous evening was to remove my wifi network from the wireless speaker - I don't know whether that affected the setting on the wired one?

Unplugged/plug in power to downstairs (wireless) speaker and everythings ok. Music library shows/plays everywhere.

Sadly this is now a typical evening in our house….

andy625,

Did you reserve both your IP addresses in the routers DHCP Reservation Table ? If not then do that. You could perhaps also set them higher up in the subnet to move them out of the way of your other network devices. Example 192.168.0.200 and 201 on whatever subnet you are using. 

See if that helps. 👍

Badge +1

No, haven't had a chance this week. It's currently still just the cabled one that's fixed.

No, haven't had a chance this week. It's currently still just the cabled one that's fixed.

If you get a chance and reserve the addresses of both in your routers DHCP configuration page, I’m fairly convinced it will resolve your issues. 

Badge +1

I hope so I'll give it a go this weekend.

Check for your make/model of router on YouTube and look for ‘DHCP Reservation’ or ‘how to reserve IP addresses’. There maybe a video on how to go about it. It takes no more than a few minutes to do in most cases.

Badge +1

A quick update.

I've now bought and set up the system with a Boost.
In "about my system" everything shows wm0.
Deleted the wifi network from speakers but left both "Wifi enabled"
Static IP addresses for everything.
Initially they normally play music ok including from the library, then after a few minutes I'll try to change the volume and realise that the volume doesn't work, or I'll try to change the music and the local library is not accessible, or I can't add songs to queue
Check about my system - loses one or other speaker, or loses all speakers and boost has no details under it.
Sometimes unplugging the missing speaker, or unplugging everything and replugging fixes it, sometimes comes back on its own.
Yesterday library not accessible from phone, but was ok on my pc (connected via wifi).Later on, nothing was  accessible from either, but I was copying files via the wifi network at the time.
Even though nothing was accessible, and I couldn't change volume, the album I'd selected whilst it was still responding was still playing through one speaker. Tried changing volume and turning music off via the buttons on the speaker, but they just beep and don't do anything. Asked Alexa to stop, and it stops.
Tried changing sonos wifi channel, didn't seem to make any difference.

Even when I stood right next to the Sky Q box in the lounge (wifi booster), it still didn't find anything. It seems to take a while to re-find the system even if I'm in the room with the booster, and even then it ocassionally loses it when in theat same room.

Every time it goes wrong, the Amazon Dots in the same rooms (right next to the sonos speakers) work perfectly.

I now know I have a wifi blank spot in my kitched, despite the router being in the bedroom above, and I suspect the wifi might be the cause of the problems, whereby my phone isn't communicating with the Boost via the router. Does this sound likely?

 

andy625,

Are you using the SkyQ Internet or a different ISP provider/router?, only if you don’t use the Sky service for internet, it is possible to turn off the 2.4ghz band from the hidden engineers menu of the Sky Q boxes, if you perhaps want to google that option as it may not be necessary if sky is not your ISP and you are using a different ISP/Router? Don’t switch off though if you are using the Sky boxes as a mesh WiFi system for your home.

Secondly if you are using the skyQ hubs as a Wifi mesh network then at least go and fix the 2.4ghz Wifi channel on the engineers menu and once that is in place set your SonosNet channel in the Sonos App at least 5 channels away from your main fixed WiFi channel. Obviously do precisely the same WiFi fix with your router if you are using a different ISP, plus make sure that the 5ghz signals don’t clash with SkyQ in that case aswell.

Next, ensure only one Sonos device is wired to the main network router/sky Q hub whichever you are using for your main home internet.

Its good that you have removed the WiFi credentials from “Settings/System/Network/Wireless Setup” leave that like that.

Reserved/Static IP addresses are a good move too and you are correct to leave the WiFi on all your Sonos speakers (that’s needed for SonosNet to work)👍

You could perhaps consider moving your other “Non-Sonos” WiFi network devices onto your networks 5ghz connection, if they are capable and can still connect okay.

Hope the things I’ve mentioned go onto help introduce the network stability that i think you now need to get things working correctly.

 

Badge +1

We are using Sky as the ISP and are using their router, so I’ll leave the 2.4ghz band turned on. I tried looking to see if there was a way of changing/fixing the wifi channel on the TV (booster) box a while ago, but couldn’t see any way of doing it. I’ll have a look for instructions of the engineers menu, wherever they’ve hidden that.

The Sonos Boost is permanently wired to the router, with the two Sonos One’s now both downstairs.

Sky Q Hidden Engineers Menu

In rapid succession press Home, 0, 0, 1, Select (or tap the touchpad on the touch remote). This brings up a hidden menu apparently and I presume you can then fix a WiFi channel ?

Badge +1

I will give that a try later. Thanks.

Reply