Sonos One and Spotify disconnect

  • 14 May 2019
  • 4 replies
  • 162 views

Hi community!
I'm new to this forum so I hope I haven't overseen the same topic..
I have a Sonos playbar (connected via LAN) a Sub and two Sonos One speakers which I use a a home theater. Everything worked fine untill two or three months ago. (Nothing changed in my household). Almost every day the app doesn't recognize the sub and rear speakers (two Sonos One), only shows question marks. Also I can't access Spotify anymore through the Sonos App when that happens. The only workaround is to reinstall the app and restart my Router. Everything works perfect again for a day and all of a sudden the error occurs. I'm not sure if this is related to App Issues (I've read some comments about that) or if any of my settings is buggy.

Thanks for your Help!
Chris

4 replies

Welcome Chris.

There's a couple of potentials, here. It could be simple wifi interference, casued by something that changed outside of your house, or something that changed on its own inside your house. At one point, I had a microwave that started leaking RF, and caused issues in my house when I was using it, and required me to replace it with a new one, better shielded.

The other potential here might be a duplicate IP address issue, which would cause one or more of your speakers to drop off of the LAN. Sometimes they might reconnect on their own, sometimes not. Unfortunately not easily diagnosed by looking at your router. There's a quick fix of simply unplugging all of your Sonos devices from power, then rebooting your router. Once the router comes back up, go ahead and plug back in your Sonos devices.

If that turns out to work, I'd certainly recommend that you look into reserving IP addresses for all devices on your network. It's not an urgent thing, though, but if your router lost track of where it was in the DHCP table once, it's semi-likely to do so again. Reserving IP addresses all arouhd only makes good housekeeping of your LAN, and protects against issues.

But if neither of those suggestions strike your fancy, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and either post the number here, or contact Sonos Support to discuss it. I tend to suggest the phone folks, they have more tools available, but are only available during business hours. Both the Twitter and Facebook support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
Chris86,

The sub and play:1's connect to your Playbar using the internal 5ghz radio cards and the channel is auto selected... it’s possibly some sort of WiFi interference from 5ghz devices nearby, maybe even a neighbours WiFi. I would look for potential interference... do you have any WiFi repeaters or extenders for example? If so make sure they are all using the same 2.4ghz and 5ghz channels as your main router.

Maybe consider switching your router to a different channel in the 5ghz band and then powering off/on all your Sonos devices.

Just as a precaution, though it may not make any difference, I would also just set the SonosNet channel at least five channels away from your routers 2,4ghz channel ... it’s good practice to do that anyway.

And then finally, go into your Sonos App “Advanced Settings/Wireless Setup” and see if you have your WiFi credentials stored in there, if you do, then remove/reset them as they are not required when running your devices on SonosNet, with your playbar cabled to your router.

Hope that resolves your dropout issues.👍
Hey guys. Thanks so much for that quick response!!

My diagnose code: 1358235959

Unfortunately we live in a rented apartment with a provided router that I can't access so if it really is WiFi / IP related I'm screwed 😃 nevertheless I'll try to remove the wifi credentials in the rear speaker settings maybe that helps. I'm just still confused why the app stops to work properly as well in these cases🤷
Well it directly shows the whole system again and it works right now 🙀🤩
Will see if that does the trick now

Reply