Sonos on iPhone drops music when iPhone sleeps

  • 22 September 2018
  • 4 replies
  • 887 views

SONOS STAFF and community: This issue of music dropping and skipping when iPhones sleep has affected both my wife's and my iPhone/Sonos performance for a year or so on various phones and through multiple IOS and Sonos upgrades. I have searched for hours online and on this community and I see that this bug has existed for quite a long time without resolution. I've tried virtually everything that has been recommended and nothing resolves the issue. The only successful work-around is to set the auto-lock to 'never', which is a risky tactic if you don't remember to change it back.

Sonos Staff: Have you been able to recreate this? Can you confirm that this is a Sonos bug? If not, where can we go next. If so, what is being done and how can we help you resolve this quickly? If there is already a fix and I've missed it please post it all over the place so people can find it.

Community: What have you done to successfully resolve this? Are others still suffering from this issue?

4 replies

Userlevel 7
Badge +19
If you are playing music stored on your iPhone then of course it will stop as the iphone will shut down the wifi connection. How is this a Sonos issue?
A wifi connection shouldn't drop when the phone screen goes dark. If it did then Sonos wouldn't work for anyone. With that said, perhaps my understanding or my setup is incorrect. If so I could use some guidance. Should I have Sonos connected to music that's stored somewhere other than my phone?

From the other conversations on this topic, I can see that Sonos has been engaged in attempts to resolve, and provided ideas and feedback that helped some but not all. They've also included bug fixes in the 9.1 upgrade for this issue that didn't work for me and others.
It's Apple terminating the stream, not Sonos. When your phone goes to "sleep", Apple assumes that there's no other connections that are important, and cuts off the streaming from the phone. (note...this is an assumption on my part, but an educated one). I must assume that Sonos is heavily petitioning Apple to not make this assumption, which appears to have been part of the one of the iOS update, for which Sonos has been paying heavily for in these boards. I think, if you instead, use AirPlay 2 to stream to an appropriate Sonos speaker, the iOS system sees that your using an Apple system and keeps the connection open.

You may want to also direct some of your ire to Apple in this particular issue.
Try the following....worked for me. On iPhone open settings/general/background app refresh setting to ‘on’ with at least WiFi and slide Sonos to ‘on’

Reply