Answered

Sonos not working with Spotify??

  • 6 May 2018
  • 8 replies
  • 22751 views

Badge
Hello

Recently my Sonos PLAY:1 has stopped working with Spotify. It started by saying it was losing connection to Spotify completely, now it's now playing broken parts of songs and skipping some completely. I'm using the Sonos app on iOS and using the Spotify iOS app and neither are working, can anyone help?

Also, other people seem to be able to use their Spotify accounts on the same Sonos system with no issues

Thanks
icon

Best answer by Airgetlam 6 May 2018, 22:55

I've got a few suggestions.

First, reboot your router. It's entirely possible it's gotten in a state where it can't actually deal with a request for Spotify. Rebooting it will re-set it to a fresh state.

Once you've done that, try removing Spotify from the Sonos app, then shut down the app completely. Open it back up, and re-install the connection to Spotify.

Next, it's possible that you're having an issue with wifi interference. I'd recommend reading Wifi Interference FAQ

You may also be habing an issue with a duplicate IP address in your local wifi. Try unplugging all of your Sonos devices, then rebooting the router (yes, again...needs to be done while the Sonos are unplugged, we're doing a different thing than what we did before). Then plug in your first Sonos device. If you've got one connected to the router with an ethernet cable, choose that one, if not, just plug in the one physically closest to the router. Wait a minute for that device to fully boot up, then move on to the next one. Be sure to allow enough time for each device to boot before moving on to the next, it's important.

You could also potentially go into your router's DHCP reservation table, and set up reserved IP addresses for your Sonos devices. I had to find my router's manual and read how to do that, you may already know. It solves the same issue as addressed in my previous paragraph.

Finally, if none of that works, I'd recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and call in to Sonos to discuss it.
View original

8 replies

I've got a few suggestions.

First, reboot your router. It's entirely possible it's gotten in a state where it can't actually deal with a request for Spotify. Rebooting it will re-set it to a fresh state.

Once you've done that, try removing Spotify from the Sonos app, then shut down the app completely. Open it back up, and re-install the connection to Spotify.

Next, it's possible that you're having an issue with wifi interference. I'd recommend reading Wifi Interference FAQ

You may also be habing an issue with a duplicate IP address in your local wifi. Try unplugging all of your Sonos devices, then rebooting the router (yes, again...needs to be done while the Sonos are unplugged, we're doing a different thing than what we did before). Then plug in your first Sonos device. If you've got one connected to the router with an ethernet cable, choose that one, if not, just plug in the one physically closest to the router. Wait a minute for that device to fully boot up, then move on to the next one. Be sure to allow enough time for each device to boot before moving on to the next, it's important.

You could also potentially go into your router's DHCP reservation table, and set up reserved IP addresses for your Sonos devices. I had to find my router's manual and read how to do that, you may already know. It solves the same issue as addressed in my previous paragraph.

Finally, if none of that works, I'd recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and call in to Sonos to discuss it.
Userlevel 5
Badge +12
Same here, my diagnostic is:
1881690451
It is happening since last Spotify Android update a few days ago.
Not usable at all.
Big problems with Spotify Connect and Sonos, maybe a Spotify app problem.
I have the same issues after last Spotify app update on all my Android devices.
Badge
I have this problem.

The Sonos One says, "Here is Spotify" then nothing.
If I ask an Amazon Echo the same (in the same house/network) it plays Spotify immediately.
The same is happening to me, it had been going on for a few days, I have tried several things without luck
There's been several software updates since these original posts, so the cause may or may not be the same. I would recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and either post the number here, or contact Sonos Support to discuss it. I tend to suggest the phone folks, they have more tools available, but are only available during business hours. Both the Twitter and Facebook support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
Badge +1
My Sonos-app skipped to next song over and over without playing at all.
Spotify worked fine on all other devices in the same network.
We have not been able to play Spotify for a week through our Sonos-hardware.
We live in Sweden.

This is how I solved our problem:

  1. I logged into our router and saw all 4 sonos devices in the mac-lease list.
  2. I examined our DHCP-server settings and saw that I had not set any DNS-server, in this scenario the DHCP-server set the router itself as a DNS-server.
  3. I changed the DNS-setting to 8.8.8.8 which is the Google DNS on the internet.
  4. I deleted all MAC-leases to my four SonosZP, in fact i deleted the whole list, forcing all devices to reconnect.
  5. After approx ca 30 seconds all units had connected againand received new MAC leases/ip-numbers. And most important they all got the new DNS-setting 8.8.8.8.
  6. Now finally the sonos could connect to spotify and play again.
I interpret this that the sonos app had stored/cached an old ip number to the spotify server. Perhaps Spotify here in Sweden changed the ip of their server a weeks ago?

Perhaps Sonos should add some sort of ping or name lookup service to all added services in the sonos app. If there is no Connection to one of the Music services the could present an error message like "The Music service "Sonos/10.43.212.182" is not answering. Please contact your 3rd party supplier.
They kind of do, on the side of this forum, it's called View real-time service status, which is just a link to

https://status.sonos.com/

I suppose your request is to add it in to the controller application, as well? I guess they could just send a request over to the 'default' browser on the device....

I wouldn't expect this kind of thing to be high on their priority list. It wouldn't help sales of their speakers any.

Reply