Question

Sonos not working with my Plex Server

  • 1 June 2019
  • 1 reply
  • 107 views

I can't get Sonos working with my Plex server. It was working for months, I don't think I made any changes, and now it won't work.

I tried setting up a second Plex Server on my network and that one doesn't work either. I can, however, get music playing from severs that have been shared with me so it certainly seems to be something specific to my network but I have no idea where else to go with my troubleshooting.

I posted on the Plex forum and was totally ignored so I'm hoping someone here can assist me.

When I try to play the steam I can see the network traffic hit my server so I assume all the ports are open correctly. I can see in the sonos controller talk to my Plex when I have debug logs enabled and I can stream everything with the Plex app itself. Not sure what else I can do.

Any ideas?

(Note, I have NAT reflection enabled and have added plex.direct as an exclusion in my whitelist for rebind protection).

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

I have tried in vain to get Plex working on my Sonos. It just doesn’t work. I recently bought a Synology DS218+ for the express purpose of being able to stream my personal music library to the Sonos. Now after the fact I see it doesn’t work and that many others also say it doesn’t work. Sonos needs to stop pushing Plex until they can work out these bugs.