Sonos not working since Sky q upgrade

  • 24 September 2017
  • 1 reply
  • 1057 views

I have been pulling my hair out past few days over what seemed like an easy fix that just would not work.

I was directed to my netgear switch which I know supports spanning tree but Sonos advises my switch is not compatible which could be the cause of the problem but never had the issue with the switch until sky Q was installed.

Couldn’t find any advice on here relating to a similar issue and I followed all the options I had seen without a solution.

Turns out there was a recent upgrade to SKY Q box software enabling Powerline networking even though my boxes are Ethernet connected Powerline is On by default as some sort of backup but it does not support spanning tree and has in fact created some sort of strange network loop. Wireless devices connect to the Sky Q box as a hotspot and then try’s to connect to the router by Powerline instead of the Ethernet via the switch.

Solution:
Go to your sky Q box go Home, then scroll down to settings (don’t enter just highlight it) push 0,0,1 then select button. Enables engineer mode, turn off Powerline and or any WiFi if you don’t need it......for instance I have a mini box in the same room as my router so no need for extra hotspot.

Voila system back working and all sorted.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 4
Badge +3
Excellent info. Thanks for sharing 🙂