Sonos no longing connecting to NAS

  • 27 October 2018
  • 8 replies

Hi. Don't know if anyone can offer any advice. Out of the blue songs stopped connecting to my Drobo 5N where my music is stored. I can see my library in the controller on my Mac laptop and phone but when I try and play anything I get an error message: Unable to play '(song title.m4a)' - unable to connect to //Drobo5N/Media.

I have followed the suggestions posted elsewhere: Switch off router. Switch off Sonos. Switch off anything else on network - including Drobo. Then re-booted router, added Sonos and then switched on Drobo. There was no difference - Sonos controller still cannot access the files. Other material on the server is instantly available so no issues with that.

I have checked system preferences to ensure the Firewall is allowing access and that seems good, o running out of thoughts as to what is causing the problem. Grateful for any thoughts.

Best answer by Stanley_4 27 October 2018, 21:26

There is another discussion on the Drobo around here recently, I think the fix there was to use the IP number, not the name to connect to it.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +21
There is another discussion on the Drobo around here recently, I think the fix there was to use the IP number, not the name to connect to it.
Hi Stanley_4. Many thanks for your reply - it worked! I did as you suggested and, this morning, after the music library update had completed, everything appears back to normal. Tank you for the solution and taking the time to respond to my question.
I have same issue, update Drobo5N2 with current firmware 4.1.2 and Dashboard 3.3.0, used IP number to connect worked great for most of the day. Stopped music for several hours and now Sonos unable to locate music files, say no longer availible however itunes and Audirvana Plus are able to connect without issue. Dashboard still shows Music share still connected. Issue must be with Sonos
Userlevel 7
Badge +21
Duplicate pwalsh2 post below. Please don't double post the same issue no matter how confusing the forum software makes things for new posters.
Well 24 days later Sonos will not connect again to Drobo5N2! Nothing changed IP address still same but will not play/connect! This is getting old!
Just found a Sonos update maybe they fix problem
Userlevel 2
Hi Community...I'm having the same problem. Suddenly, shortly (but not immediately) after updating the firmware on my Drobo5N2 (to 4.1.1-13.40.108863) my Sonos stopped being able to see the network drive. I see the notes about connecting via IP address, but can't find instructions on how to specify the drive location by IP versus network path. The Sonos app only seems to welcome the latter. Would be grateful if someone could point me to instructions.
Did you read Stanley_4's answer above?