Question

Sonos music disconnects, won't connect, playback issues and app very slow to change songs

  • 23 January 2018
  • 2 replies
  • 325 views

I just bought two sets of sonos speakers, 2 play 1s 5 ft from my router (50Mbps) and one play 5 roughly 20ft from my router.

Sonos app constantly cannot connect to the speakers, primarily play 5. the app works better when only connected to the play 1s. i get all sorts of errors when trying to play music or podcasts while connected to either. the app is very slow and sometimes just wont connect to the speakers. sometimes the song will play and cut out. some times i cannot play another song and the app shuts down. I get tons of errors (connection was lost, network connection speed insufficient to maintain playback buffer, unable to play the selected item, unable to play - unable to connect to service). The wifi at both locations of the speakers is great (i can stream HD movies instantly with no issues in either location). all products are updated

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Diagnostic 8396099
Userlevel 7
Badge +26
Hi colelevin, looks like that diagnostic was submitted when your controller wasn't connected to the players. I'd suggest starting with closing the app, and reopening it. When that's done, check if your players are listed. If they are, can you check for updates? There's one that just came out.

If you're still having trouble after the update, can you send a new diagnostic?