Sonos Move and Netgear Nighthawk Mesh


Hardware:

1 x Sonos Move, 2 x Sonos Play:1, 1 x IKEA SYMFONSIK

Netgear Nighthawk Mesh, with 1 x MR60 (router) and 2 x MS60 (satellites)

 

Interaction between a controlling device (iOS device, e.g.) and the Sonos Move:

  • If a controller and Sonos Move are attached to the same MS60 (mesh satellite), the Sonos app on the controller CANNOT see the Sonos Move.
  • If a controller and Sonos Move are NOT attached to the same MS60 (mesh satellite), the Sonos app on the controller CAN see the Sonos Move.

The other Sonos devices are always visible to a controller, regardless of mesh device association. 

 

This is consistently reproducible, and persists beyond repeated full resets of the Sonos Move. 

 

HELP!


18 replies

Hi All,

 

I have the same issue – but in my case I have just two Sonos One’s – the situation I have

is that only one of them can be seen from the Satellite’s (MS-60) on the mobile app – desktop app

is fine - it can see both. If I move into the main room where the hub (MR-60) is then

the mobile app can see both. Absolutely consistent and repeatable.

 

Also just to note if relevant that one of the Sonos One’s is 1st Gen and one is 2nd Gen.

 

I can see from the network info that the one that “disappears” is connecting via

5GHz (to one satellite) and the one that’s visible everywhere is connecting via 2.4GHz (to the other satellite). Suspect this is the issue. I can’t see how to force the Sonos speakers to use one network or the other though?

 

Is there a firmware upgrade that will help per the post above, and I so what version?

 

Cheers,

 

Martin

To all other on this thread. 
I have just tested a development firmware and it seems to work. 
Finally !!!!!!!!

So, is there a firmware update coming soon that will solve this problem?

Badge

To all other on this thread. 
I have now been in contact with netgear support (equals at least 10-15 hours in total during many nights) beyond the “no expert knowledge” and a solution is on it’s way. 
I have just tested a development firmware and it seems to work. 
Finally !!!!!!!!

@pihrm thanks for your reply. 
hmmmmm it just can’t be right. 
And I believe there must be some kind of a sonos bug that they have to fix since it is working with all other sonos devices. 
After my reply to you I discovered that it all varied depending of which sattelite or router my phone was connected to. 
your Nighthawk system (when you had it) where the sattelites cabled or connected wireless?

And if wireless, where both sattelites connected to the router or were one of the sattelites connected through the other sattelite?

hope it Makes sense 😊

 

Regarding my former Nighthawk system, both satellites were connected directly to the router. Neither satellite was connected via another satellite.

As for your discovery about the Sonos Move problem appearing, based upon which satellite or router your controller (phone) was connected to, that directly mimics my experience as described in original description of this post.

Badge

@pihrm thanks for your reply. 
hmmmmm it just can’t be right. 
And I believe there must be some kind of a sonos bug that they have to fix since it is working with all other sonos devices. 
After my reply to you I discovered that it all varied depending of which sattelite or router my phone was connected to. 
your Nighthawk system (when you had it) where the sattelites cabled or connected wireless?

And if wireless, where both sattelites connected to the router or were one of the sattelites connected through the other sattelite?

hope it Makes sense 😊

Hi hvidegaard,

I experienced the identical issues with the Move that you describe. 

However, I now have a fully functional environment, including a mesh wifi network AND Sonos gear AND new Apple HomePod Minis (which also mesh) PLUS additional new 2.4GHz Apple HomeKit equipment. 

I dumped the dual-band Nighthawk mesh, and replaced it with a tri-band Orbi mesh. I got them both at a store called Costco, which is amazing with returns. So I took back the Nighthawk, and bought the Orbi model RBK753S. These are both Netgear products. The tri-band feature was critical to success.

Badge

Dear pihrm

I am very curious since I have the exact same problem having the same netgear mesh system and sonos move. 
My “old” s1 system operating on the sonosnet works perfectly. 
Since buying the move and moving my s2 system to wifi it has been a very bad user experience. 
have you talked to sonos?

A strange observation, the move isn’t visible as part of my system in the S2 app. 
Move is connected to the wifi and can Stream and play the songs in the queue using the touch button on the device. 
If I turn off the power of move the device is suddenly visible in the app with status “offline”. 
when I turn on the power again it connects and then disappear from the app !?!,

So - the app has “connection” to the device. Knows it is no longer Off-line but doesn’t show the speaker ???? What is going on?

Sorry for my language skills. I am not native. 
Best regards

Peter

2.4GHz and 5GHz are indeed using the same SSID. And for my home situation, given the user base, and the dozens of unique devices which operate perfectly fine in that mode, I won’t be changing my network for effectively a single troublemaking device.

Choice is clear. Dump the Sonos Move, and move on.

I appreciate all the suggestions and feedback. Thank you.

Ah, Sonos Move can’t do SonosNet. So no, a Sonos Boost wouldn’t help.

Yes that’s where the issue appears to lie, as the Move doesn’t connect to SonosNet, so possibly the easiest way to perhaps resolve the matter is to ensure the 2.4Ghz and 5Ghz WiFi bands are individually/uniquely named ...and to perhaps just check if all the wireless access points are using the same WiFi channels/credentials and can handle SSDP multicast broadcasts over UDP. 

Ah, Sonos Move can’t do SonosNet. So no, a Sonos Boost wouldn’t help.

 

Would throwing hardware/money at this problem, via a Sonos Boost, likely make it all Just Work?

Is there authoritative Sonos support documentation which states Sonos equipment may not work properly on a mesh network?

pihrm

I understand that the Sonos Controllers use SSDP multicasts (the UPnP discovery protocol) over UDP to discover the Sonos players. Both the Sonos players and controllers must share the same network subnet. However if the Sonos devices are connecting to multiple access points, the recommendations are that they be set to the same WiFi channel. This is for optimum performance particularly in groups and for some reason with mesh systems it appears some will work okay with Sonos, but others may not, particularly if the satellites are perhaps auto-selecting their own WiFi channels and to solve any issues arising, many here (myself included) often suggest using SonosNet for Sonos device discovery/communication instead. 

The issue we appear to have here, is the main Sonos Household is working okay on SonosNet with the mesh connected subnet, but it appears the SSDP multicast broadcasts are not (always) getting through to the Sonos Move device’s in the Household, which (obviously) cannot be connected to the SonosNet signal and which clearly connect to the WiFi over the mesh satellite signals. I was therefore suggesting it might be best if the satellites in the mesh setup were all operating with the same settings/channels as the main Nighthawk router. It appears that by default they are, but I suspect the SSDP broadcasts are not working (being forwarded) as they should be here when the controller is connected to one access point and the 'Move' is connected to another

It’s my thoughts that it might be a router or access point issue and it might perhaps be best to speak to the Netgear support desk to see if they can maybe suggest any router, or access point, settings/port forwarding that may help to resolve the issue.

If Netgear do suggest changes, it would be interesting/helpful to know the outcome back here also for future reference.

Userlevel 7

This probably adds nothing by way of a thumbs up for a Mesh network. Full disclosure my network is an Asus AiMesh using three (3) Asus tri-band routers with Ethernet back-haul. Here’s my point…

I’m not convinced that mesh networks are ideal for Sonos or even a good idea. Mesh networks are intended to provide better whole home Wi-Fi coverage by-enlarge for single point connection devices. Cell phones and tablets while mobile can adjust very quickly to different nodes as one moves through their home.  

Tablets and PC’s as consumption/work devices are usually at one point during the majority of their use by individuals. Typically tablets and PC’s are used in a seated/lounge position or on a desk respectively...connected to a single node.

Sonos is a multi-connection product. Each product when in Wi-Fi (wireless) mode connects to the closest node in range given their relative placement in the home. Therefore, in a mesh network environment it is critical that only the main node have DHCP capability and all nodes broadcast on the same channel. Turning off Airtime Fairness can also be an important factor not just for a mesh network but single router/modem configurations. Of course there are other factors to consider...too many to mention.

So how is my Mesh network better than any other….bottom-line..it isn’t. My Mesh network performs as it should providing excellent whole home Wi-Fi coverage and extending (via Ethernet backhaul) my one (1) gigabit ethernet to each router providing said throughput to devices that can accept a wired connection.

My Sonos on the other hand is in wired (boost) mode using a Sonos Boost module connected to the main node. Other Sonos speakers in close proximity to one of the other two routers are wired as well to boost the SonosNet. 

IMO to avoid Sonos connection issues in a mesh network environment one should either wire a Sonos speaker/component (except a surround or sub) or invest in a Sonos Boost module. In truth...wired mode (SonosNet) can also resolve issues in a traditional home network.  As I said JMO….so take it for what it’s worth.  

Cheers!

For those in the US...Go Chiefs!

 

 

  

I can find no option to force the satellites to broadcast on the same channel as the router. However it appears this is default behavior, as the option to change channels is global for the entire mesh, not router/satellite specific.  

Those workarounds do not appear to be configurable options on the mesh system.

Not sure if this applies to your particular router/hubs, but perhaps see if this video may assist you.

 

Those workarounds do not appear to be configurable options on the mesh system.

Are the mesh satellites/hubs broadcasting on the exact same channel as the main router or do they auto-select their channels? If the latter, I would perhaps try to fix the channel and ensure they exactly mirror the channels of the main router and see if that solves the issue. If the problem persists, then you might have to consider ‘blacklisting’ both a controller and Move, so they remain connected to one access point only, but perhaps keep that option as a last resort.

Reply