Answered

Sonos mobile app unable to connect to music library (a file share).

  • 23 May 2019
  • 6 replies
  • 205 views

Error: "The computer [name] is not responding"

Note that, from the same cell phone; I was able access the file share using CX Explorer via the intranet wifi. I could also access the share from another PC over intranet wired network; all using the same share path and user credentials.

Hence it seems that this is neither a firewall, user permissions, nor a network /wifi issue.

I have also tried to restart my phone; as well as reinstalling the Sonos mobile app. Additionally, I have tried using a different phone - same issue (so it is not particular to my phone).

The file share is hosted on a Windows 10 (1809) PC.

Logically this seems to points to the Sonos app. Is this the culprit?

Anyone else having the same issue? Is there a fix?

Thanks for your time!
icon

Best answer by KK_Sonos 24 May 2019, 17:12

Hi Jeff, thanks! Not sure if you have missed my message from above, but the issue had absolutely nothing to do with firewall /antivirus. Indeed, the solution is to enable the Windows 10 feature, namely "SMB 1.0/CIFS File Sharing Support".

At the Windows 10 PC, go to Control Panel -> Programs & Features -> Turn Windows Features ON or OFF -> Checked the box for "SMB 1.0/CIFS File Sharing Support" to install the feature -> Restart PC

Hope this helps other users. Cheers and thanks again!
View original

6 replies

Userlevel 7
Badge +20
Hi KK_Sonos,

Are you able to access the music library from the Sonos app on your computer? If not, try removing the share and rebuilding it. This should fix any folder permission errors there may be. If you get the same error, it's probably a firewall or antivirus issue preventing your speakers from accessing the computer. You can try going through the firewall and antivirus setup again, as sometimes these settings can change with a program update.

If that doesn't help, please submit a diagnostic report and reply with the confirmation number.
Hi Jeff,

I have tried all of the followings, issue persisted.

1) Remove and then recreate the share.

2) Installed Sonos windows controller on the Windows 10 PC. In this case the shared folder is on the same machine as the Sonos windows controller. The setup did open up the Windows Firewall required by Sonos. I was able to see all my speakers from the Sonos windows controller; however when I tried to add the library (share); I got the same message that the computer is not responding.

Again, I am still able to access the share with the same credential from another PC, and from my cellphone (using CX explorer). Only the Sonos application has the access issue.

Diagnostic report sent. Confirmation number is 1147600937.

Many thanks!
Hi Jeff, I have found the culprit. Here is the solution for you to add to the knowledge base:

At the Windows 10 PC, go to Control Panel -> Programs & Features -> Turn Windows Features ON or OFF -> Checked the box for "SMB 1.0/CIFS File Sharing Support" to install the feature -> Restart PC

Many thanks!
Userlevel 7
Badge +20
Thanks for the report. The report doesn't show much information about your computer as it was sent from your Android controller. The not responding message is generally caused by firewall or antivirus settings. If you've gone through the settings and rebuilt them, it would be best to continue troubleshooting this issue live with our phone team. Please give us a call, our number can be found here.
Hi Jeff, thanks! Not sure if you have missed my message from above, but the issue had absolutely nothing to do with firewall /antivirus. Indeed, the solution is to enable the Windows 10 feature, namely "SMB 1.0/CIFS File Sharing Support".

At the Windows 10 PC, go to Control Panel -> Programs & Features -> Turn Windows Features ON or OFF -> Checked the box for "SMB 1.0/CIFS File Sharing Support" to install the feature -> Restart PC

Hope this helps other users. Cheers and thanks again!
Userlevel 7
Badge +20
Hi Jeff, thanks! Not sure if you have missed my message from above, but the issue had absolutely nothing to do with firewall /antivirus. Indeed, the solution is to enable the Windows 10 feature, namely "SMB 1.0/CIFS File Sharing Support".

At the Windows 10 PC, go to Control Panel -> Programs & Features -> Turn Windows Features ON or OFF -> Checked the box for "SMB 1.0/CIFS File Sharing Support" to install the feature -> Restart PC

Hope this helps other users. Cheers and thanks again!


Thanks for the update. I posted before refreshing. In effect, having the sharing protocol inactive on your computer results in the same behavior as if the firewall prevented the connection between your Sonos system and computer. It's good to hear that things are working for you now, though.

Reply