Sonos keeps skipping to next track. Unusable.


Userlevel 2
I submitted a diagnostics report 3124711 after yet another track skipped with about 3 minutes left to play. My Sonos system is now pretty much unusable for anything but the radio (and I have a DAB, thank you). Please tell me how to sort this out.

163 replies

Userlevel 5
Badge +2
Hello Matt,

When playing tracks, are they stored on your Mac or on a NAS drive? For either one, how is the device (Mac or NAS) connected to your home network?

And just to clarify, Sonos works fine with the Radio functionality, correct? It doesn't sound like it's cutting out at with any other sources.
Userlevel 2
Hi Thanks for your reply. I have a NAS drive hard-wired to a Sonos bridge, which is wirelessly connected from a room upstairs to 2 x Sonos Connect and 1 x Sonos Connect AMP downstairs. The wireless channels are at opposite ends of the scale (although I think they are on 2 and 10 rather than 1 and 11). The radio occasionally cuts out, and the sound also cuts out playing line-in signals going into the Sonos Connect devices. The radio isn't as bad as the other sources, which are pretty much useless.
Userlevel 5
Badge +2
Okay. Based on that description and the diagnostic, it looks like Sonos is failing to transmit data reliably from the BRIDGE to the other units. This could be from intermittent interference on this channel (11) or from another wireless device broadcasting nearby. Would you mind changing Sonos to channel 6 and testing for a bit? I'd like to see if the wireless failures are occurring on channel 11 only. Once it's been running for a bit, please submit one more diagnostic report and I'll have a look (particularly if it cuts out again).
Userlevel 2
Ok, thanks. I'll switch them over when I get back from work tonight.
Userlevel 2
Hi, this problem is still occurring, and on Friday evening (I think) I noticed some terrible distortion when trying to play tracks from the music library. I submitted diagnostic reports immediately after that happened, and a few more after various skipping problems that we experienced in the last few days. On another thread I read that a support ticket (130815-000982) has been opened for this problem, but I've heard nothing. I appreciate that software will never be perfect, but this is FAR below the quality I would expect from equipment with as high a price tag as Sonos carries. I'm fairly unimpressed, to be honest. If you can't sort this out I think I'd like a refund.
Userlevel 5
Badge +2
Matt, thank you for the additional diagnostic. The system is looking good on channel 6, but obviously the issue is still occurring when trying to play music from your NAS. The ticket you cited was created for another user, which is why you did not receive any email. However, I would like to make a ticket for you specifically so we can get further details on your current system. The ticket will be under 130819-000988 and I will be sending an email shortly. We can then continue troubleshooting this issue with you. Thanks.
Same here with Sonos skipping to the next song while in the middle of playing one. It skips whether I'm playing from my NAS, directly from my iPad, Songza and Internet radio. I've rebooted all equipment, reset my Bridge and synchronized all components, deleted my iPad app and reinstalled, which required me to set up the connection again to my Bridge. Nothing helped. I listen to my Sonos almost everyday and this just started in the last 1-2 days.
Userlevel 5
Badge +2
Same here with Sonos skipping to the next song while in the middle of playing one. It skips whether I'm playing from my NAS, directly from my iPad, Songza and Internet radio. I've rebooted all equipment, reset my Bridge and synchronized all components, deleted my iPad app and reinstalled, which required me to set up the connection again to my Bridge. Nothing helped. I listen to my Sonos almost everyday and this just started in the last 1-2 days.
Since this is happening on all different sources, then it sounds like the Sonos components are not maintaining a decent connection to each other. This could be from wireless interference or possibly a troublesome wired connection to the router. The next time the system experiences a dropout, please submit a diagnostic by following the steps in this FAQ. Let me know what the confirmation number is and I'll be able to provide some more information. Thanks.
Userlevel 2
I'm having a similar problem - starting about 3 days ago, the system can't reliably hold a track. Goes for all feeds: radio, Pandora and Rhapsody. I've reset the router and bridge repeatedly and it's good for 1 track or so, then looses it. I read the recommendation about changing channels, but that doesn't seem to be an option on Sonos iGadget apps
Userlevel 5
Badge +2
Hello, You're correct, the iOS devices are unable to change the wireless channel on Sonos. This can be done using a Sonos Desktop Controller for PC or Mac. Would you mind sending a diagnostic report from your Sonos system? I can take a look at the state of the Sonos wireless network and let you know if a channel change is needed. You can find out how to submit a diagnostic report here. Thanks.
I was away for the weekend and when I got back everything seemed to be working fine. I'll do the diagnostics if anything else comes up.
Okay - I would also like to join this thread and say that my Sonos keeps skipping and cutting out! This is unacceptable from sonos and is making the system pretty much unusable. I spoke to a sonos rep and feel pretty fobbed off and say my tracks have not copied over properly to the nas is nonsense since I have also tried to play from the laptop and the same probs still occur. I have spent a huge amount of money on this system and sonos cannot seem to solve the problem! Please please somebody from sonos help me!!!!!!!!!!!! From a very disgruntled customer
Okay - I would also like to join this thread and say that my Sonos keeps skipping and cutting out! This is unacceptable from sonos and is making the system pretty much unusable. I spoke to a sonos rep and feel pretty fobbed off and say my tracks have not copied over properly to the nas is nonsense since I have also tried to play from the laptop and the same probs still occur. I have spent a huge amount of money on this system and sonos cannot seem to solve the problem! Please please somebody from sonos help me!!!!!!!!!!!! From a very disgruntled customer
Also diagnostic just submitted 3158573 from when it has skipped twice tonight!
Userlevel 2
Thanks for the reply and sorry for the lag. Turned out the problem was a bad cable connection the bridge and router. Replaced it, and all's good 🙂
Userlevel 5
Badge +2
Okay - I would also like to join this thread and say that my Sonos keeps skipping and cutting out! This is unacceptable from sonos and is making the system pretty much unusable. I spoke to a sonos rep and feel pretty fobbed off and say my tracks have not copied over properly to the nas is nonsense since I have also tried to play from the laptop and the same probs still occur. I have spent a huge amount of money on this system and sonos cannot seem to solve the problem! Please please somebody from sonos help me!!!!!!!!!!!! From a very disgruntled customer
Hello, thanks for submitting the diagnostic report. Right now it looks like Sonos is only looking at your PC for music and is not currently looking at the NAS's shared folder. The recent errors correspond with Sonos trying to maintain a connection to the PC when playing music. The local Sonos network looks great, though, which is excellent. At the moment, is the PC connecting to your router via wireless? Or is it wired in to the network? I'd also like to know if your wired Sonos component is plugged straight in to the router or if it's plugged in to something else first (like a powerline adapter). Thanks!
Userlevel 5
Badge +2
Glad to hear all is well! Let us know if you have any additional questions and we'll be happy to help further.
Userlevel 2
I am rapidly losing patience on this issue. Last night I must have had something like a 2/3 to 3/4 dropout rate on tracks. It is simply not acceptable for equipment with this sort of price tag. I waited for a call from your technical support yesterday (having asked for one) and received nothing - not even a reply to the emails I sent yesterday.
I'll add to the thread having the same issue. Haven't tried to replace cables or change broadcast channels but seems odd that so many similar issues are being reported. Has there been a recent software push that could be affecting? About the same time this connectivity issue started I had one of my ZP100s begin powering down sporadically. I have to reboot it to reconnect then next day it's off again. I've been a very happy Sonos customer for years and invested heavily, expect this will be quickly resolved but frustrating.
I am also having the same problem. I have a basic modem -> bridge -> player set up and it is pretty much unusable at the moment due to constant track skipping and dropouts. I also find the software regularly freezes when I'm using it (basically my entire computer will be frozen including the cursor for 5-10 seconds) and I am often getting an 'unable to browse music' message (all the music is stored on my laptop). Have done all the recommended restarts / channel switches etc etc and nothing has helped - very frustrating as I use my Sonos every day... I have submitted a diagnostic 3159617, please help!
Userlevel 5
Badge +2
I am rapidly losing patience on this issue. Last night I must have had something like a 2/3 to 3/4 dropout rate on tracks. It is simply not acceptable for equipment with this sort of price tag. I waited for a call from your technical support yesterday (having asked for one) and received nothing - not even a reply to the emails I sent yesterday.
Thank you for the heads up, Matt. It looks like you were able to get in contact with one of our technicians and schedule an appointment for a call. Please continue working with him so we can help provide some hands-on assistance with your system. Thank you!
Userlevel 5
Badge +2
I'll add to the thread having the same issue. Haven't tried to replace cables or change broadcast channels but seems odd that so many similar issues are being reported. Has there been a recent software push that could be affecting? About the same time this connectivity issue started I had one of my ZP100s begin powering down sporadically. I have to reboot it to reconnect then next day it's off again. I've been a very happy Sonos customer for years and invested heavily, expect this will be quickly resolved but frustrating.
Hi there, the rebooting ZP100 is worrisome. The Sonos components communicate in a mesh network, so if one component is going down frequently then it might be affecting the connectivity of the other units. Would you mind submitting a diagnostic report and letting me know what the confirmation number is? You can find instructions on how to do so here. This will let me take a look at the communication between these units. I'd also like to know what music source(s) you're playing when the audio drops out. Thanks.
Userlevel 5
Badge +2
I am also having the same problem. I have a basic modem -> bridge -> player set up and it is pretty much unusable at the moment due to constant track skipping and dropouts. I also find the software regularly freezes when I'm using it (basically my entire computer will be frozen including the cursor for 5-10 seconds) and I am often getting an 'unable to browse music' message (all the music is stored on my laptop). Have done all the recommended restarts / channel switches etc etc and nothing has helped - very frustrating as I use my Sonos every day... I have submitted a diagnostic 3159617, please help!
Does your PC's cursor lock up when using other programs besides Sonos? If the PC stops responding to the point where you're not able to move the mouse or give commands, it's likely becoming unresponsive on the network as well, which would cause problems when Sonos is trying to play music or browse from it. I also notice that the computer is connected to your network via wireless. As a temporary test, would it be possible to wire the computer directly to the router (or to a Sonos component) and play music over the wired connection instead? I'd like to know if the cutouts continue when it's not streaming over the WiFi (and if the computer's lock-ups cease). The system looks good according to the diagnostic. The signal strength between your units is strong and there is minimal interference. Do you experience any cutouts when playing from other sources? Thanks!
I'll add to the thread having the same issue. Haven't tried to replace cables or change broadcast channels but seems odd that so many similar issues are being reported. Has there been a recent software push that could be affecting? About the same time this connectivity issue started I had one of my ZP100s begin powering down sporadically. I have to reboot it to reconnect then next day it's off again. I've been a very happy Sonos customer for years and invested heavily, expect this will be quickly resolved but frustrating.
Thanks for response Ryan - Diagnostic 3160002 was submitted. Primary music sources are Pandora and Songza. Issues occur on both sources.
Okay - I would also like to join this thread and say that my Sonos keeps skipping and cutting out! This is unacceptable from sonos and is making the system pretty much unusable. I spoke to a sonos rep and feel pretty fobbed off and say my tracks have not copied over properly to the nas is nonsense since I have also tried to play from the laptop and the same probs still occur. I have spent a huge amount of money on this system and sonos cannot seem to solve the problem! Please please somebody from sonos help me!!!!!!!!!!!! From a very disgruntled customer
Yes I changed it from the NAS to the PC as the Sonos when played through the NAS kept cutting out so I wanted to see what would happen if I played it through the laptop. It still skips through the laptop but not as much - see my last diagnostic. The PC was connected to the router and was wired in to the network and yes the sonos component is plugged straight in to the router. This has now dragged on for nearly 4 months ! Can I just please have a sonos rep around to sort problem out !! Thanks
I am also having the same problem. I have a basic modem -> bridge -> player set up and it is pretty much unusable at the moment due to constant track skipping and dropouts. I also find the software regularly freezes when I'm using it (basically my entire computer will be frozen including the cursor for 5-10 seconds) and I am often getting an 'unable to browse music' message (all the music is stored on my laptop). Have done all the recommended restarts / channel switches etc etc and nothing has helped - very frustrating as I use my Sonos every day... I have submitted a diagnostic 3159617, please help!
The cursor only locks up when I'm interacting with the Sonos software and is usually shortly followed by a track skip, but the two are not mutually exclusive... Typically it seems pretty stable at the moment but as soon as it starts mucking me around again I will wire my laptop and see if that makes any difference. The only other source I use is the Android app on my phone (to play music stored on my phone) which doesn't seem to suffer the same issues as far as I have noticed... Thanks for your help!

Reply