sonos keeps cutting out. sonos suggests A network switch with an IGMP Snooping option will be the fix


Badge

Having a right terrible time with Sonos 

 

Can some one please tell me exactly what I need to do as I’m no techie    

 

the tech side say I must do “A network switch with an IGMP Snooping option will be the solution “

 

this means nothing to me. please help

 

from

sonos

Thanks for following up with me.

I completely agree, the devices within are very common. Though we are reporting Network Flooding outwith our connections. While the issues are experienced on Sonos, they're originating from the network. The Network speed and bandwidth have zero impact here.

A network switch with an IGMP Snooping option will be the fix. 

I'll be more than happy to arrange a time to call but have very little further to add at this time. We must reduce the flooding and then combat the high amount of wireless interference. 
 

thanks ! As I’m about to dump the lot of it doesn’t work !! 14 speakers   Really poor of Sonos to not work 

 

 

 

 


 

 

 

 

 

 


 

 


15 replies

Userlevel 7
Badge +17

Are any of your Sonos speakers directly wired to your router or network with an ethernet cable? If not, can you wire one of them to the router?

Badge

Hi

 

hi.  yes   We were asked to do that so have a Sonos one old and also we added an Ethernet cable to the sound bar  on the tv  wired from the router   ..so two speakers hard wired. 
 

the issue still is there   
 

the surrounds cut out on off on off all the time  

 

 

 

 

 

 

Badge

They said we need to :

 

A network switch with an IGMP Snooping option will be the fix. 

 

does anyone know how to do this simply please ? Or suggest a device I have to purchase.

Userlevel 7
Badge +17

Do you notice any change if you just hard wire one speaker? Try disconnecting the Play:1 from the router but keep the sound bar hard wired. Also try unplugging the sound bar from power for about a minute.

Badge

Hi 

 

we started with just the play one hard wired on our study to the router. 
 

we have then been told to try hard wire a speaker elsewhere so not ideal but we have a long Ethernet cable going outside the house to the tv soundbar in the lounge. I’d prefer just from the study as we can’t leave Ethernet cables all over the place. 
 

We need to do this IGMP snooping option so I need to know how to do this please.  
 

happy to unplug the Sonos one in the study and just use the soundbar but that means leaving tons of outside cable.   Not ideal fix as router is in my study and soundbar in the lounge. 

Userlevel 7
Badge +17

Keep the Play:1 hardwired and disconnect the soundbar. Have you unplugged the sound bar and surrounds from power for about a minute? Have you tried changing the SonosNet Channel in the Sonos app?

Badge

Hi

 

we have tried that my friend. 
 

we first just had the Sonos one hardwired.  It cut out all the time.  We changed Sonos channels many times with Sonos on a call.   They said to hardwire the tv soundbar hence why we now have long wires outside !

 

we did unplug the sound bar for a minute and unplugged  the Sonos one from the Ethernet. 
 

it’s all just reconnected so we will have to now try and see if it cuts out.  Issue is we are doing the same over and over and it’s not getting better.  The tv surrounds just go on and off all the time. 
 

I need to do what Sonos say and fix the igmp snooping option. Sonos are most unhelpful to loyal customers.  
 

appreciate your response !

 

anyone know about igmp snooping fix please ??

Userlevel 7
Badge +17

I believe IGMP snooping might be a setting you enable on your router. What model router do you have?

Badge

We have the bt smart hub 2 

 

we use halo 2 for strong WiFi 50 plus on all rooms with their boosters 

 

 

A network switch with an IGMP Snooping option will be the fix.

 

Support was referring to an unmanaged network switch that is IGMP snooping enabled such as this one. I have no idea if this switch is available for purchase in the UK, if not look for a similar one (keywords: unmanaged network switch ; IGMP snooping enabled).

Badge

Very kind.  Thanks so much. I’ll do some digging.   Or will have 14 speakers to go !  It’s driving us mad going in and out all The time 

Badge

Hi. We ordered the tp link to-sg105 you recommend 

 

can I please ask what we do with it from our router and how does it fix the issue please ?

 

sonos said this last 

“I'll be more than happy to arrange a time to call but have very little further to add at this time. We must reduce the flooding and then combat the high amount of wireless interference. 

I'd much prefer a switch to be introduced with further testing and diagnostics to follow.”

 

 

 

 

Hi. We ordered the tp link to-sg105 you recommend 

 

can I please ask what we do with it from our router and how does it fix the issue please ?

 

The ethernet switch is a portable multi network socket. You can hard wire up to 4 devices to it (TV, PC, Sonos etc.), the port which reads ‘Link/Act’ being the one you plug into a free ethernet port on your BT smart hub.

 

 

 

sonos said this last 

“I'll be more than happy to arrange a time to call but have very little further to add at this time. We must reduce the flooding and then combat the high amount of wireless interference.

 

Sonos uses multicast for discovering and grouping purposes. IGMP snooping restrains the multicast traffic in your switched network to prevent these data packets from flooding your network if more than one multicast enabled streaming device (Sonos or IPTV for instance) is wired into your network.

Badge

Hi  ok   we will do that      

 

our router has four ports so i dont see why plugging them all into the tp link if we just plug that part into the router makes a difference and put all in the tp link how that makes the drop out issue go away im   happy to try !   its reeeeeally bad !

 

many thanks 

 

ill update if we get any joy..  appreciate your help !

Few routers are IGMP snooping enabled, and as the diagnostic report points to multicast flooding the BT smart hub is probably incapable of handling multicast traffic.

 

In case the drop outs persist: If 'Auto channel' is enabled in your router, then disable it and set a specific channel, either 1, 6 or 11. Change also the SonosNet channel ('Settings --> System --> Network --> SonosNet Channel') to either 1, 6 or 11. That means when e.g. SonosNet is set to channel 1, put your router on channel 6 (or vice versa). See also Reducing wireless interference. If you’ve got a HUE bridge put ZigBee on channel 25.

 

Edit: Make sure that you’ve removed the WiFi credentials from the system. On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Wait about 10 min, then go to 'Settings → System → About my Sonos System' and see if WM:0 is being displayed next to each unit.

Reply