Answered

Sonos keeps continuously stops playing songs

  • 7 September 2017
  • 36 replies
  • 10886 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

Badge
Thanks a lot for the update.
As I said, I can't turn off the auto-lock. It is also not a safe option. You may forget to turn it on again.
There is no issue in our network. It is strong and it is a small apartment. I also did try turning the AirPlay on the Apple TV, so that is not the issue either.

I will be waiting for the Sonos development team to come with a solution. There is one thing I need to add for their info. This issue showed up only about a year ago or less. For the three years before that, I never had this problem. Nothing changed in my environment, so with other people facing the same issue, that would lead me to suspect something that was introduced in the system that caused it.
Userlevel 7
Badge +20
Thanks a lot for the update.
As I said, I can't turn off the auto-lock. It is also not a safe option. You may forget to turn it on again.
There is no issue in our network. It is strong and it is a small apartment. I also did try turning the AirPlay on the Apple TV, so that is not the issue either.

I will be waiting for the Sonos development team to come with a solution. There is one thing I need to add for their info. This issue showed up only about a year ago or less. For the three years before that, I never had this problem. Nothing changed in my environment, so with other people facing the same issue, that would lead me to suspect something that was introduced in the system that caused it.


The issue is specifically tied to the AirPlay feature which was added a little while ago. If the issue remains, you likely have another AirPlay device active on your network beyond your Apple TV. See if you can track it down and disable AirPlay. That should get the streaming working again.

Your best option, in my opinion, is to offload your iOS device's music library to a computer or NAS drive, then to set up a music share. This will allow you to use your phone to control your Sonos, and play the music library without having to disable AirPlay on non-Sonos devices. It will even play when your phone is locked or off the network entirely.
Badge
Thanks Jeff S for the advice.
I am very lean on the equipment, with minimal devices, so I don't think it is a hidden AirPlay device.
I can do what you suggested about the music sharing, though I was hoping to play with just one device... but until this issue is resolved at the root, I might just have to do that.
Thanks.
I just updated to version 9.3, which said it was for "reliability" updates, and the issue is still not resolved. I have to leave my phone unlocked or else it just randomly skips. SONOS THIS IS UNACCEPTABLE. This issue has persisted for MONTHS.
Userlevel 7
Badge +20
Moderator Note: Please see this thread for information regarding streaming music from iOS devices.

At this time there will be audio playback issues if you are streaming from the storage on an iOS device while you have active non-Sonos AirPlay devices on your network. You can either disable AirPlay on non-Sonos devices, or disable auto lock on your iOS device.

Your best option is to offload your music library to a computer or NAS drive, then set up a music share. This will allow you to use any controller to play your music library, even if there are AirPlay devices active and your phone goes to sleep, or offline.
[quote=Jeff S]Your best option is to offload your music library to a computer or NAS drive, then set up a music share.

This isn't really an option at all. I've already spent nearly $3000 on Sonos devices, now you're suggesting I spend several hundred more to buy a NAS device, then spend time setting it up and aggregating all the music from my computer, my phone, my wife's computer, and her phone onto that device, then always have to keep it up-to-date with whatever changes are made on those devices? That is a really crappy suggestion and great deflection from the actual issue which is your software.

Fix your software.
Badge
Ditto
I’ve been having the same issue for a couple of months and can’t think of anything new with our system that coincided with the start of the issue. However I just went into settings on my iPhone and turned off auto refresh and use cellular data for Sonos and my system has worked flawlessly for over an hour - a record for us for the past 2 months. Hopefully it will continue. Regarding the cellular data, my iphone will randomly try to use cellular even though I have a strong WiFi signal and horrible (almost non existent) cell reception at my home. I have noticed this issue while browsing on safari etc in the past - perhaps this is our issue while streaming on Sonos.
Badge
This should give good clues to the Sonos development team to pinpoint the problem, Users should not go around finding sideways to address this issue. It needs to be solved at the core.

Can you tell us what auto refresh you turned off? Is it in the Sonos settings or the iPhone settings?
I realized my first post wasn’t super clear. I turned off both “background app refresh” and “cellular data”. Both are found on my iPhone at Settings -> Sonos. I turned both at the same time so I don’t know if just one has helped the issue but Sonos hasn’t turned off randomly since the settings were changed! Hope that helps.
Badge
Unfortunately for me, this didn't work. Just few minutes.... then cut off as has been the case the past months.
Back to Sonos.... I really hope their software developers find a solution.
Turning off AirPlay for other devices didn't work either, just a reminder.