Answered

Sonos keeps continuously stops playing songs

  • 7 September 2017
  • 36 replies
  • 10890 views

  • Contributor I
  • 0 replies
My Sonos PLAY:1 keeps cutting out during songs for now apparent reason. My Wifi is working just fine otherwise so what gives? It happens both when using Spotify and the Sonos app. Can you guys help?
icon

Best answer by Jeff S 24 December 2018, 18:01

Moderator Note: Please see this thread for information regarding streaming music from iOS devices.

At this time there will be audio playback issues if you are streaming from the storage on an iOS device while you have active non-Sonos AirPlay devices on your network. You can either disable AirPlay on non-Sonos devices, or disable auto lock on your iOS device.

Your best option is to offload your music library to a computer or NAS drive, then set up a music share. This will allow you to use any controller to play your music library, even if there are AirPlay devices active and your phone goes to sleep, or offline.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

There's a pinned thread about this issue, but I'll summarize for you. It's liable to be one of two things, either wifi interference, in which case there is a well written FAQ n this website about it, or it's a case of duplicate IP addresses, often exposed during the soft reboot that occurs during a software update.

If it's the latter, it's fairly easily dealt with by unplugging all of the sonos devices, then rebooting your router. Once the router is back up,' plug in one of your speakers to the power, and wait for it to connect. Once it is done, then move on to the next speaker. This forces all of your speakers to request new IP addresses from a "fresh" router and IP table.
Userlevel 7
Badge +19
Hi there, Esco:

Thanks for reaching out to the Community. Glad to see Airgetlam was able to get you pointed in the right direction. If you still require help, please submit a diagnostic report and I'll be happy to take a look. Here's a link to an article that outlines how to submit the report. Be sure to reply with the seven-digit confirmation number it gives at the end.
This did not work for me. Sonos is horrible. Total unmitigated disaster. I had a Bose system for 10 years- never had any issues. Sonos can’t seem to play longer than 2 mins without skipping or stopping.
Userlevel 7
Badge +20
Hi, robertsmich. What exactly did not work for you? If you are referring to the running of diagnostics, this isn't the fix- just the means by which we can propose one. If you could respond here with a confirmation number, we will be able to provide further advice. Thanks in advance.
Hi, same issue here. I've reset both the router and all Play 1 speakers (3) but keeps dropping. Diagnostic code 1105655530.
Any help is appreciated!
My sonos only plays half or a third of any song. These are albums that are already on my phone so internet speed is not the issue. It’s unusable at this point
Submit a system diagnostic within 10 minutes of replicating this issue, and either post the number here, or contact Sonos to discuss it. There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

Since there's little to go on in your post, I'd suggest you're suffering from either wifi interference or potentially a duplicate IP address issue.
Since there's little to go on in your post, I'd suggest you're suffering from either wifi interference or potentially a duplicate IP address issue.
It's more likely the "Can't play music files stored on my iPhone because I have non-Sonos Airplay devices on my network" syndrome.


@sagedeli: In what country do you reside - in Switzerland by any chance?
Badge
I have been facing the same problem for months. I just gave up and used streaming radio only. My own songs on the iPhone play for a short while then disconnect. Sometimes it goes to the next song and sometime stops playing the whole Playlist. No rebooting ever fixed it. It does play radios so it is not an internet connection.
I almost gave up then decided to search. I see other people facing the same problem. Then I am encouraged as I am not alone. I hope Sonos can reproduce it and fix it.
I tried the link to the article on how to submit a report bu the link takes me to a "page not found".
Userlevel 7
All

if you are using an iOS device try disabling auto-lock found in "display settings".
Badge
Thanks for the tip AjTrek1, but that is not the issue unfortunately.
Songs will stop playing even if I am using the iPhone and the screen is not locked.
And many months ago, the songs would continue playing even after the screen is locked.
Something happened... anybody from Sonos know what happened to cause this?
Userlevel 7
Badge +20
Hi, Kamalyhya. If switching off the lockscreen did not help, then it may just be a coincidence that the issues with your system coincide with this wider issue encountered by other users. Would you keep the lock screen off for now, just to be sure, then replicate the problem and submit a diagnostic, responding with the confirmation number? Many thanks.
Badge
Thanks Edward R
I replicated the problem. It cut the song and played the next song while the iPhone was still on.
The diagnostic number is 524888476.
I experimented with one thing: I had the iPhone on and also the Sonos app open all the time and I did not experience the cutoff. When I experimented again with the iPhone on but I am working on other apps, I experienced the cutoff.
Thanks.
Badge
Hello.... Anybody out there?
Any progress in understanding this problem?
Thank you.
Userlevel 7
Badge +20
Thanks Edward R
I replicated the problem. It cut the song and played the next song while the iPhone was still on.
The diagnostic number is 524888476.
I experimented with one thing: I had the iPhone on and also the Sonos app open all the time and I did not experience the cutoff. When I experimented again with the iPhone on but I am working on other apps, I experienced the cutoff.
Thanks.


Thanks for the report. I see that you are playing from your iOS device's library. The best way to get your library streaming is to disable AirPlay on any non-Sonos devices on your network. Disabling auto-lock on your iOS device works for some folks, but you may need to keep your phone awake in order to continue streaming.

My advice would be to sync your iOS library with iTunes on a computer, then set up a music share. This will allow you to stream your music while there are non-Sonos AirPlay devices on your network, and even when your phone is off the network, screen locked, or offline.
Badge
Thanks Jeff S.
On the auto lock, I do not have much choice. The device is managed and for security reasons I cannot disable the auto-lock. It is not a good idea anyway. I used to play my songs and go to the shower and it worked. What has changed?
And if I could play with auto-lock I would have to remember to re-instate it as I wouldn't want to have it off, again to keep my phone secure. Can't Sonos allow the songs to play when the screen locks, just like iTunes or YouTube, or Sonos before?

I can try using the desktop to play my songs... it's a departure from what I used to do and may not always be convenient. I still would ask why not restore the ability to have songs continue to play after the screen locks, just like before?

Thanks.
Userlevel 7
Not to start a conspiracy...but...it seems the issues of songs skipping and the like started just around the time Apple launched the Home Pod or shortly thereafter. Could Apple be trying to make Sonos appear as a problem? Hmmmm:8
Badge
It sure is frustrating that at this day and age when you expect things to "just work" we are held back by simple technical issue. I can't believe this is happening as we approach the third decade in the 21st century.
Userlevel 7
Badge +20
Thanks Jeff S.
On the auto lock, I do not have much choice. The device is managed and for security reasons I cannot disable the auto-lock. It is not a good idea anyway. I used to play my songs and go to the shower and it worked. What has changed?
And if I could play with auto-lock I would have to remember to re-instate it as I wouldn't want to have it off, again to keep my phone secure. Can't Sonos allow the songs to play when the screen locks, just like iTunes or YouTube, or Sonos before?

I can try using the desktop to play my songs... it's a departure from what I used to do and may not always be convenient. I still would ask why not restore the ability to have songs continue to play after the screen locks, just like before?

Thanks.


You can alternately disable AirPlay on non-Sonos devices on your network. Essentially, AirPl;ay is grabbing control of the Sonos app and interrupting streaming when the phone auto locks.
Badge
I am not sure how I should do that!
I have an Apple TV and a smart TV. Of course we have other mobile phones in the house. Neither the TV, nor the Apple TV were on when I was streaming to the Sonos. Should I unplug them? Are the other iPhones considered also AirPlay devices and should be turned off?
You can go into the settings on your Apple TV and turn off AirPlay. I did it, and it fixed things up a treat.
Badge
Unfortunately it did not work for me.
It has been inconsistent. The point at which it breaks and whether it will stop all together or jump to the next song has been so much varying. I have been experimenting with the distance of the speaker, Airplay On and Off, even the whole Apple TV on or off, even the WiFi frequency (2.4 vs 5).
Sometimes it worked to the degree I though it was resolved, but I repeat the test and the songs get interrupted.
I am frustrated to say the least.
Userlevel 7
Hi kamalyahya

Sorry for your frustration. Experimenting with the 5Ghz is definitely not going to help as Sonos connects to 2.4Ghz. The 5Ghz is only used in an HT setup to send material to surround speakers and/or a sub (HT setup or not). One last question...are there any access points and/or range extenders involved?
Badge
No, there are no extenders or other access points.
Userlevel 7
Thanks Jeff S.
On the auto lock, I do not have much choice. The device is managed and for security reasons I cannot disable the auto-lock. It is not a good idea anyway.


Based upon you response it appears you are part of a larger problem that Sonos is investigating. Here's a link to explain:
https://support.sonos.com/s/article/305#mobiledevice

FYI, turning off "auto lock" on my iPhone X works for me :8