Answered

Sonos is not reading the correct iTunes playlist

  • 11 October 2017
  • 1 reply
  • 256 views

I’ve recently moved my iTunes music off my Mac to a WDMyCloud NAS drive. All worked well then there was an issue with my iTunes. Apples helped me sort it out and I can now use iTunes music from the NAS drive and also see the music via the Sonos app. I can also see the Playlists using the Sonos app but when I select a tune on the playlist it comes up with a different tune and says that “the share//wdmycloud/public does not exist. If I navigate to the album (rather than the playlist) the tune plays. I think the Playlists are somehow corrupt or not pointing to the right place. Any help would be most appreciated.
icon

Best answer by Keith N 4 November 2017, 00:48

Hi there, Jimbo76. Since moving the iTunes Music from your Mac to your NAS have you removed and re-added the music library? This will clear out any old references the system would have and when you re-add, it will re-index all the content. Check this out.



Note: you do not want to just update the music library index. That will not remove any old non-functional paths.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +19
Hi there, Jimbo76. Since moving the iTunes Music from your Mac to your NAS have you removed and re-added the music library? This will clear out any old references the system would have and when you re-add, it will re-index all the content. Check this out.

Note: you do not want to just update the music library index. That will not remove any old non-functional paths.