Answered

Sonos goes haywire when using a recordplayer with sa port

  • 30 December 2021
  • 26 replies
  • 159 views

Userlevel 3
Badge +5

I used to have my Sonos Amp connected to my Pro-ject turntable (debut III with preamp). I moved my Amp away and recently also got a Sonos Port. I connected my turntable to the port and want to use it as an input for the record player.
 

But the audio keeps dropping, at some point my system goes total haywire. Most Sonos devices totally drop out and are missing from the system and after a while come back. Today it even when they came back claimed two S2 products (Ikea speakers) where incompatible with S2 and after a few more minutes they did show up normally again.

This is my setup:

Pro-ject recordplayer line into Sonos Port

Sonos Amp 

Sonos Arc + Sub + 2 Sonos Ones SL

2 Sonos Ikea speakers

Sonos One

Sonos Play:1

Sonos Roam

Sonos Boost

 

The port is NOT connected to any receiver and just functioning as a line in for the turntable.


I try and play the line in on the Arc, Play:1 and/or Amp. Lots of drops of the sound until it all goes haywire.

When it goes haywire it seems like mostly the products who use the Boost disappear. I know my One is on the wifi network directly and so is the Port. The odd thing is my Arc also disappears and that one is wired.

Any tips or ideas what I can do?

icon

Best answer by Ken_Griffiths 30 December 2021, 18:27

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

26 replies

Does your router have separate SSID’s for its 2.4Ghz and 5Ghz WiFi bands? If so, perhaps shift the Roam onto the 5Ghz band and then remove your routers 2.4Ghz WiFi credentials (if applicable) from your Sonos App network settings, leaving just the 5Ghz band in place. Also…

  • Set the routers 2.4Ghz WiFi band to channel 1, 6 or 11 and set the channel-width to 20MHz only.
  • Set the Boost so that it is at least one metre (or more) away from the router.
  • Set the SonosNet channel in the Sonos App so it is at least 5 channels away from the chosen router channel.

What I think may also prove helpful in this instance, is to reserve/fix all the Sonos IP addresses in your routers DHCP servers reservation table, so that on system-reboot the Sonos products will always get assigned their existing IP address.

See if those few suggestions resolve your system issues.

Good network hygiene advice from Ken. 

@Asgorath What is your Audio (Line-In) compression setting? And what is the Port’s Line-In Delay setting? 

Userlevel 3
Badge +5

Does your router have separate SSID’s for its 2.4Ghz and 5Ghz WiFi bands? If so, perhaps shift the Roam onto the 5Ghz band and then remove your routers 2.4Ghz WiFi credentials (if applicable) from your Sonos App network settings, leaving just the 5Ghz band in place. Also…

  • Set the routers 2.4Ghz WiFi band to channel 1, 6 or 11 and set the channel-width to 20MHz only.
  • Set the Boost so that it is at least one metre (or more) away from the router.
  • Set the SonosNet channel in the Sonos App so it is at least 5 channels away from the chosen router channel.

What I think may also prove helpful in this instance, is to reserve/fix all the Sonos IP addresses in your routers DHCP servers reservation table, so that on system-reboot the Sonos products will always get assigned their existing IP address.

See if those few suggestions resolve your system issues.

Some of these I already had, some not. My Router has Dual Band Smart connect (i.e. both bands are offered on the same SSID). Both where set to auto channels and bandwidth. Changed them to 20 and 1 fixed now. And added the IP addresses to be set.

What’s the idea behind turning off the 2.4Ghz? With 50+ devices it’s not something I quickly would turn off. But I think you mean temporary to force Sonos on 5Ghz?

I actually noticed that all my Sonos products have Wifi enabled now. Curious if it’s wise to just remove the boost? I have a Mesh-Wifi network with routers on all floors. Would that be wise?

Thinking about also wiring the Port.

Userlevel 3
Badge +5

Good network hygiene advice from Ken. 

@Asgorath What is your Audio (Line-In) compression setting? And what is the Port’s Line-In Delay setting? 

It was set to Uncompressed, changed it to Automatic.

Delay was originally set to Medium based on advice of an article, but set it to High now.

Userlevel 3
Badge +5

Could having 02.11ax / WiFi 6  turned on impact performance?

What’s the idea behind turning off the 2.4Ghz? With 50+ devices it’s not something I quickly would turn off. But I think you mean temporary to force Sonos on 5Ghz?

As you have a Sonos Boost, I presumed (hopefully correctly) that it is wired to your router, in which case the Sonos devices should all be running on a SonosNet signal, rather than your router WiFi, as briefly outlined in this support article:

https://support.sonos.com/s/article/3235

My reason behind keeping the 5Ghz credentials in the Sonos App Network settings, was for your Roam to use that WiFi connection, as it cannot use SonosNet. These things can reduce interference and may help to prevent devices, playing music, hopping between a SonosNet signal and your WiFi signal.

 

Could having 02.11ax / WiFi 6  turned on impact performance?

Not really helpful to have more channels broadcasting, but note all your Sonos products (except the Roam) are not using your router WiFi signal, as briefly explained in my post above.

I would make sure your Boost is set at least a metre away from the router and check that the SonosNet channel is away from your routers 2,4Ghz channel, as mentioned earlier.

Userlevel 3
Badge +5

What’s the idea behind turning off the 2.4Ghz? With 50+ devices it’s not something I quickly would turn off. But I think you mean temporary to force Sonos on 5Ghz?

As you have a Sonos Boost, I presumed (hopefully correctly) that it is wired to your router,

 

Fully correct. It’s wired to my primary router (and placed as far as it can from it). With two other routers acting as Meshnodes in other places in the house.

If I understand correctly, despite all devices having “Enable Wifi”  turned on (checkmark), they aren’t using the Wifi but the SonosNet signal?

 

What’s the idea behind turning off the 2.4Ghz? With 50+ devices it’s not something I quickly would turn off. But I think you mean temporary to force Sonos on 5Ghz?

As you have a Sonos Boost, I presumed (hopefully correctly) that it is wired to your router,

 

Fully correct. It’s wired to my primary router (and placed as far as it can from it). With two other routers acting as Meshnodes in other places in the house.

If I understand correctly, despite all devices having “Enable Wifi”  turned on (checkmark), they aren’t using the Wifi but the SonosNet signal?

@ratty will love that comment, as he has argued for a long time about the labelling in the Sonos App in relation to the devices WiFi adapters.. I’ll just say, if you were to switch them off you would be denying a wireless SonosNet connection to that device too - you need to leave the adapters switched on .. even though they actually won’t be using your routers WiFi signal. Hope that makes sense🤔?

Userlevel 3
Badge +5

What’s the idea behind turning off the 2.4Ghz? With 50+ devices it’s not something I quickly would turn off. But I think you mean temporary to force Sonos on 5Ghz?

As you have a Sonos Boost, I presumed (hopefully correctly) that it is wired to your router,

 

Fully correct. It’s wired to my primary router (and placed as far as it can from it). With two other routers acting as Meshnodes in other places in the house.

If I understand correctly, despite all devices having “Enable Wifi”  turned on (checkmark), they aren’t using the Wifi but the SonosNet signal?

@ratty will love that comment, as he has argued for a long time about the labelling in the Sonos App in relation to the devices WiFi adapters.. I’ll just say, if you were to switch them off you would be denying a SonosNet connection to that device too - you need to leave the adapters switched on .. even though they actually won’t be using your WiFi signal. Hope that makes sense🤔?

 

So the label actual means its using the Boost / SonosNet? Christ that is some unclear labeling. Glad I didn’t turn it off just to try :)

 

Oh I’ve not said so yet, but thank you for all the help so far.

 

So the label actual means its using the Boost / SonosNet? Christ that is some unclear labeling. Glad I didn’t turn it off just to try :)

 

Oh I’ve not said so yet, but thank you for all the help so far.

 

No, the label means its Wi-Fi radio is turned on/off.  The most confusion happens when someone hardwires a Beam/Arc/Amp, connects it to surrounds or a Sub, then turns off Wi-Fi because it’s wired to Ethernet.  They forget that it has to connect to the Sub and surrounds via Wi-Fi.

If I understand correctly, despite all devices having “Enable Wifi”  turned on (checkmark), they aren’t using the Wifi but the SonosNet signal?

@ratty will love that comment, as he has argued for a long time about the labelling in the Sonos App in relation to the devices WiFi adapters..

Quite. The “Disable WiFi” turns off the “WiFi” hardware (Sonos use off-the-shelf chipsets), but since in this instance it can only apply to SonosNet (or a home theatre’s 5GHz satellites connection) it’s infuriatingly misleading. Leave it enabled. 

Yes. Unfortunately. It’s what many of us have been railing against since that feature was included in the controller. 

It really means “turn off all radio signals”  which included SonosNet and Wifi, as well as the capability for sound bars to connect to Subs and surround devices. 

I’d be a fan of removing it altogether, but I do recognize there are (very few) instances, mostly in professional installations, where it makes sense. But it’s so poorly labeled that we have this issue over and over in the forums, where people think they’re doing the right thing, based on the label, but turns out they’re not. 

I’d be a fan of removing it altogether

And go back to http://x.x.x.x:1400/wifictrl ? Bring it on. Worked perfectly, without all the “unable to disable” controller protestations. 

Heh. Your memory is infinitely better/longer/sharper than mine, sir. I tend to live in the moment, for better or (more likely) worse. 

And go back to http://x.x.x.x:1400/wifictrl ? Bring it on. Worked perfectly, without all the “unable to disable” controller protestations. 

 

Ahh the good old days, where we’d report the mention of that command and it would magically *poof* off the board.

So the label actual means its using the Boost / SonosNet? Christ that is some unclear labeling. Glad I didn’t turn it off just to try :)

 

Oh I’ve not said so yet, but thank you for all the help so far.

ha ha .. you certainly wouldn’t be the first to have switched off the WiFi adapter and wondered why things were not working. It mostly happens when folk cable a Beam/Arc etc; to a router and then switch off the adapter thinking it’s not needed, when in fact it’s needed for the wireless surround speakers/Sub to work - oddly they don’t realise their surrounds stopped working until a few days later and then wonder if their devices have a fault🤔?

Anyhow, if you want to go onto try some of the things suggested here earlier, then you should (hopefully🤞)  find your issues will go away and things should begin to settle - reserving the IP addresses will help too.. and keeping your SonosNet channel at least 5 channels away from the router’s 2.4Ghz band will also help.

edit: I need to type faster (beaten again with my reply here) .. ha ha😀

So the label actual means its using the Boost / SonosNet? Christ that is some unclear labeling. Glad I didn’t turn it off just to try :)

 

Oh I’ve not said so yet, but thank you for all the help so far.

ha ha .. you certainly wouldn’t be the first to have switched off the WiFi adapter and wondered why things were not working. It mostly happens when folk cable a Beam/Arc etc; to a router and then switch off the adapter thinking it’s not needed, when in fact it’s needed for the wireless surround speakers/Sub to work - oddly they don’t realised their surrounds stopped working until a few days later and then wonder if their devices have a fault🤔?

It’s worse than that. If WiFi credentials are in the system -- e.g. for Move/Roam -- the satellites would connect to WiFi in the absence of the HT master’s 5GHz signal. Owing to latency variations they will sometimes work, sometimes not. 

And go back to http://x.x.x.x:1400/wifictrl ? Bring it on. Worked perfectly, without all the “unable to disable” controller protestations. 

 

Ahh the good old days, where we’d report the mention of that command and it would magically *poof* off the board.

That might have been me, wearing my old mod hat. After https://bsteiner.info/articles/disabling-sonos-wifi then why bother?

That might have been me, wearing my old mod hat. After https://bsteiner.info/articles/disabling-sonos-wifi then why bother?

 

“We can’t tell you, but Google is your friend.”

Userlevel 3
Badge +5

It seems to be fixed! Managed to play an A side of a record without any drops, sonos systems disappearing, etc. So far so good. !!

Things I did (and any and all or a combination ofc.) can be it. I obviously didn’t just do one thing and try to know exactly what, that would be way to scientific and organized :)

 

Router:

  • 2.4 Ghz to 20 Mhz only
  • 2.4 Ghz from auto-channel to channel 1
  • Followed a guide on the internet for most optimal Router settings for the ‘proffesional’ section of Wifi on my Asus router. Causing me to flip Enable IGMP Snooping from On to Off.

Sonos

  • Sonos to Channel 11
  • Audio Compression to auto instead of uncompressed (I really think this may have been it)
  • Audio delay on the Port to to Max

As mentioned because I use the Boost and as such SonosNet I think the Router settings may not have been the biggest issue, unless the channels where interfering. So think the Audio Compression of line-in may have been the one causing the problems?

But I have been on a long battle on why my Wifi signal sometimes goes bonkers. I’ve used Apple’s AirPort Utility’s very handy channel sniffer to figure out the endless amounts of channels and wifi signals here. Even tried out a different routers once, etc. At some point one of my Network switches was the issue, but that was replaced. I’ve managed to improve the signal a lot over time. But never completely. To the point it’s even left ppl who know way more than me about it baffled. So who knows, perhaps limiting the 2.4Ghz to 20Mhz or something like that will have played a part, and perhaps improve my overall quality. Which is very welcome with a full Smarthome and over 50+ deviced connected :P

Huge thanks to @Ken_Griffiths and @ratty 

 

Userlevel 3
Badge +5

So the label actual means its using the Boost / SonosNet? Christ that is some unclear labeling. Glad I didn’t turn it off just to try :)

 

Oh I’ve not said so yet, but thank you for all the help so far.

ha ha .. you certainly wouldn’t be the first to have switched off the WiFi adapter and wondered why things were not working. It mostly happens when folk cable a Beam/Arc etc; to a router and then switch off the adapter thinking it’s not needed, when in fact it’s needed for the wireless surround speakers/Sub to work - oddly they don’t realise their surrounds stopped working until a few days later and then wonder if their devices have a fault🤔?

 

Yeah, I was just about to think, since the Arc is cabled…. glad I also didn’t do that :) God that label at least needs like a massive info-box besides it what it actually does.

 

FWIW 40MHz at 2.4GHz is crazy, antisocial even, assuming there are any other channels in use (by you or neighbours). It can’t avoid overlapping with the standard recommended channels (1, 6, 11). Partial overlaps are particularly damaging. 

Userlevel 3
Badge +5

FWIW 40MHz at 2.4GHz is crazy, antisocial even, assuming there are any other channels in use (by you or neighbours). It can’t avoid overlapping with the standard recommended channels (1, 6, 11). Partial overlaps are particularly damaging. 

Perhaps this will also fix my overall network issue. If so, I could hug the two of you :wink: It’s wild here with Wifi signals. While living in a suburban house at the corner of a street, it’s still insane how many wifi signals there are. Perhaps I should just try and organize the street to all pick specific channels for 2.4Ghz :)

A reason why I left it to my router to find the best signal on ‘auto’, but perhaps that was actually NOT a good idea.

Plus there’s all the Zigbee low-power IoT stuff, and Bluetooth, jostling for space in the Wild West of the 2.4GHz band. And that’s before the microwave oven gets turned on.