sonos doesn't show my complete itunes library.

  • 23 November 2012
  • 58 replies
  • 73896 views

I have for example artists named Blue Knights. In my itunes library I show three albums for a total of 21 songs. When I bring up the sonos app on my macbook pro, and load music library, it only show one of these albums that has five songs. I've gone to manage settings, and updated music library now about five times .... still same results. I've gone to music library settings, removed the library, and added it again .. three times ... still same results. I checked the rest of the artists that are listed in Sonos, and it seems to be missing about 12 other artists and songs of those artists that I have in my itunes library. Considering giving up on Sonos and returning play5 and bridge to retailer. Anyone interesting in buying this system from me. Previously I asked a question of why when I shut off my macbook pro the music still plays, and never received a response from sonos. This type of support and product doesn't seem to be worth the monies.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

58 replies

hi there exactly the same problem sonos is not seeing all of my music, it is all there on the nas drive, i too have uninstalled and reinstalled all my music onto the nas several times, it is all on the nas and plays from the nas on my laptop through media player, update music library dozens of times, still can't see certain tracks, even directed the path to a specific folder on the laptop (known to be missed by sonos via nas) and sonos still does not pick it up, my pal said this was an id tag problem but have checked that and proved id tags to be 100% ok - emailed sonos but no help whatsoever from them at all, had my system installed by a sonos supplier, they have given up too, scratching their heads, don't understand it !!!! really poor
Userlevel 5
Badge +3
Hello dr4m5s and martyn, This could be related to a file format issue or an ID Tag missing. Could you please check if you see your files on the Sonos Desktop Controller by going to Music Library > Folders, and browse to the file location and see if it appears. If you see the music files, you will need to add the tag manually with iTunes or any Tag editors (ex:Media Monkey) If it is not the case, could you please check what is the file format and see if it is a Supported Audio Format Sonos uses the ID Tags (Artist/Albums/Composers/Genre/Tracks) to order the music files. If the Tags are missing you will not see them on Sonos within those categories, but only in the Folders part with its file name. (ex: mymusicfile.mp3). I would recommend then to use iTunes or Media Monkey to edit those Tags to access them from those categories. Here is a good tutorial on http://www.fanhow.com/knowhow:Manually_Add_ID3_Tags_to_MP3_Files_in_iTunes_29281013 Martyn, could you please check on iTunes the ID3 Tag version of the missing tracks? Right click on the Track in iTunes > Get info and under the Summary tab you will see the version. Let me know if you have any questions about it.
I have e the same problem. I just bought an album from the Itunes store and out of the 11 tracks on the album, only 9 show up in Sonos, yet they all show up and play in Itunes. This is not the only album this happens on ... I have about 500 albums and it happens on others. The album I just bought is "The Last Great Traffic Jam Live" by Traffic and the 2 tracks that don't show up or play are: Light Up Or Leave Me Alone & The Low Spark of High-Heeled Boys I have already tried everything that was suggested and nothing works. Any other suggestions???
Okay!!!! I figured out what the problem is! This should help everyone with the same issues. First of all, I use Carbonite to back up my files. Not an endorsement, just letting you all know how I found out what was wrong. When Carbonite backs up a file, there is a little GREEN dot that shows up beside the file name. When it hasn't backed it up yet, there is a little YELLOW dot that shows up. When I opened the file folder with my new album in it, all the dots were green except the two songs that weren't showing up in Sonos. I looked a little closer and those two files had a .m4p extension on them, and the ones that were green and WERE showing up in Sonos had a .m4a extension. The p in the extension means (for what reason I have NO idea) that the file is PROTECTED. Sonos won't play a protected file and Carbonite won't back up a protected file. I simply changed the p to an a in the extension and everything works great!!!
I am having the same problem. I checked the extension (.m4p vs .m4a) on the a few of the songs I know are in Itunes but are not appearing in Sonos. I these cases the songs have the .m4a extension but do not appear in Sonos. It is odd, because in this case only one song from this particular album appears in Sonos and the other songs on the album do not appear. Any other suggestions?
First read the post below this one .... you should try that one before this. After I wrote the response above I found the same thing you did. Some showed up and some didn't. AND I was having trouble with CD compilations showing up as seperate albums with only ONE song on them. Instead of having about 500 CD's, Sonos showed I had almost 4000. This is how I resolved the problem. First I copied ALL my music files into a different folder ... I named mine SONOS MUSIC. It's on the same hard drive so the copying went pretty fast. I made sure all the music that was in a compilation CD such as 45's on CD, TOP 100 of different years, etc, were all in the same folder which I named 45's. Then I started Sonos on my desktop and went to MANAGE / SETTINGS then I highlighted the music folder (the Itunes one) and deleted it. You are only deleting the file name from Sonos, not the I tunes music ... it will still be there for Itunes to read and it will work as it did before (Itunes). When that was done I ADDED the new one I had named Sonos. Once it is done your problem should be solved. Mine is. One other thing ... if you still have the problem, when you start Sonos and click on MUSIC LIBRARY, try going down to the FOLDERS option and click that. If you have labeled your music library as I have, by Artist name, you should be able to scroll through and find what you want pretty easily, and all your songs should be there. Hope this helps.
One other thing just occured to me and you should try this before you go to all the trouble with what I suggested above. In Itunes, go to the CD you are having trouble with and right click it. Then click on GET INFO. Check to see if the Artist name and Sort artist names are all the same on all the different tracks. If they aren't the same, then simply change them. For some reason, whoever puts the information down on metadata doesn't always take care to match everything up and it really screws with how Sonos reads the CD. Good luck.
some songs downloaded from itunes were protected. they are marked .m4p , not .m4a sort your songs by "kind" all the protected will be together. Those are the troubled items. put those into a playlist burn to a cd, then burn back you will then have douplicates. just delete the protected ones. the new unprotected ones will play fine on sonos worked well for me took a little time
In my case, Sonos doesn't even show complete music library in folder view. Any idea how to fix this. I'm extremely frustrated and despite posting questions have yet to receive a reply.
Badge
The suggestion posted by Joe Franczek worked for me. The files that weren't showing up in Sonos all happened to be protected file formats. Did just what he said to do, updated the Sonos Library, and the music now plays. Thanks!
Userlevel 2
Badge
This gets back to my #1 issue with my Sonos system.  Lack of any track management tools at all!  If a music file is "skipped" by the indexer for ANY reason, there should be a way to find or list all the files that are not indexed.  One idea would be to create a special virtual folder in the controller that would list files with ID Tag issues.  Or create an actual report (what a concept...) that you can run from the PC controller that will identify files and URL's for tracks that are not indexed.  ANYthing... SOMEthing... Just give us a way to find and fix non-indexed tracks that does not involve hunting and pecking our way throgh thousands of files.

SONOS:  Do you realize how hard it is to find tracks that are not indexed when one has 10,000 files on a hard drive?  We don't even know they are missing until you try to play it.  And that's just ONE file...

Comon... PLEASE give us some tools to work with.  I've brought this up before, and I can't believe that with the popularity of SONOS that I'm the only one that wants better in-app track management.

Pretty Please?

Bruce
I have been holding off buying a Sonos system because of the issues raised here. I am happy to spend a large lump of money on this Sonos perfection, but will not be impressed and feel cheated if these problems are the norm. How many others are also withholding their purchases too? Big marketing rule - don't confuse your customers.
Userlevel 2
Badge
One more thought on my other posts on this subject.  If SONOS can't (or wont) add even basic track management, then the next best thing are the following enhancements:

1. List of ALL tracks that are not indexed for play.

2. A button that will automatically "fix" these tracks with some sort of temporary tag so that they can be added to the library immediately.

3. An exportable list (or report) of all tracks that have been "fixed" so that I can more easily use 3rd party track management tools (like media monkey for example).

At least this way ALL tracks on the hard drive would be immediately playable (other than by browsing the folder list).  This would be better than nothing and would still make it MUCH easier to deal with tracks that are not formatted properly.

Bruce
I had the same problem but I was able to resolve it. Try This: Open I-Tunes. At the top of the screen click on FILE. Then click on LIBRARY. Click on ORGANIZE LIBRARY. Check on CONSOLIDATE FILES. This will get all on your music into the I-Tunes Media where SONOS can access it.
Userlevel 2
Are your missing tracks from compilation albums?  Mine had Album Artists tags of “various artists” or something similar.  Deleting the Album Artists tag on the offending songs enabled Sonos to pick them up and index them correctly.  
Had the same problem due to many songs being protected.  Followed this helpful website an all my songs are now in Sonos.
http://computers.tutsplus.com/tutorials/how-to-remove-drm-from-your-music-with-itunes-match--mac-592...
I have just imported 250 CDs into iTunes and from there onto a NAS drive. 15 of them would not show up in the Sonos Music Library.

I have spent ages trying to find out what the difference was between these 15 discs and the rest. Eventually, and by chance, I discovered that I imported the 15 into iTunes using the WAV encoder option. All the ones which show up in Sonos were imported using the AAC encoder.

It's difficult to find this out because if you click on Get Info for the album as a whole, it doesn't show you which encoder was used. You have to click on Get Info for an individual track and look under the File tab.

I have now re-imported these 15 discs into iTunes using the AAC encoder option and they now show up properly in the Sonos Music Library.
Sonos supports wav, however wav doesn't support proper tagging, so Sonos did find them, it just doesn't have any metadata to use for the display of those tracks, if you look in the folders view in Sonos you'd find them in there.
Fair enough, except I don't have a Folders View. In any case, if WAV files don't show up in the library index they're not exactly accessible.
I'd be willing to bet you do, on the phone controller it's Music Library - Folders. Should be there in the pc controller as well, although I can't check right this minute.

Anyway it's just making the point that the tagging is the important bit, that needs to be done right, something you can't always rely on iTunes for.
just downloaded and installed the app on both my phone and laptop, now I can't find my iTunes music library. Only a small fraction of my library is showing up on the Sonos app. I've read most of the suggestions but still cannot get it to find the bulk of my music library. It doesn't look like this is going to be an easy fix. I might just take back the sonos system and opt for a bluetooth system.
Have you actually shared your iTunes library and told Sonos where it is?
I did finally get it to work but the process was not at all straight forward, it was quite frustrating. It doesn't help to google for instructions, if anything that just totally complicated everything. While I did get it to work, unfortunately, I can't advise how! All I can say is if you're patient and persistent, you can get it to work. To answer your question, yes.
Mine was working within five minutes of getting it out of the box.
This isn't a technical answer, but I delete the current iTunes profile, and the add it again. Works for me.