Question

Sonos does not work - keeps cutting out


Show first post

62 replies

StopWithTheCrappyUpdates wrote:

You guys must be paid shills. The system was solid for 6-8 months until the update - now it sucks. Unplug them all, then plug them back in one at a time? Tried it. Even took them off DHCP and gave them fixed IP addresses. Still dropping out. Alarms don't work. Grouping falls apart.

When nothing changes but a SONOS UPDATE and the system goes from good to suck - you can bet it was the update.

And explain to me how a lousy interface is the fault of a rock solid wifi? How about alarm group settings that won't stay on? Does wifi affect that? Is the wifi affecting my timer settings?



To the bold? No you didn't. There is no way to take Sonos off DHCP and give it a fixed IP.

As to the rest? If I'm a paid shill, I'm getting paid way too little. ;)
Folks, I thought I would post my fix in the event what I did helps any of you fix your Sonos issue. I have a Series 5 gen 1 unit that began having issues several weeks ago. I was familiar with the sound on cut-out as it reminded me of the same symptom experienced when setting up VoIP networks. In my case packet loss was the issue and the fix was to enable QoS (Quality of Service) on the router. Many of you may have routers with this feature (typically disabled). To enable it you need to log into your router as ADMIN and the setting is commonly found in the Advance section of the menu. My Linksys allowed, by default, me to enable the setting then do a performance test to establish the best performance. Once I enabled this setting the problem and cut-out went away. Good luck - I hope it helps.
I'm having the same problem and changing the wireless signal did not work. My diagnostic is 8268069. Please help, Sonos.
Userlevel 1
Same issue for the first time, tried streaming music from Google play music to a Sonos 1 (using Sonos App), as well as casting from my android device (from Google play music app) using downloaded music only. Music keeps cutting out randomly every minute or so. Diagnostic 8323887. I did a wifi and network speed test and there's no issue at all (download speed on wifi with computer sitting next to the sonos 1 is a robust 200+ Mbps).
I have had Sonos products for a number of years and never had problems. Now they have become so unreliable as to be useless. What the hell has happened to this company? I spent two hours on the phone last week to have my problem seemingly resolved, now it is back and worse than ever. I would urge anyone thinking of spending a fortune on this junk to rethink and go with someone else.
Connection problems which appear suddenly are often caused by network problems, not Sonos problems. The typical cause is duplicate IP addresses. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Modem
Router
Switches or hubs
Wired Sonos units
Wireless Sonos units
Computers/printers
Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.
Oh, my mistake. I didn't realize you were marketing speakers only intended for computer experts. I'm merely a music lover who thought the convenience of wireless speakers would enhance my listening pleasure. However, you might want to reconsider advertising Sonos' ease of set up. That confuses those of us who don't spend all day working on routers and such.
If I may, jgatie was not marketing anything. He's an end user, just like you and I are. He's making a concerted effort to help people with problems, often on their local wifi network, resolve those issue, and get to a place where many of us are, with a rock solid system.

It shouldn't be unexpected to have a reliance for a wifi speaker system to have a certain amount of reliance on a good wifi network. In the majority of cases, there's no need for any special work to be done, however, the very nature of local wifi networks will indeed require the occasional "grooming" to get them back to the same state as when they were initially set up. His recommendation goes in to an extremely easy process by which this can be done. It's only his last two sentences that require any particular knowledge to be done. The rest is just a matter of unplugging things from power, and then plugging them back in to power in a particular sequence. No need to be a computer expert in order to do that process.

I hope that you'll give his post another read, and I think that if you're willing to follow his instructions, you'll find that your Sonos system will be as reliable as I assume his is, and I know mine is.
Also experiencing cutting ins and outs with my sonos system, randomly and very frequently; sometimes 2 times within a minute time.

Diagnostic number 8356866
I just started experiencing the same problem as well. Tried everything from rebooting, etc. Yes, I am a computer/network expert. Have the latest and greatest network/wireless system..........no luck! I then read kmarlow's post and plugged a player into a wired connection on the other end of house and magically it all started working again. Go figure!!!! Thanks kmarlow!
jgatie wrote:

[b]There is no way to take Sonos off DHCP and give it a fixed IP.[b]


First - before peddling assumptions as proof, there are simple things like packet captures that one can run on their network to determine if duplicate IP addresses are being assigned, if firewalls are blocking specific traffic, or if some other network conflict exists. Access points can display radio interference information to help you pick the best channels. Quality of service can be manipulated to give your Sonos traffic priority over other traffic on your network, etc. Some of these may help, some may not. I see a lot of low quality information being spouted here as causation and solutions, especially bolder statements by @jgatie as gospel. In response to @jgatie’s presumptuous and incorrect statement about assigning static IP addresses to Sonos speakers, I in fact have static IP assignments to all of my Sonos speakers by MAC address reservation via my DHCP server. Yes, you can use DHCP to reserve static IP addresses to anything on your network. With all that said, it has had no positive impact on my sound dropouts.

I have no dropped packets, no IP conflicts, no firewall conflicts, no rules blocking specific applications - essentially no network cause I can yet attribute my Sonos woes to. I was contemplating buying more speakers just this week, too - not until Sonos fixes this problem.

I had a good first few weeks with my Sonos Play:3 stereo pair and Play:1 until about a week ago when music started fading in and out from all sources - Amazon Music Unlimited, Spotify, iTunes and randomly on different speakers like someone was playing with the balance knob. I even connected one of my Play:3’s to my gigabit switch to form a SonosNet with no improvement.

I don’t have answers yet and am still looking. My search may prove there is nothing I can do and this is indeed some software issue. It is however frustating and a waste of time attempting some other commenters’ advice. If you have a hypothesis, please test it and share your proven solution. If things don’t help, saying that also helps. Please stop posting junk answers, though.
I am also extremely frustrated - I can’t play podcasts for more than a minute or two without the speaker cutting out and skipping to another episode. I wanted a Sonos because it was supposed to be more reliable and better quality than a Bluetooth speaker. I have tried to follow people’s various instructions with suggestions of how to fix the problem. I have read through the many many different pages /topics on this forum devoted to this same issue. It shouldn’t be this hard to get the product to work! I don’t think it’s unreasonable to expect to set up a speaker according to its instructions and then be able to actually use it. I have great WiFi that’s works for everything else I own- but I don’t have experience troubleshooting WiFi connections, IP addresses, etc. If that was a requirement to own a Sonos then they should stop marketing this product as easy to set up and extremely reliable - sorry that’s just not true. If this many of us are having the exact same problem it seems like it’s an issue with the product, not the users. I never post on things like this but I am hoping if people continue to post, Sonos will have to do something to fix the issue.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)