Sonos does not work - keeps cutting out


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

105 replies

StopWithTheCrappyUpdates wrote:

You guys must be paid shills. The system was solid for 6-8 months until the update - now it sucks. Unplug them all, then plug them back in one at a time? Tried it. Even took them off DHCP and gave them fixed IP addresses. Still dropping out. Alarms don't work. Grouping falls apart.

When nothing changes but a SONOS UPDATE and the system goes from good to suck - you can bet it was the update.

And explain to me how a lousy interface is the fault of a rock solid wifi? How about alarm group settings that won't stay on? Does wifi affect that? Is the wifi affecting my timer settings?



To the bold? No you didn't. There is no way to take Sonos off DHCP and give it a fixed IP.

As to the rest? If I'm a paid shill, I'm getting paid way too little. ;)
Folks, I thought I would post my fix in the event what I did helps any of you fix your Sonos issue. I have a Series 5 gen 1 unit that began having issues several weeks ago. I was familiar with the sound on cut-out as it reminded me of the same symptom experienced when setting up VoIP networks. In my case packet loss was the issue and the fix was to enable QoS (Quality of Service) on the router. Many of you may have routers with this feature (typically disabled). To enable it you need to log into your router as ADMIN and the setting is commonly found in the Advance section of the menu. My Linksys allowed, by default, me to enable the setting then do a performance test to establish the best performance. Once I enabled this setting the problem and cut-out went away. Good luck - I hope it helps.
I'm having the same problem and changing the wireless signal did not work. My diagnostic is 8268069. Please help, Sonos.
Same issue for the first time, tried streaming music from Google play music to a Sonos 1 (using Sonos App), as well as casting from my android device (from Google play music app) using downloaded music only. Music keeps cutting out randomly every minute or so. Diagnostic 8323887. I did a wifi and network speed test and there's no issue at all (download speed on wifi with computer sitting next to the sonos 1 is a robust 200+ Mbps).
I have had Sonos products for a number of years and never had problems. Now they have become so unreliable as to be useless. What the hell has happened to this company? I spent two hours on the phone last week to have my problem seemingly resolved, now it is back and worse than ever. I would urge anyone thinking of spending a fortune on this junk to rethink and go with someone else.
Connection problems which appear suddenly are often caused by network problems, not Sonos problems. The typical cause is duplicate IP addresses. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Modem
Router
Switches or hubs
Wired Sonos units
Wireless Sonos units
Computers/printers
Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.
Oh, my mistake. I didn't realize you were marketing speakers only intended for computer experts. I'm merely a music lover who thought the convenience of wireless speakers would enhance my listening pleasure. However, you might want to reconsider advertising Sonos' ease of set up. That confuses those of us who don't spend all day working on routers and such.
If I may, jgatie was not marketing anything. He's an end user, just like you and I are. He's making a concerted effort to help people with problems, often on their local wifi network, resolve those issue, and get to a place where many of us are, with a rock solid system.

It shouldn't be unexpected to have a reliance for a wifi speaker system to have a certain amount of reliance on a good wifi network. In the majority of cases, there's no need for any special work to be done, however, the very nature of local wifi networks will indeed require the occasional "grooming" to get them back to the same state as when they were initially set up. His recommendation goes in to an extremely easy process by which this can be done. It's only his last two sentences that require any particular knowledge to be done. The rest is just a matter of unplugging things from power, and then plugging them back in to power in a particular sequence. No need to be a computer expert in order to do that process.

I hope that you'll give his post another read, and I think that if you're willing to follow his instructions, you'll find that your Sonos system will be as reliable as I assume his is, and I know mine is.
Badge
Also experiencing cutting ins and outs with my sonos system, randomly and very frequently; sometimes 2 times within a minute time.

Diagnostic number 8356866
I just started experiencing the same problem as well. Tried everything from rebooting, etc. Yes, I am a computer/network expert. Have the latest and greatest network/wireless system..........no luck! I then read kmarlow's post and plugged a player into a wired connection on the other end of house and magically it all started working again. Go figure!!!! Thanks kmarlow!
jgatie wrote:

[b]There is no way to take Sonos off DHCP and give it a fixed IP.[b]


First - before peddling assumptions as proof, there are simple things like packet captures that one can run on their network to determine if duplicate IP addresses are being assigned, if firewalls are blocking specific traffic, or if some other network conflict exists. Access points can display radio interference information to help you pick the best channels. Quality of service can be manipulated to give your Sonos traffic priority over other traffic on your network, etc. Some of these may help, some may not. I see a lot of low quality information being spouted here as causation and solutions, especially bolder statements by @jgatie as gospel. In response to @jgatie’s presumptuous and incorrect statement about assigning static IP addresses to Sonos speakers, I in fact have static IP assignments to all of my Sonos speakers by MAC address reservation via my DHCP server. Yes, you can use DHCP to reserve static IP addresses to anything on your network. With all that said, it has had no positive impact on my sound dropouts.

I have no dropped packets, no IP conflicts, no firewall conflicts, no rules blocking specific applications - essentially no network cause I can yet attribute my Sonos woes to. I was contemplating buying more speakers just this week, too - not until Sonos fixes this problem.

I had a good first few weeks with my Sonos Play:3 stereo pair and Play:1 until about a week ago when music started fading in and out from all sources - Amazon Music Unlimited, Spotify, iTunes and randomly on different speakers like someone was playing with the balance knob. I even connected one of my Play:3’s to my gigabit switch to form a SonosNet with no improvement.

I don’t have answers yet and am still looking. My search may prove there is nothing I can do and this is indeed some software issue. It is however frustating and a waste of time attempting some other commenters’ advice. If you have a hypothesis, please test it and share your proven solution. If things don’t help, saying that also helps. Please stop posting junk answers, though.
I am also extremely frustrated - I can’t play podcasts for more than a minute or two without the speaker cutting out and skipping to another episode. I wanted a Sonos because it was supposed to be more reliable and better quality than a Bluetooth speaker. I have tried to follow people’s various instructions with suggestions of how to fix the problem. I have read through the many many different pages /topics on this forum devoted to this same issue. It shouldn’t be this hard to get the product to work! I don’t think it’s unreasonable to expect to set up a speaker according to its instructions and then be able to actually use it. I have great WiFi that’s works for everything else I own- but I don’t have experience troubleshooting WiFi connections, IP addresses, etc. If that was a requirement to own a Sonos then they should stop marketing this product as easy to set up and extremely reliable - sorry that’s just not true. If this many of us are having the exact same problem it seems like it’s an issue with the product, not the users. I never post on things like this but I am hoping if people continue to post, Sonos will have to do something to fix the issue.
I'm having the same issue after recently switching from a Pioneer speaker to a Sonos. My Pioneer never had this issue. This is really frustrating! My diagnostic number is 8385972.
Diagnostic code = 8395302
Volume keeps dropping to super low for 10-15 seconds every 7-15 minutes. Music keeps playing, though. Help, please.
Badge
Today (25th of January) I downloaded and installed the new Sonos update.
Everything seems to work perfect again. I haven't had any cutting outs; let's keep it like that! I listened to music for 2 hrs straight without experiencing any cutting outs of my 2xplay:3. After that I watched a movie and didn't had any cutting outs either! Felt good.

I haven't changed anything in my wifi- or router-settings or whatsoever. Just installed the Sonos update, that's all.
At the moment I have version 8.3

Glad it works again! No more frustrations. How I look at it right now: I am not gonna install any new updates :)
Badge
It appears it was too good to be true. All of the sudden the 2xplay:3 I have are cutting out again. I didn't do anything special. Just turned on the Sonos-system by using the play-button on top of the play:3.

8436450

It went well for 5 days, after having downloaded and installed version 8.3.
Updating from 8.3 to 8.3.1 didn't change a thing; also cutting out.
Hope this will be fixed soon.
Userlevel 7
Badge +3
HI Beers, I took a look at your diagnostic and there's a lot of 5GHz noise around your PLAYBAR causing some connection troubles with the PLAY:3s. It's not likely that an update can fix it, but that we'll need to do a little wireless troubleshooting there. I'd suggest that you give us a call on our support line.
Also experiencing cutting ins and outs with my sonos system. Two play 1s and one play 3. It's now everytime we use the system. It's gotten to the point where it's embarassing to have people over and play music. We wind up just using a regular old bluetooth, wireless speaker. Please help!!

Diagnostic number 8452936
I've been having cut-out issues with my library music. After it cuts out, I cannot get it going again with my iPhone. I need to go to my iMac, reboot the Sonos App and press play. Then it works.
8452955.
I'm having cut out/skipping issues too. It's so annoying. I swear it has only been happening since updating to version 8 of the player. I have had sonos in the office for a few years now, and its only been the past few months that has noticeably got worse...PLEASE FIX THE BUG SONOS
Has anyone responded from Sonos officially? I have the same issues and I've been running Sonos 5s Gen 1, Sub, 3s for years without issue (except obvious wifi issues) but this is Sonos. I went direct - ethernet connected and it's still happening. Sonos? I'm in over $4K with you guys. I need some love of some kind.
I am having major skipping occurrences which just started today. It seem that this is a widespread issue and Sonos needs to take care of it.
It seems to be getting worse. I’ve had Sonos for 5 years now. Interruptions and drop outs never happened to me up until a year ago. Now I cannot make it 5 minutes into listening without Sonos failing. Hugely frustrated and disappointed. Sonos used to be great but now it’s garbage.
Userlevel 4
Badge +3
Hi, all. Thanks for reporting this issue to us. There are no bugs in the current software that would cause issues of this nature. This is likely a local WiFi issue on each of your respective systems. We can certainly get to the bottom of this for you. Following an occurrence of this issue, please submit a diagnostic and respond with the confirmation number. This way we can identify the cause for you. Many thanks in advance.
aedcharmer wrote:

We have a sonos 1 and two sonos 5 currently. we have set them up EXACTLY as per the instructions. We have exceptionally high internet speed. We have connected our spotify.

Despite updating the sonos (about twice a week as the sonos tech nerds seem to screw it up every time).

It NEVER works. it will play for 3 or 4 minutes then immediately cut out. Or one of the speakers decides not to play. Or the phone or iPad being used as a controller tells us that the music is playing but it is not.

Sonos is proving to be one of the worst products purchased, its adverts suggest interruption free music, whereas in reality it cuts out constantly. Absolutely unacceptable.

Any help would be appreciated considering the ludicrous amounts charged.



I have same problem and my system is hard wired.......

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings