Sonos disconnecting from Wifi and cutting out often

  • 10 October 2017
  • 1 reply
  • 5090 views

We use Sonos in our studio to control the volume of music. We have two Ipods in use, one to stream the music through Rockmyrun and the second with the Sonos app to control the volume.
Lately we have many cut outs with the Sonos app saying it is disconnected. We have added a modem specific to our music, changed the router to bridge mode amongst others, created a wifi specific to Sonos. However this problem continues to happen despite all our attempts.
When we test the speed it's fast enough and should be working.
What options can we take to fix this problem?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

There are a couple of potential issues to be looking at.

First, of course, is Wifi interference. Sonos has a good FAQ to read about here: Wifi Interference FAQ

The other initial possibility is a duplicate IP address issue. I'd recommend powering off your iPods, the Sonos devices, and then reboot the router. Once the router is back up and running, then power on one iPod, and let it fully boot. Then move to the next iPod and allow that one to fully boot. Move on to your first Sonos device, and plug it back in, and allow it to fully boot as well. By the way, if you have one of your Sonos devices plugged in to your router, do this one first. As before, once it's fully booted up, move on to the next, etc.

Finally, if neither of these potential solutions work, I'd recommend that you submit a system diagnostic, and post the number here, for the folks at Sonos to look at.