Question

Sonos Defaults Music Source Volume After Switching from Line-In

  • 10 May 2017
  • 3 replies
  • 441 views

When I select any music source (i.e. TuneIn) while Line-In is playing, the volume always defaults at 25% in the new source. This becomes annoying when I use another automation device like Smartthings to select the new source. Volume settings sent from the automation during switching is ignored by Sonos. My work around is to delay sending volume settings by a second or more. Is the 25% volume default a feature?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 1
Badge +1
Hi Pchamp1010,


Thanks for reaching out about the mismatched volume levels. I'll do my best to get it sorted out.

It is expected behavior to have some variation in the volume levels from one source to another. The Line-In source can especially be dramatically different compared to streaming source like TuneIn, as it depends on the type of device connected, what the audio output level of that device is, etc. You may benefit from adjusting the line-in source level. This will allow an increase or decrease to the amount of signal the Line-In gets and may ultimately balance the volume level compared to TuneIn.

* From the Sonos music menu, touch Settings > Room Settings. Tap the Sonos product the source is connected to. You may need to experiment with the source level to find what works best for your needs.

Let me know how that works out or if any questions come up.
Hi Pchamp1010,


Thanks for reaching out about the mismatched volume levels. I'll do my best to get it sorted out.

It is expected behavior to have some variation in the volume levels from one source to another. The Line-In source can especially be dramatically different compared to streaming source like TuneIn, as it depends on the type of device connected, what the audio output level of that device is, etc. You may benefit from adjusting the line-in source level. This will allow an increase or decrease to the amount of signal the Line-In gets and may ultimately balance the volume level compared to TuneIn.

* From the Sonos music menu, touch Settings > Room Settings. Tap the Sonos product the source is connected to. You may need to experiment with the source level to find what works best for your needs.

Let me know how that works out or if any questions come up.



That’s for line in. How do we set Auto Play Volume for music services, like Google Play Music?
When I select any music source (i.e. TuneIn) while Line-In is playing, the volume always defaults at 25% in the new source. This becomes annoying when I use another automation device like Smartthings to select the new source. Volume settings sent from the automation during switching is ignored by Sonos. My work around is to delay sending volume settings by a second or more. Is the 25% volume default a feature?

Do you use SmartThings? I tried it, and it seems to need some Samsung SmartThings hub?

I use Yonomi, but I don’t see how to delay an Action.