Question

sonos crossfade

  • 11 September 2019
  • 21 replies
  • 444 views

Anyone else having problems with crossfade since last update on iOS v10.4. Was working fine before the update but now greyed out. Thanks.

21 replies

If controller options are greyed out it usually means a version mismatch. Check for software updates, in Settings/System.
Huge thanks for quick reply ratty! My updates are automatic but I did do a manual refresh and was told all up to date. Looked at system info and all sonos components (five in total, beam and left and right rears, connect amp and bedroom sonos one all show version 10.4. From what I can tell no mismatch? I’m Playing from Spotify but generally never had a problem with crossfade ( other than the sonos app always reverting to off). Have uninstalled and reinstalled both Spotify and sonos apps? Cross fade was definitely running fine last weekend, updated to 10.4 yesterday and now it’s suspiciously greyed out?! Lol.
You'd better submit a diagnostic, post the number, and Sonos Support can take a look.
Userlevel 7
Badge +20
Working OK for me. What source are you playing from? The source needs to be 'cross-fadeable', so to speak.
Edit: I've just read the original post properly. Working OK for me on Spotify via the Sonos app., just for reference.
Userlevel 2
I’m having the exact same issue. Was working fine, now greyed out. All up to date.
Userlevel 7
Badge +21
Which platform are folks seeing it work/not work on? Bug could be specific to platform type.
Userlevel 2
Badge +5
I have the same problem... anyone has a solution?
Having same problem. Please help. This is a huge listening issue for me.
Userlevel 7
Badge +26
Hi guys, crossfade isn't always an option for all sources, or at all times. Using the Spotify App to play on Sonos, I don't believe crossfade is available, but if you have a playlist that's been loaded into the queue with songs fro Spotify, it should be.

If you're seeing crossfade greyed out, it's best to be clear about where exactly you're playing from (what the source is and how it was started), so we can check it out.
Ryan,

I have had sonos for 8 months now and just last week this became an issue. I have used sonos to play my spotify playlist and anything from spotify and have always had the crossfade option through Sonos. Now it is greyed out. Click three dots while listening and can not interact with crossfade option. Extremely frustrating.
Userlevel 2
Badge +5
Ryan, same for me. This issue is since last week. For me it’s a big problem too...
Hi guys, crossfade isn't always an option for all sources, or at all times. Using the Spotify App to play on Sonos, I don't believe crossfade is available, but if you have a playlist that's been loaded into the queue with songs fro Spotify, it should be.

If you're seeing crossfade greyed out, it's best to be clear about where exactly you're playing from (what the source is and how it was started), so we can check it out.


Added bold to re-emphasize Ryan’s request.
Userlevel 2
Badge +5

Hi guys, crossfade isn't always an option for all sources, or at all times. Using the Spotify App to play on Sonos, I don't believe crossfade is available, but if you have a playlist that's been loaded into the queue with songs fro Spotify, it should be.

If you're seeing crossfade greyed out, it's best to be clear about where exactly you're playing from (what the source is and how it was started), so we can check it out.
Added bold to re-emphasize Ryan’s request.

When I’m listening Spotify from the Spotify app with my iPhone, iPad and from Alexa...
Yes, using Spotify from my phone listening through my Sonos speakers. In the Sonos app the crossfade is greyed out. Unable to be interacted with.
Userlevel 2
Badge +5
@Ryan S Hello! Can you help us with this problem? Thanks in advance!
Userlevel 7
Badge +26
Thanks for the details everyone. Spotify doesn't have crossfade as an option when using Spotify Connect (the feature where you use the Spotify app to play directly to speakers such as Sonos). Previously, you could start the stream from Spotify, then go to the Sonos app and turn crossfade on. This isn't available available anymore.

If you start the stream using the Sonos app instead, you'd be able to turn on crossfade, as it's currently a Sonos feature that isn't built in to the Spotify app.

I'll let the team know that you're looking for this, but I don't have any specifics on if it'll come back.
Userlevel 2
Badge +5
Thanks for the details everyone. Spotify doesn't have crossfade as an option when using Spotify Connect (the feature where you use the Spotify app to play directly to speakers such as Sonos). Previously, you could start the stream from Spotify, then go to the Sonos app and turn crossfade on. This isn't available available anymore.

If you start the stream using the Sonos app instead, you'd be able to turn on crossfade, as it's currently a Sonos feature that isn't built in to the Spotify app.

I'll let the team know that you're looking for this, but I don't have any specifics on if it'll come back.

Before the last update it was possible. I'm always listening music with the Spotify app and the crossfade was available in the Sonos app this way... For me it's really annoying...
Userlevel 7
Badge +26

Before the last update it was possible. I'm always listening music with the Spotify app and the crossfade was available in the Sonos app this way... For me it's really annoying...

That's correct, the last update had a few Spotify changes, most of them not visible in any way and reliability related, but this crossfade change was one minor one that did get included.
The customers do not find this to be a MINOR change. It is extremely important to the quality of our listening.
I’m having the same issue. As of last week stopped working. Needless to say that this is a big deal to me. Sonos please do your best to revert this feature back

thanks
Userlevel 6
Badge +13
Was the removal of the feature detailed in the release notes?
Is it a Spotify thing or Sonos?

Reply