Question

Sonos Controller iPhone/iPad Not Connecting to Speakers

  • 1 October 2016
  • 4 replies
  • 405 views

Updated my internet router. Now internet is 5 times faster, but Sonos no longer connect. Always show you need to add at least one speaker. Have been using Sonos for three years without problem. Please help!

Reboot everything in order. Since it is new SSID for wifi, all other devises reconfigured and works great except Sonos.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

How to connect Sonos to your new router.
Done all that. I have a bridge wired to router. When I check about my Sonos system, I saw the bridge and version and IP. Sometime all speakers show; and all the sudden disappear and ask me to add speakers. Very frustrating. Any other things I should try?
You may have interference between the new WiFi and SonosNet. They should be at least 5 channel numbers apart, and the router shouldn't use 40MHz channel width at 2.4GHz. Virtually all routers default to channel auto-selection, and some greedy routers default to 40MHz at 2.4GHz.

Also, make sure you have at least 50 cm physical separation between the BRIDGE and the router. More if you can manage it.

If things remain broken then try wiring one of your Players in place of the BRIDGE. A failing BRIDGE power supply could also account for your symptoms.
Thx. I have two BRIDGEs. One is next to the router so I move it away from the router. So far yesterday whole day was OK. Hopefully stays the way it is. Both my wifi and SonosNet use channel 6. It has been the same channel for the last two year with the old router.