Question

Sonos Controller iOS variable lag finding system.

  • 14 September 2020
  • 6 replies
  • 60 views

I'm having a weird error in the last few weeks where the Sonos Controller app on iOS is having a hard time connecting to my Sonos system. It usually lags for about 30 seconds, shows the "Sonos cannot be detected" message, but then suddenly connects. But today it just refused to connect to the system. Disconnected and reconnected the Sonos components via my router, but no luck for a while. Eventually it started working fine, but I'm not entirely sure what's going on or why it's happening. I was just wondering if anyone else is having this problem?

 

iPhone 11 Pro Max

iOS13.7

Sonos S2 12.0.6


6 replies

Userlevel 4
Badge +12

Hi @duck13, thank you for reaching out.

For us to check, we would like you to take a diagnostic from the Sonos app and post the confirmation here.

Setting > Help & Tips > Submit Diagnostic.

We would prefer the diagnostic taken after the issue occurred; because the diagnostic will have the logs that we can check for.

After taking the diagnostic, you can follow this support article for common troubleshooting steps you can take.

If you have other concerns, feel free to reach out.

Hi there,

I submitted diagnostics; the number is 1772231279.

 

Thanks for looking into this!

Userlevel 3
Badge +10

Hi @duck13.

Welcome, thank you for reaching out to Sonos Community.

Base on the Diagnostic report I notice that the Wifi channel you're currently connected to is kinda congested.

Try to switch to channel 6.

To do this need to temp wire again one of the speaker to the router then go to Settings » System » Network » Sonosnet channel 6

Let us know if it works. If you need help with any other information, please be sure to let us know.

I don’t think this is a solution per se, but I wired one of the rears in my playbase/play:1 setup to the router so I could use Sonosnet and that seemed to fix things. I did change the channel to 6, but can’t tell if that actually solved the problem before deciding to just use Sonosnet. It looks like even on Sonosnet there’s some lag time for the iOS controller to find the network, but it is much faster than how things were before. It does seem like a cop-out solution though...

I spoke too soon. I’m still having lag with the controller on iOS and on my Mac in finding the Sonos system, to the point that on the Mac controller it’s showing the warning message that it’s having trouble finding the system.

Userlevel 3
Badge +10

Hi @duck13.

Welcome, thank you for reaching out to Sonos Community.

Since it's a recurring issue now, I would like to recommend calling our customer phone support on this so you can be assisted with more thorough and in-depth troubleshooting steps.

If you need help with any other information, please be sure to let us know.

Reply