Sonos Connections on a New Orbi Wifi Fix

  • 1 July 2019
  • 3 replies
  • 664 views

Spent a few months figuring how to get my Sonos speakers working on a new Orbi Wifi. The changing of Wifi routers effectively bricked 2,500 bucks of Sonos products for me. It just wouldn't work on the new router. My setup is a Boost (connected by wire to Orbi router) and 5 Play Ones, a Playbar and Sub; all wifi connected.

The boost (and probably a speaker if it's hardwired into the Orbi router) will be seen by the Sonos Controller App, but the wireless connections would not transfer over or be seen by Sonos. Factory reset or no factory reset. The issue lies in my Orbi router. When I would try to add a wifi speaker in the Sonos App, it would time out and fail. Every time. Upon some sleuthing, for whatever reason, I noticed the Orbi router would allocate an IP to the speaker, but in the Orbi device settings, it would be set up as "disabled" and therefore the add new speaker would time out and fail in the Sonos App, then the speaker's IP address would disappear in the Orbi app as well since I didn't "enable" it in the device settings. You manually have to "approve"/slide the new Wifi Sonos speaker IP address to "enable" in the Orbi App to finish assignment of an IP address, which then allows the Sonos Controller App to finish seeing and capturing the Wifi Sonos speakers.

So my fix went like this:

  1. Connect the boost by wire to the router (i'm guessing a speaker would work also)
  2. Open Sonos Controller App (it should see whatever is hardwired to the router, my Orbi auto enabled the Boost, but if it doesn't, keep reading, you will have to "enable" in the Orbi app).
  3. Factory reset the Wifi speaker (i know Sonos is all against this, i'm just showing you how it worked for me on 7 speakers and a Sub.; i factory reset all of them; i did this process individually for all speakers and sub)
  4. After the factory reset, I restarted the speaker and selected "add new speaker or sub" in the Sonos App. Follow the directions in the app.
  5. Have your Orbi app open on the same device or another device, you will need to enable the new speaker's IP address. This is key as you will have to toggle back and forth between the Sonos Controller app and the Orbi app.
  6. During the final setup stages of Sonos Controller installation of the new speaker it will "hang" a little. During this final part of the install step is where you will have to be vigilant at seeing when Orbi sees it and gives it a "disabled" IP address in the Orbi app.
  7. Keep refreshing your Orbi app's "device settings" page by going back and forth between the home screen and device settings. After about 15-40 seconds of the final installation part of the new speaker, a new Sonos speaker will show up in the Orbi device settings, with a unique IP address but will be "disabled". My orbi required me to approve the new IP address by sliding the toggle from "diabled" to the green "enable".
  8. Once enabled in the Orbi app - device settings, the Sonos Controller finished installing the new speaker, and since it was factory reset, updated the firmware. It was now visible in the Sonos Controller App.
So the issue was my Orbi requiring a manual approval of the IP address to give the wifi Sonos speakers. There's a key 30 seconds in the process above where the Sonos app is almost finished installing, but you have to get in the Orbi app to toggle the wifi IP address to "enable". That was the issue, not my speaker but the IP allocation process of my Orbi. I thinks it's a security feature of the Orbi to prevent subnetworks leaching onto a wired connection.

3 replies

Userlevel 7
Badge +21
I don't think your situation is standard for Sonos/Orbi setups. I have an Orbi network as well, and didn't have to do any of the steps you described. I just plugged my Bridge into the Orbi router (by way of a switch) and everything worked as expected. I certainly did not factory reset my speakers when I switched over, and have had no issues adding new speakers to the network.

It sounds like you have some sort of security setting on the Orbi that requires all devices to be manually added to the network? Are you not using DHCP?
Cable Modem does not route
Orbi is my router: Running DHCP on Orbi
Access control on Orbi router is set to "enable all connections automatically"

For every nonSonos wifi connection (I have about 20), it gives an IP and enables them automatically.
For the wifi connected Sonos speakers it gives an IP, but doesn't enable them automatically, I have to be in the Orbi network device screen to enable the Sonos speakers, and if I wait too long it releases the IP for the Sonos and the speaker doesn't get admitted to the wifi network.

It's an Orbi issue (not enabling Sonos automatically) from what I can tell. The "enable all connections" doesn't cover my Sonos products for whatever reason.
I had a similar problem after installing an Orbi route which set up to have the same network info so I wouldn't have to configure all my devices to run on a different SSID. After an hour of frustration, PROBLEM SOLVED! Short answer: rebooting is your friend. Unplug all speakers and the TV if you have a PlayBar. Plug them all back in. Then open your Sonos app and see if things work.

The background: After the router install, all the speakers showed up on my Orbi network.Then I opened the controller app on my iPhone and it couldn't find the Sonos system. I tried closing Sonos app, reopening it, forgetting network, and reestablishing... Then my spouse turned on the TV I discovered all the speakers worked - sound being played through all of them -- but the Sonos app still wouldn't find the speakers. I tried connecting one of the speakers via ethernet cable as suggested on the support site, but all that did was add that speaker in the app but sound wasn't played through it, sound was still playing through all the others speakers. I unplugged the Orbi satellites, thinking that I needed to simplify the mesh network for the initial Sonos app connect. No dice.

I unplugged one of the speakers to move it to another room and then plugged it back in. As soon as I reopened the Sonos app, the speaker I had unplugged and plugged back in showed up in the Sonos app, AND sound played through it. All of the other speakers still had sound, but only the one I had unplugged showed up in the app. So then I unplugged absolutely all of the Sonos speakers and plugged them back in. VOILA!! They all showed up in the app!

But I discovered that I could play music but not TV sound. So I unplugged both the TV and the PlayBar, plugged them back in and now everything works as desired and intended. YEA.

Moral to the story, when making big configuration changes, unplug everything and plug it back in before diving down the rathole of frustration. Rebooting is a magic solution.

I don't know if this will solve anyone else's version of this problem, but it was a very simple solution for me.

Reply