Question

Sonos - Connection to Spotify was lost

  • 13 December 2016
  • 48 replies
  • 2933 views

Just like other users. 🙂 Have tried power off sonos bar, play 5, connect, and then rebooting router, delete account off sonos, re-add account.
Your diagnostic number is: 6860916

Thanks.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

48 replies

Can any Sonos staff help out on this? Diagnostic number is: 6860916 and still waiting for response. 😕
Userlevel 7
Badge +21
If you're desperate for a reply I'd give them a call - wait times are high at the moment due to the recent software update and the proximity of the holidays
Since update can't connect to Spotify
Diagnostic number is 6868106
Userlevel 7
Badge +26
Hey guys, we're currently working with Spotify on an outage around not being able to connect to Sonos players through their app. It's under investigation right now.

Can any Sonos staff help out on this? Diagnostic number is: 6860916 and still waiting for response. :-/

There's a lot of wireless interference in the area, so I'd suggestion changing the wireless channel on Sonos to channel 6 or 11. But with the current outage this might not be noticeable immediately.
Hey guys, we're currently working with Spotify on an outage around not being able to connect to Sonos players through their app. It's under investigation right now.

Can any Sonos staff help out on this? Diagnostic number is: 6860916 and still waiting for response. :-/

There's a lot of wireless interference in the area, so I'd suggestion changing the wireless channel on Sonos to channel 6 or 11. But with the current outage this might not be noticeable immediately.


Hi there, I've tried switching to 6 or 11 after your reply. It has been 4 days and I'm still getting connection lost errors. Diagnostic number is: 688807 please help!
and also: 6888086
I'm struggling........I have 2 Play One's and they are connected/ing to Spotify but my Play Bar is not. It works fine through the Optical lead for the TV but you would expect that. Is this the same problem that is being outlined above?
Userlevel 7
Badge +26
and also: 6888086

Thanks, there's still an issue with Spotify on Sonos affecting some regions, Australia is the main country with the issue your system is showing on the diagnostics. You don't need to worry about the wireless for the moment as this isn't unique to your household or environment. This issue is well under investigation and we're working with Spotify to get it corrected.
Userlevel 7
Badge +26
I'm struggling........I have 2 Play One's and they are connected/ing to Spotify but my Play Bar is not. It works fine through the Optical lead for the TV but you would expect that. Is this the same problem that is being outlined above?

I'd be happy to take a closer look, can you submit a diagnostic from your Sonos system and reply back with your confirmation number?
In Australia and experiencing this annoying Spotify-disconnecting issue!
Love the idea of the new Spotify features, but with update and the lost of reliability OLD features ( of the Sonos App) is painfull!
Same here. I hope they fix this VERY soon. Getting very frustrating. Was working fine on Sonos Beta.
In Australia and experiencing this annoying Spotify-disconnecting issue!
Love the idea of the new Spotify features, but with update and the lost of reliability OLD features ( of the Sonos App) is painfull!
Same issue for me, has been the case since the Sonos update to integrate Spotify a month or so ago and I too have tried all the steps including factory resets. Diagnostic is: 6894143. Really killing my usage as all I do is stream from Spotify! No Christmas music is very frustrating! Please can I get detail and a respnse from you Sonos.
Userlevel 7
Badge +26
Hi CLivers, looking over that diagnostic you're also hitting that issue I mentioned earlier. It's being worked on right now, but I don't have specific details on when it's going to be resolved. I know the team's giving it a lot of attention though.

Sorry for the trouble.
Diagnostic 6896107 sent.
... Would like to play music again over the xmas holidays please !
Userlevel 6
Badge +3
Diagnostic 6896107 sent.
... Would like to play music again over the xmas holidays please !


Hi, reviewed your diagnostic and found a high level of WiFi interference. This is very likely the cause of the issue.

At the moment your Sonos system is communicating with wireless channel 6. Mind testing the other two Sonos wireless channels 1 and 11 for 20mins each.
Here's an article explaining how to change Sonos WiFi channels.
Hi Ryan, is there any update on the resolution of this issue? I've been having the same problem for about a week now, unable to play spotify through sonos controller (and spotify ap), error "connection to spotify was lost".
Same problem. Really a shame that a high-end product has such poor support and offer no solution. This thread has been here for three-four years, for different reasons, but always same issue. Please fix! Diagnostic: 6902371
BTW, have tried all suggestions coming from Sonos team .
Same issue with my Spotify account on a Play 5. Connection is lost. Won't play anything.

Strange thing is, I've also added my wife's account and it is working fine so this is nothing to do with my router, wireless interference, the colour socks I'm wearing etc.

Diagnostics 6905618 submitted.
Some more info that may be useful.

I've just discovered my wife's Spotify is still on Premium until the end of December and that she also hasn't changed her region to Australia after we moved here from the UK last month.

I'll test changing my region back to GB and see if that has any effect. Don't really want to reactivate Premium just to play through Sonos though.
My Premium Spotify music streaming is no longer working over Sonos. The problem coincidentally started when Spotify announced that that we could play music from our Spotify app directly to Sonos. From the Sonos app, when we click on the Spotify music source, there is a "Unable to browse music" message. My Spotify account works fine when I play it from my iPad. I've tried deleting it and re-installing in the Sonos app but this did not help. Anyone have a similar experience?
Update to my above comment. Spotify app is now able to find Sonos system and send music to Sonos. Still can not play Spotify from within Sonos app but at least there is one method to hear music from Spotify now.
Unfortunately it seems you can only control Sonos devices via Spotify with Premium so the workaround doesn't work for non-subscribers.
Getting the same issue, please take a look at diagnostic number 6916506
Still having the same issue, cannot run Spotify through Sonos controller or through the Spotify ap - extremely frustrating to have invested in this system and it doesn't work. Not really a good time of year to have activated a system upgrade and it needs to be fixed please