Sonos Connect will not do multi-room if connected wirelessly

Badge +1

I recently acquired a used Sonos Connect (Gen1) with a view to integrating my hifi (in a separate room) with my Sonos network of room speakers in the rest of the house.  When connected by Ethernet cable, the Connect participates in multi-room play without a problem.  When connected wirelessly, as soon as other rooms are included in the group, the Connect ceases to play while the other rooms continue to do so.  I thought the location it was in might have only a weak wireless signal but this problem occurs (wirelessly) wherever the Connect is located.  None of the other speakers have a problem connecting wirelessly.

I also use a Sonos Bridge connected directly by Ethernet to the router to facilitate wireless connectivity.

The reason why this cannot be solved simply by using a wired connection is that the room where the Connect is to be used cannot be reached by that method.

Is this a configuration/set-up issue or is the Connect faulty?

Thanks in advance for any advice.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

33 replies

First question - did you factory reset the Connect before adding it to your system? If not, you need to do so, and then add it again.  Then we can review the situation.

As is often remarked in such situations, one should suspect the Bridge until proven otherwise. Their power supplies have a habit of degrading with age. As the voltage falls away the most common symptom is a degradation in wireless performance. 

Userlevel 7

Hi @milesman 

To add to @John B comment the Bridge is an obsolete device and is known to cause problems with today’s Sonos software. You might consider replacing the Bridge with the Sonos Boost. Furthermore I suspect the last nail in the Bridges coffin will come when Sonos S2 software is released in May or thereabouts. 

Edit: Although good reinforcement...  @ratty’s and my post crossed. :relaxed:

Badge +1

Thanks for the replies so far.

The Connect was supplied having had a factory reset and I took that on trust.  Certainly it was necessary to perform a number of OS updates as part of the installation process.  I guess I could do another factory reset to be sure.

I note the remarks about the Bridge and I appreciate that using legacy equipment is likely to bring its own issues.  I could have bought a Sonos Port but I felt that this would be a costly solution to what has to be seen as a relatively peripheral requirement.

Your other equipment locks you into S1/legacy territory, unless and until you take action, so I can see why you may not see the Bridge as an issue on that score. However they are really old wireless tech, notwithstanding the tendency of their power supplies to eventually wilt.

Just as an experiment, try substituting another player -- other than the ZP100 -- for the Bridge. 

Badge +1

Thanks, @ratty. None of my players is located where an Ethernet connection can be made - I presume that is what you’re suggesting - as the router is in the cupboard under the stairs!  But, as an experiement, I’ll try that.

Badge +1

I connected a Play 1 by Ethernet to the router.  The Connect (connected wirelessly) took a long time to deliver an unbroken audio signal to the amp and continued to briefly break the audio stream from time to time.  During a period when it was playing OK, I introduced a second player in the group and the Connect immediately stopped playing.  When the second player was excluded from the group, it took the Connect up to a minute to restart playing.  This happened every time I tried a second player.

Your wireless bandwidth is apparently under strain when grouped, as there are multiple streams flying around. Try changing the Line-In Setting to Compressed.

Badge +1

@ratty, The Line-In on the Connect is not connected to anything and so no settings are available (I assume that’s what you are referring to).  Other players function perfectly well when in the same location as the Connect and group play works perfectly well too.  It is only the Connect that has the problem so I’m inclined to think the issue is with that device rather than the network as a whole.

Have you reset it?

Badge +1

No.  A job for tomorrow...

Userlevel 7
Badge +21

Don’t think of the Bridge as Legacy equipment, it is still supported but it is truly obsolete. Aside from the power issues and the grief they cause it only supports SonosNet v1.0 that has a lot less capability than the v2.0 that anything other than the Bridge and oldest ZonePlayers use.

I recall a chart on which Sonos used which version but can’t seem to find it.

It sounds to me that for once it may not be the Bridge that is to blame.  Having said that, as others have remarked, it is old tech and now prone to problems, so for the purposes of next troubleshooting steps I would do the following:

  1. Power off your router and all Sonos, including the Connect..
  2. Wire the Play:1 instead of the Bridge.  Don’t wire the Connect.
  3. Power on your router and let it come fully up.  
  4. Power on the wired Play:1
  5. Power on the rest of your Sonos, except the Bridge and Connect
  6. Check your system works OK with the Play:1 wired and without the Connect and Bridge
  7. Check in About my System that all your speakers have WM:0 next to them, not WM:1.
  8. Go to Settings, System, Network, Wireless Setup and check there are no WiFi details in there.  If there are, reset (delete) them
  9. Factory reset the Connect as you power it back on. (see link below)
  10. In Settings, System, use ‘Add Product’ to add the Connect wirelessly.  (If it won’t add, wire it and try again).  It will doubtless require updating.
  11. See if the Connect now behaves.  It, too, should show WM:0 in About my System.

I apologise in advance if that doesn’t help, but it should not take long despite the number of steps, and it covers off a lot of possibilities.  If that doesn’t fix it, I am out of ideas I’m afraid.



Badge +1

@John B thank you for this comprehensive guide.  I’ll give it a go later on and let you know how I get on.

Badge +1

@John B I followed all your steps successfully, thanks.  The ZP100 did show WM:1 but this reverted to WM:0 on a reboot.

After getting multi-room working with the wired Play:1, I powered up the Bridge and transferred the wire to it from the Play:1.  Unfortunately, the Connect stopped working in multi-room mode.  I wonder if I should reset the Bridge to factory default and set it up from scratch.

Do you mean ZP100 (which is a Connect:Amp) or the Connect?  If anything connected even temporarily to WM:1 it suggests there are still some Wifi details in your system somewhere.

I think you should dump the Bridge, tbh.  If everything now works with the Play:1 wired, and that is not a viable setup going forward, then I would think about getting a Boost to replace the Bridge.

What did you find when you went into wireless setup?  Were there any WiFi credentials in there?

Badge +1

I mean the Amp.  When I looked at the network settings I was invited to set up wifi and there was no indication of existing wifi credentials. Since connecting the Bridge, my mesh wifi network is showing as an ‘other network’.  I have removed it so that only SonosNet is identified as running on Channel 11 but this has not resolved the problem. Using either of the other two channels makes no difference.

I appreciate your comment about the Bridge.  I shall reset it and reinstall it just to see if it makes a difference but, as you say, I shall probably have to replace it.

ZP100 (which is a Connect:Amp)

I hate to nitpick, but it’s the ZP120 which is the Connect:Amp. ZP100 is older, larger, and with rather more connection possibilities.


If the Connect was working fine multi-room when the Play:1 was wired, but not with the Bridge, then that does rather suggest the Bridge is at fault. Probably its PSU in fact.

If you have access to a meter, test the PSU’s output voltage. It should be a shade over 5.1V DC, and steady. Anything less than 5V, usually accompanied by voltage wobble, and the PSU is an ex-PSU. It is no more.

There are third party compatible PSUs on Amazon, but it would be understandable if you opted to replace it with a Boost.

Since connecting the Bridge, my mesh wifi network is showing as an ‘other network’.  I have removed it so that only SonosNet is identified as running on Channel 11 but this has not resolved the problem. Using either of the other two channels makes no difference.


You have mesh WiFi?  Did I miss this bit of information somewhere along the way?

Badge +1

Thanks for all the further comments.

  • It is an ancient ZP100 Amp.
  • The Bridge PSU is giving a solid 5.12v
  • No you didn’t miss the bit about the mesh because I hadn’t previously mentioned it.  Does that make a difference?  There is an option to use the router’s own wifi but I’m not sure that it would reach all parts of the house where the players are situated.

I have tried to reset the Bridge but I only got a flashing white light when it was powered up with the button pressed. I did get a flashing orange light when adding the product but it was added with its previous device name still showing and I’d have expected that to have disappeared if the reset had been successful.

I agree that the Bridge seems to be the weak link here and it will need replacing.  The only alternative is to cnnect a player via Ethernet but this would only be possible on a continuing basis using a powerline device and our mains circuitry is not very powerline-friendly.

Thanks again for all the advice you have given - it’s been an education.

Hmm. So the Bridge PSU is fine.

When factory resetting the Bridge one has to be very patient. Keep pressing the button and eventually the LED will flash amber.

WiFi mesh and Sonos can need some special care.  Which brand of mesh? How does it Connect to router?  So router wifi is turned off? What is acting as DHCP server?

Badge +1

Hmm. So the Bridge PSU is fine.

When factory resetting the Bridge one has to be very patient. Keep pressing the button and eventually the LED will flash amber.

So I tried again, more persistently, and eventually got the orange, then the green light.  The device was re-registered as part of the process suggesting success.

I now have the Bridge working and one of the players connected by Ethernet to a powerline device, and I’m pleased to say that multi-room playing is working, including the Connect - provided the latter isn’t the first player added to the group.  Hopefully, this solution will keep on working.

Thanks again for all the advice and encouragement I’ve received.


It does seem to me that, as a pioneer in wireless multi-room music, Sonos has been beset with issues around backward compatibility as they have developed and improved their OS and devices over many years.  This is going to get even more challenging/interesting with the advent of Sonos S2….

In your position I would want to know why the system was and is behaving the way it does. The most obvious user-accessible tool is the Network Matrix, an undocumented part of the diagnostics. It displays a basic snapshot of the SonosNet mesh topology.

Note the IP address (x.x.x.x) of one of your players (not the Bridge) and point a browser to http://x.x.x.x:1400/support/review substituting the numeric address. Paste a screenshot here if you’d like some input.