Sonos Connect Orbi Issue

  • 25 December 2018
  • 6 replies
  • 410 views

I have a Sonos Connect connected with Ethernet cable to the main Orbi, and it feeds audio into an amplifier that powers non-Sonos speakers. The Ethernet runs from the 1st floor to the second floor, as our house came with an audio center that houses the amp which is connected to non-sonos speakers throughout the house. An Orbi satellite is also on the second floor.

Typically I stream audio from Spotify. This worked for the first month or so, but then the non-Sonos speakers started cracking and eventually the Sonos would not appear on the wi-fi network. If I bring the Sonos to the first floor and run Ethernet directly from the main Orbi to the Sonos, I can reestablish a connection, but once I move the Sonos back upstair to connect to the Amp, the wifi doesn't recognize the Sonos. This happens whether I add the Sonos to my main network or my guest network.

Please help me!!!

Thanks, Josh

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

What exactly is this 'splitter'? An Ethernet switch, or (rarely these days) a repeater hub? If it's a cable economiser they must be used in matched pairs at either end of a cable run, to carry two Ethernet connections over a single 8-core cable. They can't be used to share a single port.

By the way, is the Orbi in bridge mode?
Userlevel 7
Badge +22
I gave you my thoughts.

Try WiFi only off krbinwith no wires. While working plugged into main (direct to main router not through solitter) Go to settings ... advanced.. WiFi setup. Complete WiFi setup and then take upstairs unwired.

You obviously have an issue with splitter so remove from being wired.
It worked fine originally when wired directly to main router through a splitter. That no longer works. I should have just had everything set-up on wi-fi from the start.

The satellite is too far from the amp to run audio, so I tried to connect the satellite through the splitter. That also failed. I guess all that's left is figure out how to wire it and the other equipment in the audio room without using a splitter for the satellite.

Anyone have any other thoughts?

Many thanks, Josh
Userlevel 7
Badge +22
If I have this straight you can ethernet plug it in to downstairs Orbi and all is fine.

You have an ethernet wire that runs from the downstairs Orbi up to your second floor and it won't work when connected to that ethernet outlet (has something wrong with it). But you need to plug it in upstairs as that is where your Amp is.

Or are you saying it works when hooked via ethernet to router but when you take it upstairs and run it wirelessly it doesn't work. I'm assuing this is your one and only Sonos unit.

Your choices are wire it via ethernet to the Orbi upstairs (Orbi upstairs ethernet ports work same as the main one) or
While wired to your main Orbi downstairs and working go to sonos app settings...advanced...wifi setup and follow wizard. Once done unplug from all ethernet and run wirelessly from Orbi only.
Thanks for the help. I have tried this, but my satellite orbi is on the second floor as is not wired back to the router. Therefore, when I try to wire the Sonos Connect directly to the satellite it doesn't recognize any connectivity.
Userlevel 4
Badge +3
Have you tried wiring the Connect to the Orbi satellite? I have my Sonosnet established by having one of my Sonos speakers plugged in a Satellite (which in itself has a wired backhaul to the router) and works perfectly