Question

Sonos Connect Amps

  • 29 April 2020
  • 7 replies
  • 61 views

Hi, I have 10 sonos connect amps.  Frequently, all amps will not show on my app or will drop out.  When playing music through any zone, the music will also randomly stop playing.

 

I have a diagnostics number 143899102.

 

Thanks for any help.


7 replies

Userlevel 5
Badge +13

Hello @AaronMcK,

Welcome to the Sonos Community and thank you for reaching out with your diagnostic confirmation number. 

I apologize in the delay in responding to your question as we have been experiencing unusually high volumes of support requests and we are doing our best to respond to everyone. 

Can I ask if all of your Connect: Amps are in one location or are the spread out throughout your home? I can see that one Connect: Amp is off on it’s own and connecting via WiFi rather than though Sonosnet to the rest of your system.   

Can you start by changing the Sonosnet channel to 11 through your Sonos app?

Since your home WiFi network is using channel 1 and channel 7 primarily, channel 11 will allow your Sonos system to avoid interfering with your regular WiFi.

It may even bring your Bathroom Connect:Amp back into Sonosnet instead of connecting to your Zyxel access point.

Once you have made this change, reboot your Bathroom Connect:Amp and then remove the WiFi network information from Sonos:

  • Settings> System> Network> Networks> X Remove.

You may also need to check the settings in your Sonicwall router to make sure that your network is compatible with Sonos:

  • Log in to the Sonicwall router.
  • Go to Firewall Settings and select Multicast.
  • Check Enable Multicast.
  • Uncheck Require IGMP Membership reports for multicast data forwarding.
  • Select Enable reception of all multicast addresses.
  • Click Accept.
  • Go to Network and click the Configure button for the LAN zone (X0.)
  • In the Advanced tab, check Enable Multicast Support and click OK.
  • Click the Configure button for the WAN zone (W0.)
  • In the Advanced tab, check Enable Multicast Support and click OK.

 

Thanks for this - I have no Wan Zone (W0) on the router?  Please advise

Userlevel 5
Badge +13

Hello @AaronMcK,

Thank you for your response. 

If there is no WAN Zone (W0) on your router settings, hold of that that until we can gauge how things are going in your system with the changes you have made so far. 

That being said, how are things holding up in your system at this time?

Any improvement on player connectivity or audio playback?

Feel free to include an updated diagnostic report from your system so we can see if there are any other persisting issues. 

If your Sonicwall requires additional tweaking, we may want to look at some screen captures of your router settings, edited for sensitive information of course. 

Cheers. 

Hi - its definitely working a lot better.  There was a W1 setting, so I changed that as above.

 

There would still be occasions where the music randomly stops playing.  Latest diagnostics report is 232044178.

 

Look forward to hearing from you.

 

Regards

Userlevel 5
Badge +13

Hi @AaronMcK,

Thanks for the update. I have a few additional questions about your system, if you don’t mind.

  • Are both your Kitchen and Tik/Tok Connect Amps wired to the same Netgear device? 
  • Is this Netgear a switch, a router or an access point?
  • Is it possible to wire Sonos products directly to your main router?
  • It looks like you also have a Zyxel router or access point in this system as well. I’m curious about where this fits into the mix since your iOS Sonos controller is connecting to it.
  • When you are playing music, what is the source that you are using? 

 

hi - see below

Are both your Kitchen and Tik/Tok Connect Amps wired to the same Netgear device? Yes 

  • Is this Netgear a switch, a router or an access point? Switch
  • Is it possible to wire Sonos products directly to your main router? No
  • It looks like you also have a Zyxel router or access point in this system as well. I’m curious about where this fits into the mix since your iOS Sonos controller is connecting to it. Connects to the switch - there are 4 of them
  • When you are playing music, what is the source that you are using? Radio / line / Apple 
Userlevel 5
Badge +13

Hi @AaronMcK,

I’ve looked everything over again with this in mind. 

You may want to change your Sonosnet channel to 1 from 11 to isolate this network away from your home WiFi network using channel 7 and 13.

 Also check the cables and connections between your Sonos and your switch and then the switch to the router to rule out something simple as a loose connection.

Reply