Sonos Causing Interference


My Sonos system is causing interference with my Paradox wireless alarm system. If I unplug the Sonos units, the alarm is stable. My wi-fi router isn't interfering (Ubiquiti UniFi). With the Sonos unplugged and the wifi running, I have no problems. Is there a way to switch off SonosNet once the system is running on wifi? Alternatively does anyone have a suggestion for how to solve this issue?
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

At a physical level SonosNet uses a standard 20MHz WiFi channel. It won't interfere, any more than a regular WiFi, unless you have a clash of channels.

If you're wiring more than one Sonos device to the network there are other considerations, since an undetected network loop can crash the network. But this would cause everything to grid to a halt, not just a wireless alarm.

Is the alarm system on the WiFi network, or is it proprietary? If the latter, what RF protocols does it use?
The alarm isn't on the wifi network. It's a Paradox alarm which I think uses a proprietary RF protocol. It's functioning at 833MHz. As I say, with Sonos unplugged, I have no problems but when I plug it in, I immediately get interference on the alarm.
Sonos operates at 2.4GHz. There is zero chance of it interfering with an appliance which uses 833MHz.
Paradox notes interference from other 2.4GHz products like cordless phones. I have tested this over a number of weeks though and Sonos is definitely interfering. Is there a way to switch SonosNet off?
In that case Paradox is using the 2.45 GHz ISM band for something or other. 833MHz is much too far away from the band for there to be an issue. Sonos doesn't cause appreciable interference for another WiFi that's a mere 25MHz away.

Are any Sonos units in close proximity to the alarm units? As digital devices they will of course radiate a bit.
Apologies, I just checked and Paradox is on 868MHz not 844MHz. I will try moving the Sonos devices further away.

However, I understood that Sonos could be set up to run over the wifi network. Once you've done that, can one not switch off the 2.4GHz system (as Paradox notes the possibility of interference with that frequency - perhaps a harmonic?)
No worries. The frequency was about right. And Sonos won't interfere at an RF level. Something else is going on.

Yes you can configure Sonos in 'Standard Setup' to use your WiFi. See here. In that mode there's no separate SonosNet mesh; the units communicate over the WiFi channel.
Thanks a lot for your help. Will go back to the drawing board then!
Tried again. If I use SonosNet, I get interference on the alarm system right away.

Switched the Sonos to wifi and still got interference.

I then unplugged the ethernet cable from the ZP120 after having switched to wifi and that seems to have helped. Is it possible that Sonos keeps the SonosNet radios running as long as the ethernet cable is plugged in? So far so good though with just one Sonos unit running.
SonosNet is explicitly active only when at least one Sonos unit is wired. SonosNet maintains its own standard-width (20MHz) channel, separate from the router's.

When no Sonos unit is wired (and the WiFi details have been configured into the system), communication is over the router's WiFi channel only. There is still peer-to-peer communication at certain times, such as when players are grouped, but it's all within the same channel.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings