Answered

Sonos cant see my new wifi network (BT Smart Hub 2 with complete wifi)


Userlevel 1
Badge
  • Trending Lyricist II
  • 22 replies

Incredibly frustrating.  Just replaced my router from a BT Smart Hub 1 to a Smart Hub 2 and despite following the instruction I.e.connect my Sonos Play 3 to the hub via an Ethernet cable and following the app instructions, Sonos can not see my new network even when putting in the details manually.

I have followed the guidance I have seen on here such as switching off smart set up on my hub and checking that 2.4hz bandwidth is activated on the hub.  Even switched the Wi-fi mode from 1 to 2 as someone suggested but to no avail.

i had no problems with setting up my previous router so I think I am competent at following the app instructions and note when connected via the Ethernet cable, the Sonos app sees my two devices and can operate as normal but not if I remove the Ethernet cable then nothing.

Very frustrated can someone help please  

Thank you in advance 

icon

Best answer by Sam69 29 March 2020, 17:49

John B - now that is worth a try and I haven’t tried that but will

I will be lynched by my family but so be it 

I will temporarily switch off 5 ghz and change the mode and see if it will synch and then work after that 

thank you again for everyone’s time and efforts here 

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

45 replies

Userlevel 7

Hi @Sam69 

I’m going to assume that your previous Sonos setup was over Wi-Fi. In that case follow the instructions to fix your issue under the heading below by clicking the link. There are other options in the link as well. Let us know how things sort out.

If Sonos connects through your WiFi network

https://support.sonos.com/s/article/1061?language=en_US

Cheers!

 

Userlevel 1
Badge

Your assumption was correct

Thanks I will check your link and report back

Userlevel 1
Badge

I have completed all the standard connection steps per the link but Sonos cannot see my network despite being connected to my router via an Ethernet cable 

 

with the cable in place works fine but I need Wi-fi access and my devices both won’t pair with the router as can’t see it 

Userlevel 1
Badge

Just to be clear I have done all of the standard steps many times so the problem is not that I don’t know what to do it is simply Sonos cannot connect tio my new Wi-fi router

it doesn’t see the network at all and won’t accept manual vobfigu

Make sure that you have given the SONOS system the 2.4GHz setup details. SONOS does not support 5GHz.

Mother nature is not fair and you may have a hardware issue. A couple issues can strike after a reboot -- leading to frustration andincorrect conclusions. Describe your system for us.

Userlevel 1
Badge

Thanks Buzz

 

i checked the router was set up for both 2.4 and 5 from my hub management system.  Both switched on in settings but my router only shows up as a single option when you look to connect Wi-fi.

i have a Sonos Play 3 and Sonos One set up via Wi-fi.  My router is part of the BT Smart Hub 2 with complete Wi-fi set up ( 2 disks).  My Ethernet cable is fine because when either of the Sonos devices are plugged into the router I can use either device and my Sonos app works as normal but it can’t sync either device because fails when trying to find the network even when doing manual configuration 

Userlevel 1
Badge

If you needed something more than th8s I can check my hub settings etc etc 

Are the bands split, with different SSIDs (network names) for 2.4GHz and 5GHz? Some time ago there were issues with Smart Hubs that used the same SSID on both bands with “band steering” enabled. 

So when you go to Settings, System, Network, Wireless Setup, what exactly happens?

Userlevel 1
Badge

Band steering I think as single network with two bands and it allocates a dynamic channel to each 

Userlevel 7

Both switched on in settings but my router only shows up as a single option when you look to connect Wi-fi.

Hi @Sam69 

IMO therein lies your problem. Sonos is having difficulty finding the 2.4Ghz band. You need to separate them to show as distinct bands.

Userlevel 1
Badge

John B - I don’t understand your question

 

the app tells me to fix a problem then asks whether I have a new router.  It then walks me through the steps - connecting Ethernet cable etc but when it looks for my network it can’t find it 

Userlevel 1
Badge

I could switch 5 ghz off temporarily to synch my device but wouldn’t want to have this permanently off as most other devices work best with 5

is this possible?

Userlevel 1
Badge

The BT Smart `hub 2 doesn’t seem to have the option to split them - you can activate both or one if them

Userlevel 1
Badge

This is my hub set up

 

Userlevel 1
Badge

All my other devices seem to select 5 ghz automatically 

Userlevel 7

Hi @Sam69 

As I beleive separating the 2.4Ghz and 5Ghz bands would resolve your issue unfortunately the BT Smart Hub 2 does not allow band separation.

 

I believe the Hub 2 has something called Smart Setup. Can you disable this and then, with a speaker connected by Ethernet, go to Settings, System,  Network, Wireless Setup.  If there are WiFi details there already, reset them and enter your SSID and password.

I would try this with wireless mode set to 2 or 3, not 1

 

Userlevel 1
Badge

Thanks that was my view as well.  For some reason the Sonos devices don’t seem to be able to synch with my 2.4 ghz signal.

I don’t think there is a way around this - Smart Hub 2 is an increased common router and broadband service I guess my Sonos speakers are now useless and will be without a wired connection for a large number of people

 

Userlevel 1
Badge

Thanks John B - yes I switched off Smart settings and went to mode 2 - no joy

i think Sonos devices can’t synch with 2.4 ghz auto switch setting on the Smart Hub 2 and I have no means to split the network

i think I am only going to be able to connect with a wired connection although this is far from ideal given my router is in the hall way and I have my two devices quite a distance from the router as it is a big house

Thanks that was my view as well.  For some reason the Sonos devices don’t seem to be able to synch with my 2.4 ghz signal.

I don’t think there is a way around this - Smart Hub 2 is an increased common router and broadband service I guess my Sonos speakers are now useless and will be without a wired connection for a large number of people

 

I disagree. Band separation is not essential i am not totally confident about my siggestion but please try it.

Userlevel 7

I guess my Sonos speakers are now useless and will be without a wired connection for a large number of people

 

Whoa...Stop the dive and pull up :relaxed:

All you need do is setup the SonosNet by wiring a speaker or purchasing the Sonos Boost Module for $99-USD.

@John B’s suggestion may work. I just believe in taking the path of least resistance. :relaxed:

Cheers!

Userlevel 1
Badge

Yes it will work perfectly wired as I have already established this when connected via Ethernet cable

what is a Boost Module?

thought I would add that I am very grateful for everyone’s help here in case it doesn’t come across that way

Userlevel 1
Badge

Just googled it - but won’t the Boost just have the same synch problems as my two devices?  Or is the technology more advanced?  I don’t have a problem with the quality of the signal previously and via Ethernet works fine

https://community.bt.com/t5/Home-setup-Wi-Fi-network/Sonos-and-Smart-Hub2-connection-issues/td-p/1921230

Somebody has got it working.