Answered

Sonos can't seem to finish a song

  • 12 October 2016
  • 8 replies
  • 422 views

Badge
I just got 2 5s, 2 3s, and the sub. This is my first day trying them out together.

This is what I've observed:

* reasonably long periods of time with solid playback
* skipping to the next song in the middle of a song
* restarting a song in the middle of a song
* music stops entirely for around 10-30 seconds
* "Can't play this song/station" error occurs frequently
* The app seems to generate "suggestions" rather than commands. Pause, play, volume, all of it doesn't work as expected. It's very Windowsy.

I've got gigabit fiber in a small apartment with no wireless connectivity issues for other devices.

I've got to determine if this is fixable or if I need to return this whole getup.

Sonos is supposed to handle your typical streaming problems, I thought. Instead it creates new problems.
icon

Best answer by Chris 12 October 2016, 02:38

Note: With multiple sonos units I would highly recommend you use Sonosnet by having one unit hooked to your router. I would not want that many units all having to rely on my home wifi.
View original

How reliable is Sonos playback?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +22
If your having these type issues it sounds more like a wireless interference issue.

I would go under settings...advanced...submit diagnostic. Post the diagnostic number here on the forum for a Sonos Tech to review your system.
Userlevel 7
Badge +22
Note: With multiple sonos units I would highly recommend you use Sonosnet by having one unit hooked to your router. I would not want that many units all having to rely on my home wifi.
I concur with Chris. Wire one of your units to Ethernet, or get a Boost to wire. That many units will perform far more reliably separated from the home WiFi.
Badge
Wow, great responses :)

I didn't know about hard wiring one unit. I just happen to have one unit sitting right next to my router. I will figure out how that's done and report back with the results.

Thanks guys!
Wow, great responses :)

I didn't know about hard wiring one unit. I just happen to have one unit sitting right next to my router. I will figure out how that's done and report back with the results.

Thanks guys!


In addition to that, make sure your Sonos wireless channel is different from your router's wireless channel. This will put Sonos on a completely different frequency range from your home WiFi. That way, things like streaming videos or downloading large files via WiFi will not interfere with Sonos.
Badge
OK, for the sake of those that may not know what to do based on the discussion:

1) Plug one of your sonos speakers into your local network using the ethernet port. Most of the time this will mean connecting an ethernet cable from your speaker to the back of your router where you'll probably have 5 ports available.

2) If possible, install a wifi network analyzer on your phone and see what channels are the quietest. I don't think Sonos supports the 5g frequencies, so you'll be dealing with 2.4g channels that are numbered 1 -> 12 or 14. If you don't have a wifi analyzer, log in to your router and determine what 2.4g channel it's using and pick a different number (10-12 is usually good)

3) In the Sonos app, go to: menu / settings / advanced settings / SonosNet Channel and select one of the available channels. You may have to enable 'Connect to SonosNet' in the advanced settings if you haven't done so already.

These instructions are dumbed down enough for me, so I'm sure they'll help others too :)

BTW, since enabling SonosNet and plugging in one of my speakers, I have experienced none of the problems I mentioned above.

I'll report back if that changes.

Thanks
Userlevel 7
Badge +22
Great news Harry
Userlevel 7
Badge +22
Its always good to stick with the non-overlapping channels of 1, 6, and 11

Have home wifi on the most clear, and Sonos on the second most clear of the 3.