Answered

Sonos Beam question

  • 22 July 2018
  • 7 replies
  • 390 views

Badge +1
Hello. I cannot figure out how to do the following: (example)
I'm watching tv with the tv audio coming out of my sonos Beam, two surrounds (One's) and a sub.
I start playing music through these speakers, either through Alexa or via the Sonos app, and still have the tv on in the background but with no sound (because I'm now listening to music).
I then want to switch the audio back to the TV but I cannot figure out how.
I end up having to reset my whole system or get the TV audio back.
PLEASE HELP, how do I switch the sonos system from music back to TV audio.
icon

Best answer by ORLtragic 23 July 2018, 15:58

Hi there - I actually had this same issue. I was able to figure out that there's a way to switch the audio back to the TV via the Sonos app. If you open the app, choose "Browse" at the bottom, you can then choose "TV" - the audio will then switch back to the TV.

Still not ideal, but better than having to power cycle your TV every time. I'm hoping this is something that can be fixed in a future firmware update.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Hi there - I actually had this same issue. I was able to figure out that there's a way to switch the audio back to the TV via the Sonos app. If you open the app, choose "Browse" at the bottom, you can then choose "TV" - the audio will then switch back to the TV.

Still not ideal, but better than having to power cycle your TV every time. I'm hoping this is something that can be fixed in a future firmware update.
Userlevel 7
Badge +21
You should also be able to give the voice command 'Alexa, switch to TV' to turn the audio back to TV source. Since the command isn't for the TV itself, it should work whether you're using an hdmi or optical connection.
Badge +1
They both work!!!!! Thank you so much.
Badge +1
Hi there - I actually had this same issue. I was able to figure out that there's a way to switch the audio back to the TV via the Sonos app. If you open the app, choose "Browse" at the bottom, you can then choose "TV" - the audio will then switch back to the TV.

Still not ideal, but better than having to power cycle your TV every time. I'm hoping this is something that can be fixed in a future firmware update.
IT WORKS! Thank you. The TV option appeared out of no where!
Badge +1
You should also be able to give the voice command 'Alexa, switch to TV' to turn the audio back to TV source. Since the command isn't for the TV itself, it should work whether you're using an hdmi or optical connection.this worked as well! We kept saying “play the tv” or “play the sound from the tv” but not “switch to the tv”
Badge +1
Hi there - I actually had this same issue. I was able to figure out that there's a way to switch the audio back to the TV via the Sonos app. If you open the app, choose "Browse" at the bottom, you can then choose "TV" - the audio will then switch back to the TV.

Still not ideal, but better than having to power cycle your TV every time. I'm hoping this is something that can be fixed in a future firmware update.
try the voice command the other person posted about. It works great.
Can confirm the voice command works. This community is awesome!