Answered

Sonos Beam no longer connects to Sony Bravia TV

  • 11 April 2022
  • 4 replies
  • 1026 views

I have a Beam that is connected to a Sony Bravia X900H TV. It runs on Android & it has the latest update installed. I purchased both the TV and Sonos Beam a little over a year ago. Right out of the box I installed everything & connected the Beam to TV HDMI eARC input. Everything worked great and TV & Beam synced perfectly & sound was great! Then, slightly less than a year after purchase the Beam stopped providing TV sound. The Beam still works & provide perfect sound as part of my Sonos multi-room wifi audio system. So I now the speaker is working. It just does not work with my TV anymore. I’ve tied everything. I unplugged both Beam & TV for 30 sec, disconnected all HDMI cables & reconnected everything. Does not work. I tried playing around w/various settings. Nothing. I bought a new HMDI cable, nothing. I bought an optical audio adapter & connected the Sonos to the TV optical audio input, nothing. At this point I am at a loss. I guess the only thing I have not done is reset both TV & Beam to factory settings. I’m reluctant to go there until I’ve exhausted everything else. I am at a total loss & very disappointed that I go less than a year & now I no longer have Sonos quality audio on my TV. I stuck with my TV speakers. Had I known it would be like this, would not have bought the Beam and instead the Sony TV audio system. PLEASE HELP me resolve so I can bring back the incredible Sonos sound to my TV. Thanks!

icon

Best answer by GuitarSuperstar 11 April 2022, 07:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7

Try this:

Disconnect everything from the TV including the Beam. Unplug the TV and Beam from power for a couple of minutes. Plug them both back in but keep them disconnected. Make sure Bravia Sync (CEC) is enabled in the TV settings and set eARC mode to OFF. Run TV Setup under the Beam’s settings in the Sonos app. When the app instructs you to, connect the Beam to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable. After the Beam has been successfully connected, connect any other devices to the TV.

Thanks GuitarSuperstar. I will try this. I did much of what you stated but not in exact sequence & did not go back to Sonos app to run TV setup. Do I have to use the Sonos-supplied HDMI cable. I thought this cable was source of problem & bought  a new one. I don’t know what I did with the original Sonos-supplied cable. 

Userlevel 7

Thanks GuitarSuperstar. I will try this. I did much of what you stated but not in exact sequence & did not go back to Sonos app to run TV setup. Do I have to use the Sonos-supplied HDMI cable. I thought this cable was source of problem & bought  a new one. I don’t know what I did with the original Sonos-supplied cable. 

You don’t have to use the Sonos-supplied cable, but if you can find it, I recommend using it. The Sonos cables tend to be more reliable with Sonos devices.

OP didn’t reply that this fix worked, but it worked for me. Just made an account to hopefully save someone from the same frustration I went through. Only hiccup was the Sonos setup never identified the eARC, but the tv started recognizing the Sonos Beam anyways. My model is the X90J 65”. Thank you guitarsuperstar for your help!