Answered

Sonos Beam losses connection with + Apple TV 4k + KS9000

  • 28 December 2018
  • 1 reply
  • 222 views

Hi everyone.

I'm a new user of Sonos products, just bought a Beam and I love it, it's really well made and it have a lot of quality, enjoying it a lot, but I started to have some issues, after investigating around I identified what is the source of my problem.

So I have connected the beam using HDMI-ARC, enable the CEC connection (Anynet) and all seemed fine, I change between a PS4, Switch and the Apple TV and works perfectly fine with the audio source sent, no issues at all.

The problem comes when I turn down the TV and leave it for more than 10 mins, once I turn it back on the TV doesn't recognize the Beam at all, I can see it in the ARC HDMI input but it doesn't send the audio anymore, if I look in the settings the TV doesn't show or recognize anymore the option of output audio using Receiver(HDMI), to be able to use it again I need to turn of Anynet on the TV, reboot completely the television and enable Anynet again and setup.

I tested disconnecting inputs and discovered that if I leave the Apple TV disconnected this behavior does not happen, I can leave the TV off all night and in the morning turn it on and it can see and connects to the Beam immediately, I disabled the options in "Home Theater Control" for the Apple TV but this still keeps happening, any idea on how could I solve this issue?
icon

Best answer by GermanFCG 31 December 2018, 16:19

Well, just to let know and maybe it does help someone someday... I fixed the issue, just needed to disable Airplay on the AppleTV, I can't stream photos or videos to the device now (I didn't used much the function honestly) and now I can have the connection over HDMI-ARC with no issues at all, everything was solved doing that, so happy now and will maybe get a pair of Sonos One in the future to improve my setup 🙂
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Well, just to let know and maybe it does help someone someday... I fixed the issue, just needed to disable Airplay on the AppleTV, I can't stream photos or videos to the device now (I didn't used much the function honestly) and now I can have the connection over HDMI-ARC with no issues at all, everything was solved doing that, so happy now and will maybe get a pair of Sonos One in the future to improve my setup 🙂