Answered

Sonos Beam Apple TV and LG OLED via HDMI-ARC loses connection every power on/off

  • 2 February 2021
  • 11 replies
  • 262 views

Setup is LG OLED CX 55” connected to Apple TV via hdmi. TV ARC connection to Sonos beam/sub paired. 

PROBLEM:

EVERY time I power off my devices (aka turn off the TV and appleTV) and power back on at a later time, I lose the Sound to sonos.  
 

I have to go into the sonos app, click on the zone, click on TV as the source, then go into appleTV and restart the system.  
 

Please help/advise! This is a poor process for the money paid into this setup. 
 

icon

Best answer by Ken_Griffiths 3 February 2021, 09:00

My suggestion perhaps wasn’t clear. I appreciate TV Autoplay is set to ‘on’ by default, but my thoughts were to toggle it ‘off’ and then back ‘on’ again. The TV should then Autoplay through the speaker, but I’m guessing you may have toggled the switch back ‘on’ in any case.

The issue sounds HDMI-CEC related, it’s perhaps best if you can ensure that HDMI-CEC is switched on for the TV and switched off for any other devices connected to the TV, except for the Beam.

With LG TV’s that’s enabling both Simplink and Auto-power-Sync to get things working and ensuring the Beam and nothing else is connected to the TV’s HDMI-ARC port (usually HDMI-2)

The Apple TV HDMI-CEC feature can be switched off in its settings (I believe it’s in ‘Remotes and Devices/Home Cinema Control’

Hope that Assists.

View original

11 replies

Perhaps try toggling off/on ‘TV Autoplay’ in the Beam’s Room in ‘Settings/System’ in the Sonos App and see if that fixes it for you.

Thanks for the quick reply Ken!  Upon your suggestion, I toggled TV auto play to “off” as it was already “on”. Unfortunately, the same results ensues. When I power on the appleTV using the appleTV remote to boot up the tv and appleTV, the sound comes through the tv speakers. When I look at the sonos app for the zone, it has no source selected (like it loses the tv source) and I have to manually select tv and restart appleTV to get the sound going through the beam again.  Any other help is greatly appreciated. 
 

thanks again

My suggestion perhaps wasn’t clear. I appreciate TV Autoplay is set to ‘on’ by default, but my thoughts were to toggle it ‘off’ and then back ‘on’ again. The TV should then Autoplay through the speaker, but I’m guessing you may have toggled the switch back ‘on’ in any case.

The issue sounds HDMI-CEC related, it’s perhaps best if you can ensure that HDMI-CEC is switched on for the TV and switched off for any other devices connected to the TV, except for the Beam.

With LG TV’s that’s enabling both Simplink and Auto-power-Sync to get things working and ensuring the Beam and nothing else is connected to the TV’s HDMI-ARC port (usually HDMI-2)

The Apple TV HDMI-CEC feature can be switched off in its settings (I believe it’s in ‘Remotes and Devices/Home Cinema Control’

Hope that Assists.

Hey ken,

 

thanks again for trying to help me. I really appreciate it.  
 

the lg tv has those settings on (simplink and auto power sync).  However, I’ve noticed that when the problem occurs (before I reset it) the lg tv has the sound to internal tv speaker on so it’s almost like the sonos beam and tv arent always locked in with each other.  I don’t know if it’s an appleTV setting, an lg tv setting, or a sonos setting but it’s very frustrating to say the least. Is there anyway I can provide you a diagnostic report when it happens again?  Would that help?

 

thanks again for all help. 
 

cheers

Ruchacha

Only Sonos support staff can see/read your diagnostic reports - please note that the Staff here are clearly marked by their Sonos profile image. I’m just a Sonos user, like yourself, so can’t read your diagnostic.
 

I will suggest however that the next time you encounter the issue, then immediately submit a further diagnostic report and post it’s reference number back here in this thread ...and then contact/chat to the Sonos Support Staff via this LINK to see what they can ascertain from the report.

I hope that helps.👍

I have a similar issue with a Beam, LG OLED TV, and FireTV. I worked around it by having a HDMI switch connected to the LG TV rather than having the FireTV connected directly to the LG TV. The only thing connected to the TV is the Beam and the switch.

Ken and pasc,

 

thanks for your continued help with my tv sound issues.  I think I found another piece of critical information needed to help diagnose what the real underlying problem might be.  This goes back to kens home theater hdmi cec attempt.   I noticed that when the tv turns on and the sound is coming out the tv speakers , that I go into appleTV settings , remotes and devices and it seems to trigger the appleTV to flip over to hdmi cec.  It’s odd.  I literally go to that screen and as soon as it appears, I see the appleTV auto update that setting and then it comes through the sonos beam.  So the issue is how to get appleTV to “remember” or stay on this setting without having to manually go to that screen and have it trigger over. 
 

any thoughts/ideas? 
 

I can create and post a YouTube video of it if you think it will help.  
 

let me know

 

thanks again!

Check the TV for updates. It sounds like the CEC hub software is misbehaving. I’d also double check for the latest update from Apple. And, of course, the Sonos, but I honestly don’t think this issue is coming from there. 

Then try unplugging the TV from the wall for five minutes, forcing the TV’s software to reload when it gets plugged back in. Do the same thing for the Apple TV.

I’d be tempted to remove any HDMI cables connected to the TV other than the Apple TV and the Beam, to ensure there isn’t a non compliant CEC device connected that is interfering with the hub to properly ‘read’ the Apple TV and Beam’s connection. You could add them back, one device at a time, to see if this odd behavior continues. 

Ultimately, if it continues to misbehave, I’d contact LG’s customer support folks. 

Ruchacha,

That same screen ‘remotes & devices’ refreshes for me too when I first go into it and then stays there after that initial refresh - so I’m not sure it’s that.

Two things to try (perhaps) - Just try switching off the TV control at the bottom of that screen but it means controlling the ATV with its own remote.. or have a look in "Settings/Airplay & Homekit” and remove the ‘room’ from the available room option (if any room is showing). See if that resolves your issue - you can always change them back, if no joy.

I have exactly the same problem. LG CX 65, Sonos Beam, Apple TV 4K.

HDMI CEC enabled for Beam and Apple TV.

The audio doesn’t work *sometimes* after I switch on.

Switching Apple TV on also switches the TV on, that works fine. The Beam seems to be powered on all the time, but sometimes after a few minutes when it doesn’t work I can go into the menu on Apple TV and switch the audio to the Beam instead of TV speakers, then it starts to work. Although in some apps there is still a delay between a video starting and audio playing through the Beam.

I used to connect the Beam through an optical cable, it always worked fine. I could do that again but because Apple TV doesn’t have internal volume control, I don’t want to have to use a separate remote for volume.

Not sure what else to do.

 

I’d be awfully tempted to check for an update to the TV’s OS from LG. It sounds like it’s not allowing the CEC connection across HDMI to activate all the time. And I’d also be tempted to pull out the HDMI cables, and then put them back in. Sometimes a reseat fixes a bad pin connection. But if it is a bad HDMI connection, it’s anyone’s bet as to whether that’s in the TV, the cable, or the Beam. Not sure I know how to check that, other than just swapping the cable out, but that doesn’t really prove anything, although it may fix the issue.

 

Reply