Sonos Beam and Bose QC headphones in Samsung TV


Userlevel 3
Badge +2
I have the Beam working via HDMI on my TV and when I switch in my headphones to connect to the TV via Bluetooth, it works initially and TV says disconnecting Anynet+ device (the Beam) but then it seems to immediately reconnect the Beam and so not allowing me to switch to the Bluetooth headphones. Any ideas on how to get this working without having to switch Anynet off and on in the menu all the time? My Samsung is a 2015 UHD model.

130 replies

I have Samsumg Q950 82” TV with Beam and also Sony XM3 headphones. I find it completely crazy that Sonos does not follow standard CEC protocol and requires me to use separate Bluetooth transmitter for headphones (connected to optical out) because of this stupid “feature”.

Sonos, please disable stealing sound output from TV every 5 seconds. Modern TV:s have good output selection features built in, there is no good reason to override this.
At least let users choose if they need this or not.

 

 

 

Adding my voice to this. Come on Patrick- please sort it out!! Can’t be that difficult to fix surely. 

Signing on to add my frustration to this issue. 
 

Please no cockamamie suggestions of buying yet another device for some mystic audio fidelity that I'm missing out on. I like my audio down and dirty, thank you. If I wanted to buy another device to slap onto my entertainment area I'd buy a fancy gumball machine. Or one of those cute little Buddha statues that doubles as a WiFi hotspot.

Sonos if some fancy millionaire can get a bunch of Americans into space you can fix this. I believe in you. 

If unplugging/cutting electricity kills a Sonos product, then that’s what I’d call real product quality… Do you have it on 24/7/365 then?

Not 365, but the units are usually powered all the time the house is occupied. They’re designed to be. 

As for ‘product quality’ it’s well known that, of the various factors which determine the lifespan of any electronic component, powering-cycling -- thereby administering repeated electrical and thermal shocks -- is by far the most significant. Typically when a device eventually fails it’s at power-on time.

 

The fastest solution is to simply unplug the Beam and then select your BT headphones from the menu.

Actually the fastest solution is to mute the Beam and power on an optical-connected Bluetooth transmitter. Ideally one with a higher quality and lower latency than the BT codecs typically found in a TV.

Also, repeatedly power-cycling the Beam could reduce its lifespan.

 

@ratty:

True, if you happen/want to own yet another device.

 

If unplugging/cutting electricity kills a Sonos product, then that’s what I’d call real product quality… Do you have it on 24/7/365 then?

 

Thanks again for your valued input though.

The fastest solution is to simply unplug the Beam and then select your BT headphones from the menu.

Actually the fastest solution is to mute the Beam and power on an optical-connected Bluetooth transmitter. Ideally one with a higher quality and lower latency than the BT codecs typically found in a TV.

Also, repeatedly power-cycling the Beam could reduce its lifespan.

My Setup: 2019 Samsung TV w/ smart remote + Sonos Beam + Sennheiser 185 wireless headphones

Problem: I can't quickly turn off the sound to my Sonos Beam so I can listen to the TV privately using wireless headphones so the rest of my family can sleep.

Methods Tried and Passed On:
I tried most of them... optical switch w/ remote, wireless on/off receptacle plug w/remote, Bluetooth transmitter, etc. I was able to get these various methods to work but they were too cumbersome, too many buttons, and/or took too much time.


BEST SOLUTION FOR MY SETUP

To Turn OFF Sonos Beam and Turn ON Wireless Headphones - Follow Two Steps:
Step One: Using your Samsung smart remote, press the microphone button** and say the following exactly: "Settings Any Net Plus". Say it slowly like a robot. Brief pause between "settings" and "any net plus". It will bring up the correct settings menu. Press select (that's the center round button inside the round navigation ring). Done. You have just turned off the HDMI ARC connection with the Sonos Beam.

Step Two: Using your Samsung smart remote, press the microphone button and say the following exactly like a slow robot: "Sound Select Optical". Immediately upon hearing the verbal command the Samsung TV will makes the switch for you. No button to push. You are done! Sound will now go only to your wireless headphones and sound to your TV speakers is turned off.

**Note: To use the Samsung's smart remote verbal commands button you can't be inside Netflix or Amazon Prime or similar apps. So before you do step one and step two above do this: press the home button on the remote (the button that has a house on it!) and then toggle to the left and select the app tile that looks like a white TV with light blue background. When in this app, you can give verbal commands with no problems. This is the fastest way to get out of an app that won't take verbal commands and into an app that allows for verbal commands.


To Turn Back ON the Sonos Beam - Only One Step:
Step One: Using your Samsung smart remote, press the microphone button and say the following exactly: "Settings Any Net Plus". Say it slowly like a robot. It will bring up the correct settings menu. Press select (that's the center round button inside the round navigation ring). Done. That's it. You have just turned on the HDMI ARC connection with the Sonos Beam. Sonos Beam is up and running automatically.

Commentary
With this method you don't have to buy any additional gadgets. For fun I timed how long this method takes. It takes less than 18 seconds to turn Sonos Beam off and your headphones on and less than 10 seconds to turn the Sonos Beam back on. Hopefully this will help those of you looking for a solution with a setup like mine. Headphone Auto Detect it is not. One button press solution it isn't either. That said, this is a fast and user friendly solution that I can do on a regular basis without having to hit my head against a wall and laugh at the irony of paying extra for an intuitive, user friendly tv/sound system that won't support how I use my TV. I have used this method for a few weeks now and I can report that I am happy enough and there is enough distance between my discovery of this lack of functionality and this workable solution that I can get back to enjoying my Sonos Beam purchase without giving it the evil eye and mumbling under my breath.

The fastest solution is to simply unplug the Beam and then select your BT headphones from the menu. Once done, plug the Beam back in, it’ll steal the audio from the headphones automatically.

 

How bad is the Sonos user experience if they couldn’t fix this simple issue in two years via a firmware update once they were notified?

how would I change the volume of my AirPods if they were connected to one? 

Replace them with conventional earbuds/phones that let you change volume by touch instead of having to shout at Siri? 

Hi, same here, I am writing since I just found the same problem.  Just bought an LG C9 OLED and was super excited that I could simply use my AirPods, but this problem arose,  Saw the solution about a Bluetooth transmitter but how would I change the volume of my AirPods if they were connected to one? 

hi everyone, i am dumbfounded that a fix is still not available...

On my Samsung TV, I will run into the issue with the HDMI “claiming” the audio output back even when I select digital optical output if I was just to connect a BT transmitter via the digital optical output and keep the beam connected via HDMI (since optical digital is not “always on”). 

Hmm. I guess not all Samsung TVs are born equal then. 

So, I will need to drive both the beam and the BT transmitter from the digital output of TV (and not use HDMI at all) either via splitter or daisy chaining beam from Avantree BT transmitter. This in turn leads to some other inconveniences (eg controlling volumes of the BT output and the beam, using iPhone/sonos app to mute beam etc) 

You can train a Beam to respond to an IR TV remote. On the BT front hopefully you’d have volume control at the headphones themselves. 

Same problem as everyone and very annoying - come on Sonos - sort a fix out please!

This thread has been running since 18 July 2018. I’m sure if the ‘fix’ was on Sonos’ side, as opposed to the TV, they could have done something about it by now. 

I’ll repeat the same advice I’ve offered a number of times: get a little Bluetooth transmitter and connect it to the TV’s optical output. The chances are that, subject to headphone compatibility, you’ll end up with a better solution, in terms of quality and/or latency, than using the TV’s built-in Bluetooth. 

Hi ratty. Your advice on this is appreciated, however I don’t believe it is quite as straightforward as you suggest (or I am missing something) .  On my Samsung TV, I will run into the issue with the HDMI “claiming” the audio output back even when I select digital optical output if I was just to connect a BT transmitter via the digital optical output and keep the beam connected via HDMI (since optical digital is not “always on”). So, I will need to drive both the beam and the BT transmitter from the digital output of TV (and not use HDMI at all) either via splitter or daisy chaining beam from Avantree BT transmitter. This in turn leads to some other inconveniences (eg controlling volumes of the BT output and the beam, using iPhone/sonos app to mute beam etc)  ; however I will probably be pursuing that approach.

Same problem as everyone and very annoying - come on Sonos - sort a fix out please!

This thread has been running since 18 July 2018. I’m sure if the ‘fix’ was on Sonos’ side, as opposed to the TV, they could have done something about it by now. 

I’ll repeat the same advice I’ve offered a number of times: get a little Bluetooth transmitter and connect it to the TV’s optical output. The chances are that, subject to headphone compatibility, you’ll end up with a better solution, in terms of quality and/or latency, than using the TV’s built-in Bluetooth. 

Same problem as everyone and very annoying - come on Sonos - sort a fix out please!

As long as it’s connected through HDMI-ARC and you have “AnyNet CEC” enabled in the TV settings, the beam will continue to “reclaim” the autio output of your TV.

The solution with something_else_than_the_beam connected to the TV digital-audio-out must work in combination with disabling AnyNet (ant thus leaving the beam connected to the TV’s HDMI) and only enabling it when you want TV Audio on the Beam (eg. watching a movie/concert :) )

Thanks for the response. However, I would like to make this as easy as possible to use since my wife will be using it and this may be a little beyond her patience level :).  I think I will go the optical digital output route - ie not use HDMI ARC (my understanding is that audio quality will not be affected since the beam doesn’t support the higher def codecs anyway) and I will daisy chain or split the digital optical to the beam and BT transmitter.

As long as it’s connected through HDMI-ARC and you have “AnyNet CEC” enabled in the TV settings, the beam will continue to “reclaim” the autio output of your TV.

The solution with something_else_than_the_beam connected to the TV digital-audio-out must work in combination with disabling AnyNet (ant thus leaving the beam connected to the TV’s HDMI) and only enabling it when you want TV Audio on the Beam (eg. watching a movie/concert :) )

Like others, I have the same challenge with my Samsung Q70R TV and Beam. I was going to go with the approach recommended by ratty, viz purchase a BT transmitter (Aventree) and connect it to TV optical digital audio output but cannot determine whether this output is active all the time or not. It would appear from the settings on TV that I have to explicitly switch to this (ie switch away from the HDMI selection to the optical for audio output). When I have done that on the Samsung, the HDMI “reclaims” the output audio signal after a couple of seconds (just as it does when I tried having BT ear buds connected).   So if I do go the BT transmitter route, does this mean I am going to have to either split the optical audio output from TV to go to the BT transmitter and in parallel the Beam, or daisy chain (if there is a BT transmitter which supports that)  ??.

 

Actually, Sonos has implemented the Beam and Amp to follow the HDMI-ARC specification, a subset of HDMI-CEC, set forth by the organization responsible for publishing the spec, like all other manufacturers who implement devices that use this feature. 

You can do further research starting here, and then move on to the actual specs depending on your level of interest and electrical engineering knowledge. 
 

 

For this purpose guiding the sound to the Beam is not “stealing” but the way it is supposed to work…….

Actually, it’s the way it was designed to work, by SONOS.

Which doesn’t necessary make it right or smart…

Userlevel 6
Badge +14

A solution to the headphone issue would be OK. But please don’t mess with the HDMI function that automatically turns the sound to the Beam. For this purpose guiding the sound to the Beam is not “stealing” but the way it is supposed to work…….

 

I have difficulty understanding why you would buy an expensive speaker and then would want to use the low rent TV speakers, even for news .

Hi everybody,

My new SONOS Beam arrived yesterday, and I’m encountering the same issue like everybody else here: when connected through the ARC, the beam “steals” the audio from the TV (Samsung UE40F6200) after ~2 seconds; disabling AnyNet+ in the TV fixes the problem, but as many have said before me, this is in no way a proper & desirable approach...

As happy as I am about the sound quality of the Beam, it’s a huge & unexpected disappointment that SONOS did nothing to address this (clearly annoying for everybody) issue during all this time…

I’m still hoping…

Cheers !

 

PS. the root of this problem does not involve headphones at all.

Sometimes one might simply wish to use the normal built-in TV speakers (eg. for watching news), and you cannot do that. In my case, if I switch it to “speakers”, it stays like that for ~2 seconds, and then the SONOS kicks in and “steals” the sound.

No, the Beam is shipped with an optical to HDMI-ARC adapter, so that those who don’t have an appropriate HDMI connection can still use the device. 

+1 exact same issue. 
 

LG Smart TV OLED55C8P

Sonos Beam and speakers and sub

Bose QC 35ii Headset

 

Some were suggesting to use the Optical output but I remember in my own case, the beam will only work with ARC and not the Optical.

I will try the HDMI disconnect method and bookmark this topic.

 

Didn’t I respond to you in another thread a minute or two ago?

Connect either your Beam or your headphones to the optical output on your TV. 

Just purchased a new Samsung TV today and a Sonos beam+sub and now have this issue when connecting my Bose Bluetooth headset. The HDMI-CEC workaround is not good/nice, so I really hope that Sonos can fix this issue somehow.

Reply