Answered

Sonos Arc & Vizio TV - audio dropouts

  • 12 January 2021
  • 3 replies
  • 58 views

Having issues with my Vizio M507-G1 and just-purchased Sonos Arc and Sub Gen 3. Everything is up-to-date.

Essentially, when I configure the Digital Audio Out to anything but PCM (which is just stereo...), the audio breaks up and there is a lag I cannot fix. Didn’t do this with previous Vizio soundbar.

Does anyone have a similar setup with this all working how it should that can share their settings, please. My current ones are below:

 

Speakers: Off

Volume Control Display: On

Surround Sound: Off

Volume Leveling: Off

Balance: 0

Lip Sync: 0

Digital Audio Out: PCM

Analog Audio Out: Variable


Thanks in advance. 

icon

Best answer by GuitarSuperstar 12 January 2021, 21:12

Set Digital Auto Out to Auto and unplug your TV and Arc for a couple minutes and see if that helps.

Also be sure the HDMI cable is connected to your TV’s HDMI ARC port which I believe is HDMI 1.

Is CEC Enabled or set to ARC Only?

View original

3 replies

Userlevel 7
Badge +17

Set Digital Auto Out to Auto and unplug your TV and Arc for a couple minutes and see if that helps.

Also be sure the HDMI cable is connected to your TV’s HDMI ARC port which I believe is HDMI 1.

Is CEC Enabled or set to ARC Only?

Thank you! I’ll definitely give that a shot and hope it works. I wish I had stuck with Sony when “upgrading” TVs as I feel like this Vizio has been pretty problematic occasionally.

 

CEC is set to “Enabled” as I have an Apple TV connected also. 

Userlevel 7
Badge +17

This webpage might be helpful too:
https://support.vizio.com/s/article/What-is-HDMI-1-4-ARC-Audio-Return-Channel-and-how-do-I-use-it?language=en_US

Reply