Answered

Sonos ARC : sound from Apple TV 4k isn't working properly

  • 28 September 2021
  • 3 replies
  • 192 views

Badge +1

System: LG UHD display, Apple TV 4K (A12 Bionic version), Sonos ARC SL/Sub/Play1 home theater

Problem: volume control stopped working / no audio output

Several days ago I noticed an issue with my Sonos home theater - no sound output in Prime videos. Clicking the volume control on the aTV remote brought up a grey circle with a slash on the right edge of the screen. I was still able to get video out of locally served movies as well as the Hulu app. Later in the day, the Hulu sound quit, followed by Apple Trailers. Now I have no sound at all, even from the aTV click and window system sounds. 

I discovered that none of the apps on my devices could see the Sonos system (once the Sonos HT was installed I never again used the apps), so I did a WiFi reset as prescribed in the support docs. My apps could then see the system, but the audio was still gone. I reset the remote function and had the app relearn the aTV remote, still nothing but that grey circle with a slash on the right side of the screen. However, I was able to control the volume through the S2 app. 

I then updated the app, and also did the firmware updates on the HT components. Still no audio control via aTV remote. 

 

What is going on with this? Why did the volume turn off selectively and progressively across the Prime and Hulu apps instead of all at once? What is that grey circle with the slash through it? 

 

 

icon

Best answer by Forstal 28 September 2021, 16:49

View original

3 replies

Badge +1

Ok, I think I have figured this out. Almost. 

I decided to try the LG remote, and when I clicked on the volume button I found the same grey circe on the right side of the screen, which meant this was a LG issue and not the aTV or the Arc. I was able to get sound when I switched to “internal speakers” in the LG settings, so that confirmed audio was being passed to the LG display. I switched back to the external audio output and when I did it said that “if ARC HDMI audio output is selected it can be enabled in the Simplink setup” or something like that. 

I found a setting for Simplink that had two options: OFF or HDMI-CEC. It was set for OFF so I switched to the other option. The sound returned, and along with it I got my aTV remote working with the Sonos Arc once again. 

One odd thing happened before the sound issue was completely resolved. Initially, only the Arc was working, no Sub, and I couldn’t hear the satellites. Then those came up again and made a complete system. This is similar to when the sound worked selectively before quitting entirely. How did that happen?

The final question I have is how did the HDMI-CEC setting go to OFF without anyone touching the LG remote? Has anyone here experienced that with their LG display, or any other?

I have experienced similar ‘changes’ to my TV’s setup on rare occasions, when the TV has auto updated its OS without intervention by me. I assume it’s a failure of the QA folks in properly testing the release before it goes live, as it’s only occurred in one release, and not in others. 

Badge +1

I would think the same thing here, but in my case I don’t have my TLG panel connected to my home network.  I don’t have my Oppo on the network either. The only updates that come through for panels are for bug fixes (cross that bridge when I get to it) and adding/deleting services. Since I have an Apple TV 4K there’s no need whatsoever for an update. so all the entertainment stuff and also my new appliances are all kept away from my home network. It prevents conflicts and also checks off some potential security weaknesses. 

 

Reply